Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Flash Communication Server (flashcom) installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
didi666
n00b
n00b


Joined: 09 Sep 2003
Posts: 31
Location: Stuttgart, Germany

PostPosted: Thu Jan 15, 2004 2:03 pm    Post subject: Flash Communication Server (flashcom) installation Reply with quote

I don't have the time for a complete howto, so here is some tips which nevertheless may help you:

1. installFCS only works on specific systems. Instead of getting it to work on gentoo, I just copied+pasted the essential parts out of it into an own script:
look for the line "* Perform installation *", everything underneath should be executed. It only should be necessary to fill the variables with sensible stuff.

2. sensible default examples:
$INSTALL_DIR=/opt/macromedia/fcs
$ADMIN_SERVER_PORT=1111
$FLASHCOM_SERVER_PORT=1935
$CREATE_ETC_MACR_DIR=1
$SERVICES_DIR=/etc/macromedia/fcs/services
$SERVICE_NAME=fcs

3. To get the binaries to run in a recent Gentoo build (gcc >3.0), you need to
Code:
emerge sys-libs/lib-compat

Otherwise you will get the following error:
Code:
libstdc++-libc6.2-2.so.3: cannot open shared object file


Very stupid installer script...
Back to top
View user's profile Send private message
puddpunk
l33t
l33t


Joined: 20 Jul 2002
Posts: 681
Location: New Zealand

PostPosted: Thu Jan 15, 2004 9:40 pm    Post subject: Reply with quote

Thats interesting! A few people I know are interested in running that service. It's a shame about it's binary install script though :(

Cheers,
Chris.
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 497
Location: Maniago, Friûl, Italia

PostPosted: Fri Apr 01, 2005 10:32 am    Post subject: Reply with quote

Hi all!

I patched the FCS installation file to work with Gentoo, you can find it here. Besides excluding the distrocheck at the beginning, I also commented out the part that copies the init scripts into /etc/init.d (those RedHat init scripts won't work on Gentoo anyway).

For the init, I created this init scripts which seems to work quite well. It's my first atempt to write a Gentoo init script however, so any suggestion is welcome. ;-)

Hope this helps somebody!

M.

P.S.: I worked with Macromedia FCS 1.5 r120
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum