Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemen met geluid in 2.4.22-gentoo-r5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Gerbstar
n00b
n00b


Joined: 17 Feb 2003
Posts: 31
Location: Lelystad, Netherlands

PostPosted: Mon Jan 19, 2004 4:58 pm    Post subject: Problemen met geluid in 2.4.22-gentoo-r5 Reply with quote

Sinds ik overgestapt ben op de 2.4.22 kernels krijg ik met geen mogelijkheid meer geluid uit mij boxen. Ik heb een Terratec 512i digital, dus ik gebruik ALSA met fm801.

In de kernel heb ik bij Sound alleen de eerste optie als module gekozen (precies volgens http://www.gentoo.org/doc/en/alsa-guide.xml )

Dan heb ik
Code:
# env ALSA_CARDS='fm801' emerge alsa-driver
gedaan, om ALSA te emergen.

alsa-mixer geeft nog gewoon de oude instellingen weer volgens mij, maar voor de zekerheid heb ik alles ge-unmute. (en op 100 %)

Bij de verschillende 2.4.20-gentoo kernels kreeg ik met een beetje spelen met de instellingen zelfs alle 4 de speakers aan de praat, nu geen enkele meer, wat ik ook probeer.

Ik heb alle stappen van de handleiding al meerdere keren doorlopen met bijna alle 2.4.22-gentoo kernels (r1 t/m r5)

Ik heb op het forum veel gezocht, en veel gevonden over ALSA, maar niets was bruikbaar bij dit probleem (volgens mij)

Hebben meer mensen hier problemen mee? Of weet iemand een mogelijke oplossing?
Back to top
View user's profile Send private message
stevena
n00b
n00b


Joined: 17 Apr 2003
Posts: 50

PostPosted: Mon Jan 19, 2004 5:10 pm    Post subject: Reply with quote

Is waarschijnlijk in orde, maar toch voor de zekerheid.
Staat /usr/src/linux/ naar de sources van je nieuwe kernel gelinkt? Of nog naar je oude?
Back to top
View user's profile Send private message
Gerbstar
n00b
n00b


Joined: 17 Feb 2003
Posts: 31
Location: Lelystad, Netherlands

PostPosted: Mon Jan 19, 2004 5:18 pm    Post subject: Reply with quote

Bedankt voor je reactie, maar daar had ik inderdaad al aan gedacht.

Ik ben ook lid van de audio group in /etc/group

Ik gebruik overigens KDE (maar dat deed ik ook al voor ik een nieuwe kernel installeerde) en het probleem treedt bij alle programma's op (Noatun, XMMS, Kaboodle en ook bij opstarten KDE krijg ik geen geluid)
Back to top
View user's profile Send private message
GuidoJ
Guru
Guru


Joined: 24 Dec 2002
Posts: 444
Location: Netherlands

PostPosted: Mon Jan 19, 2004 7:56 pm    Post subject: Reply with quote

Heel veel mensen klagen over gentoo-sources-2.4.22, hoewel ik daar nooit enig probleem mee had. Tot -r5 dus, en daarin zouden alle problemen zijn opgelost. Misschien was het probleem juist dat ik geen problemen had :roll:
Back to top
View user's profile Send private message
Gerbstar
n00b
n00b


Joined: 17 Feb 2003
Posts: 31
Location: Lelystad, Netherlands

PostPosted: Tue Jan 20, 2004 9:06 am    Post subject: Reply with quote

De aRts Control Tool geeft wel geluidsactiviteit aan als ik een mp3 speel.
In het Sound System - KDE Control Menu op het tabblad Sound I/O stond de Sound I/O methode op Autodetect. Dat heb ik nu gewijzigd in ALSA, maar nu krijg ik de volgende error:
Code:
Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Device or resource busy)
The sound server will continue, using the null output device.


Ik heb het geluid dus nog steeds niet werkende.
Back to top
View user's profile Send private message
stevena
n00b
n00b


Joined: 17 Apr 2003
Posts: 50

PostPosted: Tue Jan 20, 2004 11:47 am    Post subject: Reply with quote

Een paar dingen die je eens kan nakijken:
    Bestaat je geluidsmodule wel? /sbin/modprobe -l
    Is ze geladen? lsmod
    Wat zegt dmesg over je geluidsmodule en alsa?
    Werkt je geluid vanop de commandline? aplay /usr/kde/3.1/share/sounds/pop.wav
Back to top
View user's profile Send private message
Gerbstar
n00b
n00b


Joined: 17 Feb 2003
Posts: 31
Location: Lelystad, Netherlands

PostPosted: Tue Jan 20, 2004 4:45 pm    Post subject: Reply with quote

Hieronder alle informatie die je vroeg. Ik zie niet echt een fout. Wel zie ik dat ie problemen heeft met een NULL pointer op een virtual adres, dat aplay geen geluid geeft en ik zie bij dmesg niets over sound staan.
Code:
bash-2.05b# aplay /usr/kde/3.1/share/sounds/pop.wav
Playing WAVE '/usr/kde/3.1/share/sounds/pop.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Mono
bash-2.05b# /sbin/modprobe -l
/lib/modules/2.4.22-gentoo-r5/kernel/drivers/net/dummy.o
/lib/modules/2.4.22-gentoo-r5/kernel/drivers/sound/soundcore.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/oss/snd-mixer-oss.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/oss/snd-pcm-oss.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/seq/instr/snd-ainstr-fm.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/seq/oss/snd-seq-oss.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/seq/snd-seq-device.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/seq/snd-seq-dummy.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/seq/snd-seq-instr.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/seq/snd-seq-midi-emul.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/seq/snd-seq-midi-event.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/seq/snd-seq-midi.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/seq/snd-seq.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/snd-hwdep.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/snd-page-alloc.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/snd-pcm.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/snd-rawmidi.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/snd-timer.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/acore/snd.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/drivers/mpu401/snd-mpu401-uart.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/drivers/opl3/snd-opl3-lib.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/drivers/opl3/snd-opl3-synth.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/pci/ac97/snd-ac97-codec.o
/lib/modules/2.4.22-gentoo-r5/kernel/sound/pci/snd-fm801.o
/lib/modules/2.4.22-gentoo-r5/misc/svgalib_helper.o
/lib/modules/2.4.22-gentoo-r5/video/nvidia.o
bash-2.05b# lsmod
Module                  Size  Used by    Tainted: P
nvidia               1630272  11  (autoclean)
snd-pcm-oss            38788   0
snd-mixer-oss          13200   0  [snd-pcm-oss]
snd-seq-midi            3776   0  (autoclean) (unused)
snd-opl3-synth          9608   0  (autoclean) (unused)
snd-seq-instr           5168   0  (autoclean) [snd-opl3-synth]
snd-seq-midi-emul       5008   0  (autoclean) [snd-opl3-synth]
snd-ainstr-fm           1188   0  (autoclean) [snd-opl3-synth]
snd-fm801               8420   0  (autoclean)
snd-mpu401-uart         3392   0  (autoclean) [snd-fm801]
snd-rawmidi            13504   0  (autoclean) [snd-seq-midi snd-mpu401-uart]
snd-pcm                62020   0  (autoclean) [snd-pcm-oss snd-fm801]
snd-page-alloc          6100   0  (autoclean) [snd-pcm]
snd-opl3-lib            6212   0  (autoclean) [snd-opl3-synth snd-fm801]
snd-hwdep               4640   0  (autoclean) [snd-opl3-lib]
snd-ac97-codec         42712   0  (autoclean) [snd-fm801]
snd-seq-oss            26688   0  (unused)
snd-seq-midi-event      3552   0  [snd-seq-midi snd-seq-oss]
snd-seq                38064   2  [snd-seq-midi snd-opl3-synth snd-seq-instr snd-seq-midi-emul snd-seq-oss snd-seq-midi-event]
snd-timer              14500   0  [snd-pcm snd-opl3-lib snd-seq]
snd-seq-device          4176   0  [snd-seq-midi snd-opl3-synth snd-rawmidi snd-opl3-lib snd-seq-oss snd-seq]
snd                    32900   0  [snd-pcm-oss snd-mixer-oss snd-seq-midi snd-opl3-synth snd-seq-instr snd-fm801 snd-mpu401-uart snd-rawmidi snd-pcm snd-opl3-lib snd-hwdep snd-ac97-codec snd-seq-oss snd-seq-midi-event snd-seq snd-timer snd-seq-device]
soundcore               3972   8  [snd]
bash-2.05b# dmesg
Linux version 2.4.22-gentoo-r5 (root@tjeenkwillink.kabel.utwente.nl) (gcc versie 3.3.2 20031022 (Gentoo Linux 3.3.2-r2, propolice)) #1 wo jan 14 22:42:25 Local time zone must be set--see zic manua
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000027ff0000 (usable)
 BIOS-e820: 0000000027ff0000 - 0000000027ff3000 (ACPI NVS)
 BIOS-e820: 0000000027ff3000 - 0000000028000000 (ACPI data)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
639MB LOWMEM available.
ACPI: have wakeup address 0xc0001000
On node 0 totalpages: 163824
zone(0): 4096 pages.
zone(1): 159728 pages.
zone(2): 0 pages.
ACPI: RSDP (v000 MSISYS                                    ) @ 0x000f6c90
ACPI: RSDT (v001 MSISYS MSI ACPI 0x42302e31 AWRD 0x00000000) @ 0x27ff3000
ACPI: FADT (v001 MSISYS MSI ACPI 0x42302e31 AWRD 0x00000000) @ 0x27ff3040
ACPI: DSDT (v001 MSISYS MSI ACPI 0x00001000 MSFT 0x0100000c) @ 0x00000000
Kernel command line: root=/dev/hdb3 acpi=force
Initializing CPU#0
Detected 666.744 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 1327.10 BogoMIPS
Memory: 645140k/655296k available (1722k kernel code, 9772k reserved, 299k data, 116k init, 0k highmem)
Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
Inode cache hash table entries: 65536 (order: 7, 524288 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 65536 (order: 6, 262144 bytes)
Page-cache hash table entries: 262144 (order: 8, 1048576 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: 0383f9ff 00000000 00000000 00000000
CPU:             Common caps: 0383f9ff 00000000 00000000 00000000
CPU: Intel Pentium III (Coppermine) stepping 01
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
ACPI: Subsystem revision 20031002
PCI: PCI BIOS revision 2.10 entry at 0xfb090, last bus=1
PCI: Using configuration type 1
ACPI: IRQ9 SCI: Level Trigger.
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: System [ACPI] (supports S0 S1 S4bios S4 S5)
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 7 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 5 6 7 10 11 *12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 *5 6 7 10 11 12 14 15)
PCI: Probing PCI hardware
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 5
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 11
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 12
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 10
PCI: Using ACPI for IRQ routing
PCI: if you experience problems, try using option 'pci=noacpi' or even 'acpi=off'
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Journalled Block Device driver loaded
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
NTFS driver 2.1.4b [Flags: R/O].
Detected PS/2 Mouse Port.
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
8139too Fast Ethernet driver 0.9.26
eth0: RealTek RTL8139 Fast Ethernet at 0xe8808000, 00:10:a7:04:84:4b, IRQ 11
eth0:  Identified 8139 chip type 'RTL-8139B'
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 564M
agpgart: Detected Via Apollo Pro chipset
agpgart: AGP aperture is 64M @ 0xd8000000
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 00:07.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt82c686a (rev 1b) IDE UDMA66 controller on pci00:07.1
    ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdc:DMA, hdd:DMA
hda: WDC WD800JB-00CRA1, ATA DISK drive
hdb: ST320423A, ATA DISK drive
blk: queue c0171c20, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c0171d5c, I/O limit 4095Mb (mask 0xffffffff)
hdc: LTN403L, ATAPI CD/DVD-ROM drive
hdd: AOPEN CD-RW CRW5224 1.06 20030129, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: 156301488 sectors (80026 MB) w/8192KiB Cache, CHS=9729/255/63, UDMA(66)
hdb: attached ide-disk driver.
hdb: 40011300 sectors (20485 MB) w/512KiB Cache, CHS=2490/255/63, UDMA(66)
hdc: attached ide-cdrom driver.
hdc: ATAPI 40X CD-ROM drive, 120kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
hdd: attached ide-cdrom driver.
hdd: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 >
 /dev/ide/host0/bus0/target1/lun0: p1 p2 p3 p4
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
usb.c: registered new driver hub
host/uhci.c: USB Universal Host Controller Interface driver v1.1
host/uhci.c: USB UHCI at I/O 0xd800, IRQ 5
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 8192 buckets, 64Kbytes
TCP: Hash tables configured (established 262144 bind 65536)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
hub.c: new USB device 00:07.3-2, assigned address 2
input: USB HID v1.10 Mouse [Microsoft Microsoft Wireless Intellimouse Explorer® 1.0A] on usb1:2.0
kjournald starting.  Commit interval 5 seconds
EXT3-fs: ide0(3,67): orphan cleanup on readonly fs
ext3_orphan_cleanup: deleting unreferenced inode 613769
ext3_orphan_cleanup: deleting unreferenced inode 613770
ext3_orphan_cleanup: deleting unreferenced inode 613771
ext3_orphan_cleanup: deleting unreferenced inode 613772
ext3_orphan_cleanup: deleting unreferenced inode 614498
ext3_orphan_cleanup: deleting unreferenced inode 1885519
EXT3-fs: ide0(3,67): 6 orphan inodes deleted
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 116k freed
Adding Swap: 481940k swap-space (priority -1)
EXT3 FS 2.4-0.9.19+htree+orlov, 19 August 2002 on ide0(3,67), internal journal
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS 2.4-0.9.19+htree+orlov, 19 August 2002 on ide0(3,68), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Unable to handle kernel NULL pointer dereference at virtual address 00000108
 printing eip:
c01eff53
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c01eff53>]    Not tainted
EFLAGS: 00010246
eax: 00000108   ebx: 00000000   ecx: 00001148   edx: 00000000
esi: 000000c8   edi: 00000016   ebp: 000003ff   esp: c339bf08
ds: 0018   es: 0018   ss: 0018
Process ps (pid: 597, stackpage=c339b000)
Stack: c01565f4 c01f0215 00000108 c01565f4 00000000 ffffffeb 00000001 c339bf74
       c01d519f c37e0400 00000018 c339bf7c 000003ff 00000000 c339bf80 c37d8000
       c339bf80 000003ff c37d8000 000003ff c01edf01 c37d8000 c339bf80 00000000
Call Trace:    [<c01f0215>] [<c01d519f>] [<c01edf01>] [<c01c9823>] [<c0197293>]

Code: 8b 08 89 c8 c1 e8 1f 31 d0 83 e0 01 01 c2 89 d0 31 d2 0f a4
 <1>Unable to handle kernel NULL pointer dereference at virtual address 00000108
 printing eip:
c01eff53
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c01eff53>]    Not tainted
EFLAGS: 00010246
eax: 00000108   ebx: 00000000   ecx: 0000114a   edx: 00000000
esi: 000000c8   edi: 00000016   ebp: 000003ff   esp: c32abf08
ds: 0018   es: 0018   ss: 0018
Process ps (pid: 600, stackpage=c32ab000)
Stack: c01565f4 c01f0215 00000108 c01565f4 00000000 ffffffeb 00000001 c32abf74
       c01d519f c37e0400 0000001a c32abf7c 000003ff 00000000 c32abf80 c348a000
       c32abf80 000003ff c348a000 000003ff c01edf01 c348a000 c32abf80 00000000
Call Trace:    [<c01f0215>] [<c01d519f>] [<c01edf01>] [<c01c9823>] [<c0197293>]

Code: 8b 08 89 c8 c1 e8 1f 31 d0 83 e0 01 01 c2 89 d0 31 d2 0f a4
 <1>Unable to handle kernel NULL pointer dereference at virtual address 00000108
 printing eip:
c01eff53
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c01eff53>]    Not tainted
EFLAGS: 00010246
eax: 00000108   ebx: 00000000   ecx: 0000114b   edx: 00000000
esi: 000000c8   edi: 00000016   ebp: 000003ff   esp: c32abf08
ds: 0018   es: 0018   ss: 0018
Process ps (pid: 602, stackpage=c32ab000)
Stack: c01565f4 c01f0215 00000108 c01565f4 00000000 ffffffeb 00000001 c32abf74
       c01d519f c37e0400 0000001b c32abf7c 000003ff 00000000 c32abf80 c34a7000
       c32abf80 000003ff c34a7000 000003ff c01edf01 c34a7000 c32abf80 00000000
Call Trace:    [<c01f0215>] [<c01d519f>] [<c01edf01>] [<c01c9823>] [<c0197293>]

Code: 8b 08 89 c8 c1 e8 1f 31 d0 83 e0 01 01 c2 89 d0 31 d2 0f a4
 <1>Unable to handle kernel NULL pointer dereference at virtual address 00000108
 printing eip:
c01eff53
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c01eff53>]    Not tainted
EFLAGS: 00010246
eax: 00000108   ebx: 00000000   ecx: 0000114d   edx: 00000000
esi: 000000c8   edi: 00000016   ebp: 000003ff   esp: c32a9f08
ds: 0018   es: 0018   ss: 0018
Process ps (pid: 604, stackpage=c32a9000)
Stack: c01565f4 c01f0215 00000108 c01565f4 00000000 ffffffeb 00000001 c32a9f74
       c01d519f c37e0400 0000001d c32a9f7c 000003ff 00000000 c32a9f80 c3385000
       c32a9f80 000003ff c3385000 000003ff c01edf01 c3385000 c32a9f80 00000000
Call Trace:    [<c01f0215>] [<c01d519f>] [<c01edf01>] [<c01c9823>] [<c0197293>]

Code: 8b 08 89 c8 c1 e8 1f 31 d0 83 e0 01 01 c2 89 d0 31 d2 0f a4
 <1>Unable to handle kernel NULL pointer dereference at virtual address 00000108
 printing eip:
c01eff53
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c01eff53>]    Not tainted
EFLAGS: 00010246
eax: 00000108   ebx: 00000000   ecx: 0000114f   edx: 00000000
esi: 000000c8   edi: 00000016   ebp: 000003ff   esp: c348ff08
ds: 0018   es: 0018   ss: 0018
Process ps (pid: 607, stackpage=c348f000)
Stack: c01565f4 c01f0215 00000108 c01565f4 00000000 ffffffeb 00000001 c348ff74
       c01d519f c37e0400 0000001f c348ff7c 000003ff 00000000 c348ff80 c37d1000
       c348ff80 000003ff c37d1000 000003ff c01edf01 c37d1000 c348ff80 00000000
Call Trace:    [<c01f0215>] [<c01d519f>] [<c01edf01>] [<c01c9823>] [<c0197293>]

Code: 8b 08 89 c8 c1 e8 1f 31 d0 83 e0 01 01 c2 89 d0 31 d2 0f a4
 <1>Unable to handle kernel NULL pointer dereference at virtual address 00000108
 printing eip:
c01eff53
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c01eff53>]    Not tainted
EFLAGS: 00010246
eax: 00000108   ebx: 00000000   ecx: 00001150   edx: 00000000
esi: 000000c8   edi: 00000016   ebp: 000003ff   esp: c32abf08
ds: 0018   es: 0018   ss: 0018
Process ps (pid: 609, stackpage=c32ab000)
Stack: c01565f4 c01f0215 00000108 c01565f4 00000000 ffffffeb 00000001 c32abf74
       c01d519f c37e0400 00000020 c32abf7c 000003ff 00000000 c32abf80 c349d000
       c32abf80 000003ff c349d000 000003ff c01edf01 c349d000 c32abf80 00000000
Call Trace:    [<c01f0215>] [<c01d519f>] [<c01edf01>] [<c01c9823>] [<c0197293>]

Code: 8b 08 89 c8 c1 e8 1f 31 d0 83 e0 01 01 c2 89 d0 31 d2 0f a4
 <1>Unable to handle kernel NULL pointer dereference at virtual address 00000108
 printing eip:
c01eff53
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c01eff53>]    Not tainted
EFLAGS: 00010246
eax: 00000108   ebx: 00000000   ecx: 00001152   edx: 00000000
esi: 000000c8   edi: 00000016   ebp: 000003ff   esp: c349ff08
ds: 0018   es: 0018   ss: 0018
Process ps (pid: 612, stackpage=c349f000)
Stack: c01565f4 c01f0215 00000108 c01565f4 00000000 ffffffeb 00000001 c349ff74
       c01d519f c37e0400 00000022 c349ff7c 000003ff 00000000 c349ff80 c349b000
       c349ff80 000003ff c349b000 000003ff c01edf01 c349b000 c349ff80 00000000
Call Trace:    [<c01f0215>] [<c01d519f>] [<c01edf01>] [<c01c9823>] [<c0197293>]

Code: 8b 08 89 c8 c1 e8 1f 31 d0 83 e0 01 01 c2 89 d0 31 d2 0f a4
 <1>Unable to handle kernel NULL pointer dereference at virtual address 00000108
 printing eip:
c01eff53
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c01eff53>]    Not tainted
EFLAGS: 00010246
eax: 00000108   ebx: 00000000   ecx: 0000143b   edx: 00000000
esi: 000000c8   edi: 00000019   ebp: 000003ff   esp: c2aa1f08
ds: 0018   es: 0018   ss: 0018
Process ps (pid: 844, stackpage=c2aa1000)
Stack: c01565f4 c01f0215 00000108 c01565f4 00000000 ffffffeb 00000001 c2aa1f74
       c01d519f c37e0400 000000b3 c2aa1f7c 000003ff 00000000 c2aa1f80 c34be000
       c2aa1f80 000003ff c34be000 000003ff c01edf01 c34be000 c2aa1f80 00000000
Call Trace:    [<c01f0215>] [<c01d519f>] [<c01edf01>] [<c01c9823>] [<c0197293>]

Code: 8b 08 89 c8 c1 e8 1f 31 d0 83 e0 01 01 c2 89 d0 31 d2 0f a4
 <6>eth0: Setting 100mbps full-duplex based on auto-negotiated partner ability 45e1.
Unable to handle kernel NULL pointer dereference at virtual address 00000108
 printing eip:
c01eff53
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c01eff53>]    Not tainted
EFLAGS: 00010246
eax: 00000108   ebx: 00000000   ecx: 000018e0   edx: 00000000
esi: 000000c8   edi: 0000001f   ebp: 000003ff   esp: c2a91f08
ds: 0018   es: 0018   ss: 0018
Process ps (pid: 1259, stackpage=c2a91000)
Stack: c01565f4 c01f0215 00000108 c01565f4 00000000 ffffffeb 00000001 c2a91f74
       c01d519f c37e0400 000000a8 c2a91f7c 000003ff 00000000 c2a91f80 c3756000
       c2a91f80 000003ff c3756000 000003ff c01edf01 c3756000 c2a91f80 00000000
Call Trace:    [<c01f0215>] [<c01d519f>] [<c01edf01>] [<c01c9823>] [<c0197293>]

Code: 8b 08 89 c8 c1 e8 1f 31 d0 83 e0 01 01 c2 89 d0 31 d2 0f a4
 0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module  1.0-4496  Wed Jul 16 19:03:09 PDT 2003
Back to top
View user's profile Send private message
stevena
n00b
n00b


Joined: 17 Apr 2003
Posts: 50

PostPosted: Tue Jan 20, 2004 5:00 pm    Post subject: Reply with quote

Je hebt gelijk. Er is niks mis mee.
Denk dat het eigenlijk nog maar aan een ding kan liggen: is je ALSA wel gestart?
    Wat geeft /etc/init.d/alsasound status? Als het started is is hij started.
    Anders moet je hem opstarten met /etc/init.d/alsasound start dan zou aplay moeten werken.

Als je wilt dat je die niet elke keer moet opstarten kan je ook zeggen dat dit automatisch moet gebeuren als je computer opstart door: rc-update add alsasound boot
Back to top
View user's profile Send private message
Gerbstar
n00b
n00b


Joined: 17 Feb 2003
Posts: 31
Location: Lelystad, Netherlands

PostPosted: Tue Jan 20, 2004 7:58 pm    Post subject: Reply with quote

Dat stond nog goed van mijn vorige ALSA (bij mijn vorige kernels), dus daar ligt het helaas niet aan.

Voor de zekerheid nog even mijn /etc/modules.d/alsa (volgens mij is die goed):
Code:
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsa-modules.conf-rc,v 1.1 2003/08/05 21:07:55 johnm Exp $

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
alias snd-card-0 snd-fm801
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1


Zou het kunnen helpen als ik het bestand waarin ALSA de volume-instellingen enzo opslaat weg gooi, en dan ALSA opnieuw emerge? (welk bestand is dat?) Of iemand een beter idee?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum