Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Openoffice installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
gentphil
n00b
n00b


Joined: 04 Dec 2003
Posts: 66
Location: France

PostPosted: Tue Jan 20, 2004 9:32 pm    Post subject: Openoffice installation Reply with quote

I try to install open office but I have the following problem.

The system could not install openn ofice because he need blackdown-jdk, and when >I try to install blacdown using the instructions, I have the following errors :
Traceback (most recent call last):

Files "/usr/bin/java-config", line 15, in ?
from java_config import jc_options
File "/usr/lib/python2.2/site/packages/java_config/jc_options.py" , line 6, in ?
from output import *
ImportError : No module named output


Question : What I have to do in order to install open office and install blackdown ?

Thanks for the help

Phil
Back to top
View user's profile Send private message
rt_clik
n00b
n00b


Joined: 18 Jun 2002
Posts: 70
Location: Rohnert Park, California, US

PostPosted: Tue Jan 20, 2004 9:45 pm    Post subject: Reply with quote

I had a similar problem some time ago that I believe I tracked down to a java-config and Python library mismatch. At the time it looked like my system was running Python2.3 but there was some old Python2.2 garbage lying around and/or java-config was compiled using old libraries that were no longer available.

Long story short...I think I solved this issue by re-emerging java-config.

BTW - I was not trying to install blackdown at the time. I was trying to change my default Java JDK for the system from blackdown to the ibm-jdk. Your mileage may vary.
Back to top
View user's profile Send private message
rhale314159
n00b
n00b


Joined: 14 Dec 2003
Posts: 41
Location: East US

PostPosted: Tue Jan 20, 2004 10:46 pm    Post subject: emerging blackdown java Reply with quote

I had the same problem when I was trying to install openoffice.
At the time I installed openoffice without the java support. It works.

I ended up installing blackdown later on by going to www.blackdown.org -> download -> pick a ftp server -> JDK-1.3.1 -> ppc -> FCS-02c
From there I loaded the j2sdk-1.3.1-02c-FCS-linux.bin (21Meg)
and moved it into my /usr/portage/distfiles directory. Then I did
emerge blackdown-jdk
Back to top
View user's profile Send private message
gentphil
n00b
n00b


Joined: 04 Dec 2003
Posts: 66
Location: France

PostPosted: Wed Jan 21, 2004 2:03 pm    Post subject: Reply with quote

I've re-emerge python, then java-config, and that's work...untill the last phase of buils : I've an error in src_config

and finally open office do'nt merge.

Any idea ?

Thanks by advance


Phil
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum