Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no more emerge!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
capitanjackal
n00b
n00b


Joined: 26 Aug 2003
Posts: 69
Location: Quarata (CALIFORNIA)

PostPosted: Wed Jan 21, 2004 8:56 am    Post subject: no more emerge! Reply with quote

help friends.

in the last two weeks I can't do any emerge.
I am blocked to: dev-python/python-fchksum-1.7.1

....
ibook root # emerge -U system
>>> --upgradeonly implies --update... adding --update to options.
Calculating system dependencies ...done!
>>> emerge (1 of 74) dev-python/python-fchksum-1.7.1 to /
>>> md5 src_uri ;-) python-fchksum-1.7.1.tar.gz
>>> Unpacking source...
>>> Unpacking python-fchksum-1.7.1.tar.gz to /var/tmp/portage/python-fchksum-1.7.1/work
>>> Source unpacked.
['setup.py', 'build']
running build
running build_ext
Traceback (most recent call last):
File "setup.py", line 78, in ?
extra_link_args = lflags_arg,
File "/usr/lib/python2.3/distutils/core.py", line 149, in setup
dist.run_commands()
File "/usr/lib/python2.3/distutils/dist.py", line 907, in run_commands
self.run_command(cmd)
File "/usr/lib/python2.3/distutils/dist.py", line 927, in run_command
cmd_obj.run()
File "/usr/lib/python2.3/distutils/command/build.py", line 107, in run
self.run_command(cmd_name)
File "/usr/lib/python2.3/distutils/cmd.py", line 333, in run_command
self.distribution.run_command(command)
File "/usr/lib/python2.3/distutils/dist.py", line 927, in run_command
cmd_obj.run()
File "/usr/lib/python2.3/distutils/command/build_ext.py", line 244, in run
customize_compiler(self.compiler)
File "/usr/lib/python2.3/distutils/sysconfig.py", line 165, in customize_compiler
opt = opt + ' ' + os.environ['CFLAGS']
TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'

!!! ERROR: dev-python/python-fchksum-1.7.1 failed.
!!! Function src_compile, Line 20, Exitcode 1
!!! (no error message)

I've also tried the 1.6 version, but with the same results.

my make.conf:
USE="ppc X acpi cups usb ncurses -kde -gtk gtk2 -java -gnome -alsa ethereal xmms -gps"
CHOST="powerpc-unknown-linux-gnu"
CFLAGS="-mcpu=750 -O3 -pipe -fsigned-char -mpowerpc-gfxopt"


Any idea ?
_________________
Meglio una Fiat 500 con 500 watts che una Fiat Punto con punti watts!
PS: ho comprato la punto! sono un l00s3r
Back to top
View user's profile Send private message
trance
Retired Dev
Retired Dev


Joined: 06 May 2002
Posts: 13
Location: Santa Clara, CA

PostPosted: Wed Jan 21, 2004 10:07 am    Post subject: Reply with quote

Hi there,

Not sure of the exact nature of the error, but it could be several things, first off, the compile flags your using aren't recommended. You really SHOULDN'T be using anything but:

CFLAGS="-O3 -pipe -mcpu=750"

on a G3 on recent compilers. The options your using worked for gcc 2.95.x but have somewhat poor to disasterous results on later versions. =)

In fact if you look in the current default make.conf it says:

# Recommended settings for GCC 2.95.3 only (Gentoo 1.2 or older):
#
# PowerPC 750 > up: this works on G3's and G4s, gcc 2.95.3 doesn't make the
# distinction between G3 and G4, so this is fine for all NewWorld machines, if
# you use yaboot to boot you should select this option
#
#CFLAGS="-O2 -pipe -mcpu=750 -mpowerpc-gfxopt -mmultiple -mstring"
#

ACPI isn't supported on ppc, so you can remove that from your useflags.

Give that a try with the new settings

trance
Back to top
View user's profile Send private message
capitanjackal
n00b
n00b


Joined: 26 Aug 2003
Posts: 69
Location: Quarata (CALIFORNIA)

PostPosted: Wed Jan 21, 2004 3:19 pm    Post subject: Reply with quote

thanks for your hints.

but I still have the same error.


Giacomo
_________________
Meglio una Fiat 500 con 500 watts che una Fiat Punto con punti watts!
PS: ho comprato la punto! sono un l00s3r
Back to top
View user's profile Send private message
paja
n00b
n00b


Joined: 18 May 2003
Posts: 1
Location: Europe

PostPosted: Sat May 15, 2004 3:09 pm    Post subject: Not a PPC error Reply with quote

I've got the same problem on athlon-xp - seems like older python setup.py does not like fchksum (not sure i am not a python programmer, but it seems like it could not get the gcc flags from environment...)

This is what helped:

Code:
emerge -i dev-python/python-fchksum-1.7.1
emerge -u python
emerge python-fchksum


Again - no warranty - i'm just lame user, but this worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum