Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge system: perl not found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
LarsOnPPC
n00b
n00b


Joined: 03 Aug 2003
Posts: 14

PostPosted: Fri Jan 23, 2004 8:07 pm    Post subject: emerge system: perl not found Reply with quote

Hi,

when I say "emerge system" during the installtion from a stage2 tarball and it wants to emerge autoconf it says: perl not found. Ok, I say: emerge perl, but that wants to emerge autoconf first - that means I'm hanging in an infinite loop ;-)

Do you have any suggestions to solve this problem.

I'm using the latest G4 live cd.

Kind regards,
Lars
Back to top
View user's profile Send private message
garn
Tux's lil' helper
Tux's lil' helper


Joined: 10 Sep 2003
Posts: 131

PostPosted: Fri Jan 23, 2004 8:30 pm    Post subject: Reply with quote

I had the same problem. Unfortunately I forgot what I did to remedy it.

Maybe you haven't emerge sync'ed yet?
Back to top
View user's profile Send private message
LarsOnPPC
n00b
n00b


Joined: 03 Aug 2003
Posts: 14

PostPosted: Fri Jan 23, 2004 9:25 pm    Post subject: Reply with quote

garn wrote:
I had the same problem. Unfortunately I forgot what I did to remedy it.

Maybe you haven't emerge sync'ed yet?


Hmm... I followed the instructions from http://www.gentoo.org/doc/en/gentoo-ppc-install.xml .

I also tried to build perl manually with the help of this: https://forums.gentoo.org/viewtopic.php?t=107673&highlight=perl

But during the build process I get an error from "make" - so perl can't be build.

Perhaps I should try a stage3 tarball where all these steps are already done.

Kind regards,
Lars
Back to top
View user's profile Send private message
reves
Apprentice
Apprentice


Joined: 25 Jun 2002
Posts: 215
Location: South Florida

PostPosted: Sat Jan 24, 2004 12:53 am    Post subject: Reply with quote

I had this same problem with autoconf/perl starting from stage2-1.4-ppc To resolve this I did the following:

Code:
USE="" emerge perl --nodeps
emerge perl
emerege system


perl was built successfully then rebuilt with it's dependencies/my USE settings and everything the rest of the system emerged successfully.
_________________
Robert
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum