Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xterm with backwards characters
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
loppe
n00b
n00b


Joined: 25 Jan 2004
Posts: 18
Location: Melbourne, Australia

PostPosted: Sun Jan 25, 2004 12:59 pm    Post subject: Xterm with backwards characters Reply with quote

Hello all,

I have no idea if this problem is related to my PPC, installation or other . . . but it's a weird one. The letters in the xterms on my PPC (PowerBook 3400c) are backwards!

The details:
- PowerBook 3400c running blackbox window manager (same problem observed with twm).
- xfree was installed from a package on the Gentoo 1.4 PPC LiveCD (because my PowerBook is relatively slow (180 MHz) and not much disk space (1.3Gb)).
- XFS is running and does not appear to give me errors (I have the same problem with XFS is not running).
- I installed aterm just to see if there was a difference - no difference, letters on aterm are also backwards.
- Other applications (mozilla) display fonts correctly on the PowerBook.
- when I export an xterm from my PowerBook to my PC (another computer on which I've installed Gentoo 1.4, but which does not have the same iritating problem of backwards letters in xterms), the letters are displayed correctly. This indicates a problem with the X-server (I think).
- I've tried changing the font used by Xterm - when I used (defined in /etc/X11/app-defaults/XTerm) a font found in /usr/X11R6/lib/X11/font/misc, the same phenomenon is observed. I don't know how to define a font outside the misc directory.

I have a screenshot, but no webpage to post it on. I can email it to anyone who thinks it could help. My next plan of action is to attempt to emerge xfree (without --usepkg) to see if that helps, but I'd rather fix the problem (if something to do with configuration) if possible.

Thanks in advance,
- Lars -
Back to top
View user's profile Send private message
loppe
n00b
n00b


Joined: 25 Jan 2004
Posts: 18
Location: Melbourne, Australia

PostPosted: Sun Jan 25, 2004 1:26 pm    Post subject: Reply with quote

...just got private homepage set up...

The screen shot (showing backward characters in an xterm) is my homepage (how exciting...er, not)

http://www.mypage.bluewin.ch/lamaba

Any ideas would be appreciated...

- Lars -
Back to top
View user's profile Send private message
kalisphoenix
Apprentice
Apprentice


Joined: 28 Sep 2003
Posts: 211
Location: Ohio

PostPosted: Wed Feb 25, 2004 6:01 am    Post subject: Reply with quote

Heh. Looks cyrillic.

.... I have the exact same powerbook, and I'm running Debian after I couldn't get Gentoo installed... I think you might have given me the answer, though -- thanks!

Oh, uh, sorry I can't help :-P Maybe I can duplicate the bug, tho.
Back to top
View user's profile Send private message
kalisphoenix
Apprentice
Apprentice


Joined: 28 Sep 2003
Posts: 211
Location: Ohio

PostPosted: Fri Mar 05, 2004 11:34 am    Post subject: Reply with quote

kalisphoenix wrote:
Heh. Looks cyrillic.

.... I have the exact same powerbook, and I'm running Debian after I couldn't get Gentoo installed... I think you might have given me the answer, though -- thanks!

Oh, uh, sorry I can't help :-P Maybe I can duplicate the bug, tho.


And I did duplicate the bug. I didn't install X for a while (didn't feel like it, I guess) and I have the exact same problem with backwards characters. I'm using XFCE4 and I also installed from the package on the 1.4 livecd.

I'll see if I can find anything on the 'net, and I'll report back. Have you made any progress?
Back to top
View user's profile Send private message
loppe
n00b
n00b


Joined: 25 Jan 2004
Posts: 18
Location: Melbourne, Australia

PostPosted: Fri Mar 05, 2004 9:41 pm    Post subject: Reply with quote

Quote:
Have you made any progress?


Unforunately, no, although its good to know that I'm not alone :). Here's what I have done:

I bought a new 40GB harddisk (I thought that 1.3GB was living on the edge a little) and installed it in my PB 3400c. When reinstalling Gentoo, I decided to try compiling xfree (rather than using the GRP pre-compiled package) since I now have the disk space... After a number of hours, I got the same result - backwards characters in xterms.

I'm not too sure what can still be done. I've resolved to using a console if I need to type things on the command line (however, with no scrollbar, this is not ideal).

I actually got quite a bit of good information from Henrik Farre's web site (http://www.rockhopper.dk/linux/powerbook3400/index.html) which has excellend information about installation Gentoo on a PB 3400. Still, though, no clue as to how to solve this problem.

If I find a solution, I will reply to this posting.

- Lars -
Back to top
View user's profile Send private message
kalisphoenix
Apprentice
Apprentice


Joined: 28 Sep 2003
Posts: 211
Location: Ohio

PostPosted: Sat Mar 06, 2004 2:54 am    Post subject: Reply with quote

loppe wrote:
Quote:
Have you made any progress?


Unforunately, no, although its good to know that I'm not alone :). Here's what I have done:

I bought a new 40GB harddisk (I thought that 1.3GB was living on the edge a little) and installed it in my PB 3400c. When reinstalling Gentoo, I decided to try compiling xfree (rather than using the GRP pre-compiled package) since I now have the disk space... After a number of hours, I got the same result - backwards characters in xterms.

I'm not too sure what can still be done. I've resolved to using a console if I need to type things on the command line (however, with no scrollbar, this is not ideal).

I actually got quite a bit of good information from Henrik Farre's web site (http://www.rockhopper.dk/linux/powerbook3400/index.html) which has excellend information about installation Gentoo on a PB 3400. Still, though, no clue as to how to solve this problem.

If I find a solution, I will reply to this posting.

- Lars -


Thanks. I have a 20GB drive so I was thinking about recompiling it too. I noticed that some of the text screensavers have this problem and some don't, which might help some reader figure it out.

The BSOD screensaver has this error on certain parts. The Windows, MacOS, and other UNIX screens don't seem to have it, but the Linux one (?) does.
The scrolling text screensavers, like NoseGuy, et cetera don't have this problem. I'm not sure how that helps, but it should narrow it down.

Hmmph.
Back to top
View user's profile Send private message
loppe
n00b
n00b


Joined: 25 Jan 2004
Posts: 18
Location: Melbourne, Australia

PostPosted: Fri Mar 12, 2004 6:32 am    Post subject: Reply with quote

Some progress to report.

Still no solution for xterm, however I installed gnome-terminal last night and...correct fonts :o ! Life is getting better, but it would be nice to know why xterm and aterm have this annoying problem.

I'll still keep my eyes open for solutions and post them back here.

- Lars -
Back to top
View user's profile Send private message
kalisphoenix
Apprentice
Apprentice


Joined: 28 Sep 2003
Posts: 211
Location: Ohio

PostPosted: Fri Mar 12, 2004 7:16 am    Post subject: Reply with quote

That's a good start -- something tells me that this won't be solved without an in-depth look at the source code, and I am not a programmer by any stretch of the imagination. It seems almost arbitrary, doesn't it? Quite frustrating.

I've simply been switching to console when I need to type something, which is no fun. I'll vary my attack in the days to come.
Back to top
View user's profile Send private message
fducloux
n00b
n00b


Joined: 21 May 2004
Posts: 2
Location: Argentina

PostPosted: Tue May 25, 2004 10:47 pm    Post subject: Reply with quote

So.. any news about this problem? I'm having the exact same problem :(
Back to top
View user's profile Send private message
Immortal Q
Apprentice
Apprentice


Joined: 14 Sep 2003
Posts: 241
Location: Silicone Valley

PostPosted: Tue May 25, 2004 11:17 pm    Post subject: Reply with quote

Have any of you tried X.org? On a completely different note - what kernel are you using? Do any console apps have the same issue?
_________________
Osmos.org
Now with 20% fewer rabid primates.
Back to top
View user's profile Send private message
fducloux
n00b
n00b


Joined: 21 May 2004
Posts: 2
Location: Argentina

PostPosted: Tue May 25, 2004 11:41 pm    Post subject: Reply with quote

Actually I am usin Xorg 6.7.0
the problem is with xterm and any console program i run inside
i'm also using wterm wich doesn't have that problema. but when I use vi or prozilla and many other programs the have the same font problem

I'm using kernel 2.4.24-ppc-r4
Back to top
View user's profile Send private message
porodzila
Guru
Guru


Joined: 22 May 2004
Posts: 307
Location: Terrapin Station

PostPosted: Wed May 26, 2004 1:12 am    Post subject: Reply with quote

hack it up so that the characters are reversed yet again before display .
_________________
ubi primum potero, me hinc subduco.
Back to top
View user's profile Send private message
xaqster
n00b
n00b


Joined: 15 Mar 2005
Posts: 4

PostPosted: Fri May 20, 2005 8:41 am    Post subject: I have found the cause! Reply with quote

I am running Enlightenment on SPARC via TightVNC, and am having the same problems with some of the themes and xterm. I found that the problem is Endianivityness!

http://www.rdrop.com/~cary/html/endian_faq.html <--- More than you ever needed to know about Endianness!

What it boils down to is that SPARC, PPC and the like are Big-Endian machines, and Intel, AMD and the like are Little-Endian. This means that when presented with data, big-endian reads from one end, and little-endian reads from the other! Thus, all the characters in the fonts are reversed. Basically you need to have big-Endian fonts, and use a terminal that lets you choose the font.

I am going to emerge Eterm, and see if that lets me choose the font.

HTH

Xaqster
Back to top
View user's profile Send private message
kalisphoenix
Apprentice
Apprentice


Joined: 28 Sep 2003
Posts: 211
Location: Ohio

PostPosted: Sun May 22, 2005 3:11 am    Post subject: Re: I have found the cause! Reply with quote

xaqster wrote:
I am running Enlightenment on SPARC via TightVNC, and am having the same problems with some of the themes and xterm. I found that the problem is Endianivityness!

http://www.rdrop.com/~cary/html/endian_faq.html <--- More than you ever needed to know about Endianness!

What it boils down to is that SPARC, PPC and the like are Big-Endian machines, and Intel, AMD and the like are Little-Endian. This means that when presented with data, big-endian reads from one end, and little-endian reads from the other! Thus, all the characters in the fonts are reversed. Basically you need to have big-Endian fonts, and use a terminal that lets you choose the font.

I am going to emerge Eterm, and see if that lets me choose the font.

HTH

Xaqster


Whoa. WTF? Seems like that would have been solved very early in the compilation... but as I've frequently noted, I know dick about this stuff. Very weird.
Back to top
View user's profile Send private message
lostdave
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jun 2004
Posts: 85
Location: Leeds, UK

PostPosted: Sun May 22, 2005 7:35 am    Post subject: Reply with quote

I used to have this problem on my powerbook.

One of the terminal programs (I believe it was gnome-terminal) didn't have this problem, so I switched to that. Never actually "solved" the problem though
Back to top
View user's profile Send private message
xaqster
n00b
n00b


Joined: 15 Mar 2005
Posts: 4

PostPosted: Sun May 22, 2005 11:11 pm    Post subject: Reply with quote

I think that the terms would work well enough on the SPARC terminal, but I have no graphics card in it, so I can't tell. The problem is accessing the terminals from an Intel box. I installed Gnome-terminal because it lets you choose the font, but running this causes the TightVNC server to core-dump!

I think my next port of call is going to be set up TightVNC viewer on one of our SPARC solaris test servers and check the fonts, then change the system font for one from an Intel server, then see if thet messes with the terminal through a terminal concentrator. I will get this to work!

I used to run a VW bug. As the Dubbers say, Rebuild and refuse to lose!
_________________
I'm just here to regulate Funkyness.
Back to top
View user's profile Send private message
loppe
n00b
n00b


Joined: 25 Jan 2004
Posts: 18
Location: Melbourne, Australia

PostPosted: Sun Jun 19, 2005 4:42 am    Post subject: Reply with quote

...it's been a while since my original post, but I thought I'd post what I think is the best solution.

Since resources are an issue with my PowerBook 3400c (max memory=144MB, clock speed=180MHz), I've decided to install rxvt-unicode. This terminal is basically a slimmed-down xterm, but it allows you to set the font. Here's the command and options that I use:

Code:
urxvt -fn 'xft:LucidaTypeWriter:pixelsize=10' -ls -sl 1024 -st -sr -bg black -fg white


...if you use the default font, the characters are still backwards.

Incidentally, here's my current set up:
kernel 2.6.10-gentoo-r6
X.org X11 6.8.2 r1
rxvt-unicode 5.3

to answer one of the questions above, no, the problem does not occur in a console (see my original post).

- Lars -
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum