Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.2_rc1-benh Kernel Module Problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
gino_rotormind
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2003
Posts: 79

PostPosted: Tue Jan 27, 2004 7:41 am    Post subject: 2.6.2_rc1-benh Kernel Module Problems Reply with quote

Hi,

I just upgraded to the latest ppc-development-sources (ppc-development-sources-2.6.2_rc1-r1) on my 15" AlBook and am getting the following errors apon booting and am wondering if anybody else is having similar problems, and/or have solutions.

The kernel complains of not being able to find the following modules:
off
st
ide_probe_mod
ide_tape

I did not touch any settings for these modules!

Furthermore the snd_powermac module cannot be inserted into the kernel due to:
/lib/modules/2.6.2_rc1-benh/kernel/sound/ppc/snd-powermac.ko: Unknown symbol in module, or unknown parameter (see dmesg).
Nor could snd_seq, snd_seq_midi and snd_seq_oss for the similar reasons.

the output from the dmesg reads as follows:
_seq_kernel_client_enqueue_blocking
snd_seq_oss: Unknown symbol snd_seq_device_register_driver
snd_seq_oss: Unknown symbol snd_midi_event_free
snd_seq_oss: Unknown symbol snd_midi_event_no_status
snd_seq_oss: Unknown symbol snd_seq_device_unregister_driver
snd_seq_oss: Unknown symbol snd_midi_event_new
snd_seq_oss: Unknown symbol snd_midi_event_decode
snd_seq_oss: Unknown symbol snd_seq_create_kernel_client
snd_seq_oss: Unknown symbol snd_seq_kernel_client_write_poll
snd_seq_oss: Unknown symbol snd_midi_event_encode_byte
snd_seq_oss: Unknown symbol snd_seq_kernel_client_ctl
snd_powermac: Unknown symbol i2c_smbus_write_block_data
snd_powermac: Unknown symbol i2c_add_driver
snd_powermac: Unknown symbol i2c_smbus_write_byte_data
snd_powermac: Unknown symbol i2c_del_driver
snd_powermac: Unknown symbol i2c_detach_client
snd_powermac: Unknown symbol i2c_attach_client

thanks for your help[/code]
Back to top
View user's profile Send private message
Kirja
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 116
Location: England

PostPosted: Tue Jan 27, 2004 9:19 pm    Post subject: Reply with quote

This isnt a ppc only problem. There seems to be issues with module-init-tools-3.0_pre6 and pre7. Take a look at this thread: https://forums.gentoo.org/viewtopic.php?t=128724
Back to top
View user's profile Send private message
gino_rotormind
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2003
Posts: 79

PostPosted: Tue Jan 27, 2004 11:15 pm    Post subject: Thanks Reply with quote

You have hit it directly on the head. Many thanks, I guess I shouldn't always assume that my problems are always ppc specific ;^)
Back to top
View user's profile Send private message
feliperal
Apprentice
Apprentice


Joined: 09 Mar 2003
Posts: 168

PostPosted: Wed Jan 28, 2004 7:47 am    Post subject: Reply with quote

mine borked while trying to compile support for new radeon drivers. I gueess might as well wait for the 2.6.2 release
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum