Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
my beige g3 is posessed!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
mert
n00b
n00b


Joined: 14 Oct 2003
Posts: 10
Location: Texas, USA

PostPosted: Thu Jan 29, 2004 11:42 am    Post subject: my beige g3 is posessed! Reply with quote

Greetings - I just finished installing gentoo on my beige g3 but the system seems to hang during the boot process or soon after. Sometimes the system will freeze up while loading syslog-ng, during boot. Sometimes syslog-ng will start ok and I can get to a login prompt and log in, but it will freeze up within an few minutes. for example, it always locks up part way through running 'emerge sync' It also froze up while running nano -w /etc/fstab (I was checking fstab, not editing it) It always happens within a few minutes of booting the system. when the system locks up I can't ctrl-C to kill the application and I can't use alt-F keys to switch consoles. I've tried booting with the kernel 2.4.21 that I compiled during the install and with the kernel on the liveCD and I get the same results. I've checked my fstab and it seems to be correct. Any ideas where to go next?
Thanks, mert
Back to top
View user's profile Send private message
Tapp_Darden
n00b
n00b


Joined: 17 Jul 2003
Posts: 20

PostPosted: Thu Jan 29, 2004 6:45 pm    Post subject: Reply with quote

it works fine when you boot from a live cd?
Back to top
View user's profile Send private message
mert
n00b
n00b


Joined: 14 Oct 2003
Posts: 10
Location: Texas, USA

PostPosted: Thu Jan 29, 2004 7:42 pm    Post subject: Reply with quote

I boot using bootX and when I boot using the ramdisk image the system seems to work fine. My install went with no problems. I wonder if it has something to do with the disk or disk mounting. I'm using ext3 disk format. I previously had mandrake linux on the disk and I reformated the partition to prepare it for gentoo.
Back to top
View user's profile Send private message
mert
n00b
n00b


Joined: 14 Oct 2003
Posts: 10
Location: Texas, USA

PostPosted: Wed Feb 04, 2004 11:53 am    Post subject: Reply with quote

After realizing that my computer was not, in fact, posessed by evil spirits I decided to reinstall gentoo on my G3 mac. The second install went fine and I had a stably running system. I say 'had' because I promptly blew away the fully functioning install to see if I could figure out what broke install #1. Install 2 I changed many options, I used the ppc stage 3 tarball instead of the G3, I used a difference kernel logger and cron daemon, and a different kernel. Now I'm at broken install #3 and I got it running stably after removing syslog-ng!

So, now I suspect syslog-ng. What system logger do you other ppc gentoo users use?
Back to top
View user's profile Send private message
freak4u
n00b
n00b


Joined: 04 Jul 2003
Posts: 69
Location: MA, USA

PostPosted: Sun Jun 26, 2005 3:29 pm    Post subject: Reply with quote

I too just installed gentoo on a beige g3 and I had similar problems. Here's what I found: Don't use devfs. Use udev. I had a mount line in my /etc/fstab for devfs (that I added because I thought automounting wasn't working, but it was breaking udev). If you look at your logs do you see that it can't start agetty on tty1? can you post the logs of your beige g3 and the options you're giving to bootx?
_________________
Making computing a safer place...one less Windoze box at a time
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum