Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fullscreen MOL question
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
inchhigh
n00b
n00b


Joined: 12 Feb 2004
Posts: 1
Location: NY

PostPosted: Thu Feb 12, 2004 10:01 pm    Post subject: Fullscreen MOL question Reply with quote

hi all,
I'm doing my first gentoo-ppc install (I have done gentoo on x86 and other distros on ppc). Things have gone relatively smoothly. I am stuck on one thing though. How do you get MOL to run in full screen? I have consulted the docs at maconlinux.org, but I have been unable to get things configured correctly, hopefully i"m just missing something stupid.

Here is where it stands.
I emerged mol-0.9.70_rc2, but as far as I could tell, it does not include the molvconfig tool, so I ended up downloading the latest via rsync, and manually compiled and installed it. That went fine, I ran molvconfig and went through all the tests and passed most of them, and it said it was writing the file.

Now, if I startmol -X from terminal within kde, MOL starts fine and runs in a window. While it's running if I hit Ctrl-Cmd+F9, it switches to an allblack screen with a white cursor blinking in the upper right corner, but I can't seem to interact with it in any meaningful way. I can get back to kde (with MOL running in a window) by hitting Ctrl+Cmd+F7.

If I startmol -X from a text login, I get the error:
Code:
Could not connect to X server
Video Driver(s)
No video modes at all was found-exiting
cleaning up threads..
DONE


Any pointers on where to look would be greatly appreciated. I'll post my molrc.video below. I have tried it with autoswitch_console as yes or no, with no apprent difference.
thanks again,
IH

Code:

# -*- perl -*- (for emacs syntax coloring)
#
# Mac-on-Linux video configuration
#


# ----------------------------------------------------------------------
# Startup Resolution (this is used as a hint only)
# ----------------------------------------------------------------------
#   

resolution:      1280/1024/85   # width/height/Hz
depth:         32      


# ----------------------------------------------------------------------
# X11 Settings
# ----------------------------------------------------------------------
#
#   Some config options:
#
#      xdisplay:      remote.host:0.0
#      use_backing_store:   yes/no
#
#   Backing store is primarily useful if the X-connection is remote.
#   Note: X11-video is not as fast as full-screen video.

enable_xvideo:      yes


# ----------------------------------------------------------------------
# Fullscreen (Console/fbdev) Settings
# ----------------------------------------------------------------------
#
#   The tool 'molvconfig' is used to configure the fullscreen mode.
#
#   Some config options:
#
#       vt:      9      # VT-number to use
#       gamma:   1.0      # gamma (parameter between 0.1 and 1.0)
#       gamma:   1.0 1.0 1.0   # gamma (r,g,b)
#
#   Ctrl-Cmd-Space switches back to the orignal VT

enable_console_video:   yes

start_on_console:   yes      # switch to console initially
# ----------------------------------------------------------------------
# Fullscreen (Console/fbdev) Settings
# ----------------------------------------------------------------------
#
#       The tool 'molvconfig' is used to configure the fullscreen mode.
#
#       Some config options:
#
#           vt:         9               # VT-number to use
#           gamma:      1.0             # gamma (parameter between 0.1 and 1.0)
#           gamma:      1.0 1.0 1.0     # gamma (r,g,b)
#
#       Ctrl-Cmd-Space switches back to the orignal VT

enable_console_video:   yes

start_on_console:       yes             # switch to console initially
autoswitch_console:     no              # allow automatic switching to console


autoswitch_console:   no      # allow automatic switching to console

fb_modes:      /etc/fb.modes   # extra video modes for molvconfig


# ----------------------------------------------------------------------
# XDGA (X11 fullscreen) Settings
# ----------------------------------------------------------------------
#
#   At startup, all available XDGA modes are listed. Unfortunately,
#   some of the modes might be broken (depending on the video card
#   and the XFree86 version).
#
#   By default, MOL uses just a single mode with high
#   probability of working. However, it is possible to manually
#   specify multiple modes. For instance
#
#       xdga_modes:      3 5 9      
#
#   instructs MOL to use mode 3, 5 and 9.
#
#   Cntrl-Cmd-Space leaves XDGA mode and switches back to X

enable_xdga_video:   yes


# ----------------------------------------------------------------------
# VNC Settings
# ----------------------------------------------------------------------
#
#   For VNC information, visit http://www.uk.research.att.com/vnc/
#

enable_vncvideo:   no   # Enable the VNC server
vnc_port:        5900   # port to use for VNC


And here is what the terminal gives while running and shutting down MOL (under kde):
Code:

bash-2.05b$ startmol -X
Mac-on-Linux 0.9.70-rc2-gentoo -gentoo  [Feb 11 2004 21:50]
Copyright (C) 1997-2004 Samuel Rydh
Starting MOL session 1
Running in PowerPC 7400 mode, 128 MB RAM
Timebase: 24.90 MHz, Bus: 99.63 MHz, Clock: 450 MHz
Using USB mouse on /dev/input/mice
OHCI USB controller registered
Could not open '/var/lib/mol/x11.kbd'
Video driver(s): [xvideo]

     640* 480, depth 8,32   { 0.0 } Hz
     800* 600, depth 8,32   { 0.0 } Hz
    1024* 768, depth 8,32   { 0.0 } Hz
    1152* 864, depth 8,32   { 0.0 } Hz
    1280*1024, depth 8,32   { 0.0 } Hz
    1600*1200, depth 8,32   { 0.0 } Hz

Internet Software Consortium DHCP Server V3.0pl2
Copyright 1995-2003 Internet Software Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP
Wrote 0 deleted host decls to leases file.
Wrote 0 new dynamic host decls to leases file.
Wrote 0 leases to leases file.
Listening on LPF/tun1/00:ff:e8:d1:ae:53/192.168.41.0/24
Sending on   LPF/tun1/00:ff:e8:d1:ae:53/192.168.41.0/24
Sending on   Socket/fallback/fallback-net
Ethernet Interface 'tun-<tun1>' @ 00:00:0D:EA:DB:EE
OSS sound device unavailable (will be used anyway)
OSS sound driver
MOL SCSI controller registered


    <No SCSI Devices>

    CD   /dev/cdrom       CD-ROM         <read-only>   ------
----> /dev/hda2 might be a boot-strap partition.
No volumes found in '/dev/hda'
    HFS+ /dev/hdb10       MacHD          <rw> 19412 MB
No volumes found in '/dev/sda'
No volumes found in '/dev/sdb'


>> ==================================================
>> MacOS X Boot Loader 1.1.18
>> Candidate boot volume: /mol-blk@0/disk@0:0
>> /mol-blk@0/disk@0:0,\mach_kernel (3824080 bytes)
>> /mol-blk@0/disk@0:0,\System\Library\Extensions.mkext
>> ==================================================

<*> Block Driver v1.1
<*> Ethernet driver 1.1
<*> MolAudio 1.2
<*> MolEnet: Link up at 100 Mbps - Full Duplex
+ Video Driver v1.12

Signal INT
One more to kill emulator
cleaning up...
Terminating threads...
DONE

Back to top
View user's profile Send private message
rt_clik
n00b
n00b


Joined: 18 Jun 2002
Posts: 70
Location: Rohnert Park, California, US

PostPosted: Thu Feb 12, 2004 10:29 pm    Post subject: Reply with quote

Although I have not figured out why, using `xhost localhost` prior to running `startmol` allowed MOL to make use of the local X server. localhost should be allowed access by default, but...
Back to top
View user's profile Send private message
zojas
Veteran
Veteran


Joined: 22 Apr 2002
Posts: 1138
Location: Phoenix, AZ

PostPosted: Thu Feb 19, 2004 5:56 pm    Post subject: Reply with quote

molvconfig only gets installed if you have certain USE variables set. read the changelog and the ebuild itself.
_________________
http://www.desertsol.com/~kevin/ppc
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum