Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I got gentoo on my Ibook g4, but no new apps will install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ignuu2
n00b
n00b


Joined: 05 Aug 2003
Posts: 17

PostPosted: Sun Feb 15, 2004 1:06 am    Post subject: I got gentoo on my Ibook g4, but no new apps will install Reply with quote

Hi again. So thanks to gentoo this list and the ayboot list I managed to get gentoo on my ibook G4, yay. The problem now lies in that no other apps will install. The most important things to me are getting openoffice Mozilla-Firebird and all the video toys I can built on my ibook. Xine being the first and most important one.

When ever I try to emerge anything it fails with some error at some line. I must admit I don't understand the ebuild system very well and so I am probably doing a billion things wrong. Do you guys have a good portage on ppc tutoris I should read?

Other problems I am having include a bunch of modules that the syss=tem can't find when booting. The weird part is that most of the hardware seems to work. I will post more detail later. The last question I have is how do I switch virtual terminals on my mac? Usually it's ctrl alt f* on a PC what is it on the Mac?

Thanks
Back to top
View user's profile Send private message
ckdake
l33t
l33t


Joined: 10 Apr 2003
Posts: 889
Location: Atlanta, GA

PostPosted: Sun Feb 15, 2004 4:46 am    Post subject: Reply with quote

well, to answer your last question first, I switch between virtual terminals with [ctrl]-[option] - then press and hold [fn] then press one of the [f*] keys.

Can you post more specific error messages that you get from trying to emerge programs?

as far as the modules, did you compile anything as a module when you compiled your kernel? Do you have any modules that you know you need to use? Are you using a 2.4 or 2.6 kernel? Is there anything in /etc/modules.autoload.d/kernel-2.__ (for your kernel version)?
_________________
http://ckdake.com/
Back to top
View user's profile Send private message
ignuu2
n00b
n00b


Joined: 05 Aug 2003
Posts: 17

PostPosted: Tue Feb 17, 2004 5:29 pm    Post subject: Thanks for the reply Reply with quote

The switch console works fine, thanks. I am running a 2.6 asnd there is nothing in modules.autoload.d or modules.autoload so I don't quite know where those modules are being called.

The next weird thing is installing software.

emerge -u system

gives me

!!!ERROR: sys-devel/gettext-0.12.1-r1 failed
!!! Function src_compile, Line 50, Exitcode 2
!!! (no error message)

++++++++++++++++

emerge xine-lib

!!!ERROR: x11-libs/gtk+-2.2.4-r1 failed
!!! Function src_compile, Line 66, Exitcode 2
!!! (no error message)
Back to top
View user's profile Send private message
ckdake
l33t
l33t


Joined: 10 Apr 2003
Posts: 889
Location: Atlanta, GA

PostPosted: Tue Feb 17, 2004 6:41 pm    Post subject: Reply with quote

Are you using hotplug? Is there any more text that shows up when you try to emerge programs?
_________________
http://ckdake.com/
Back to top
View user's profile Send private message
ignuu2
n00b
n00b


Joined: 05 Aug 2003
Posts: 17

PostPosted: Wed Feb 18, 2004 2:06 pm    Post subject: Reply with quote

Hi again.

I don't think I am using hotplug, ps -ef|grep plug results in nothing. However I can simply plug in a usb mouse to the system and have it work.

Are you interested in the output from the compiler as it makes the program? It is really huge and there doesn't seem to be any errors until it fails.

Something I noticed is that it always fails trying to build gtk+-2*** but I am using kde are these problems related? If not where can I get more information on how emerge works so that I can sort out this issue.
Back to top
View user's profile Send private message
fuchsmi
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2003
Posts: 118

PostPosted: Wed Feb 18, 2004 2:16 pm    Post subject: Reply with quote

it looks like if you have problems with you swap-space.
double-check your swap! (with "cat /proc/swaps").

michi
Back to top
View user's profile Send private message
ignuu2
n00b
n00b


Joined: 05 Aug 2003
Posts: 17

PostPosted: Wed Feb 18, 2004 2:16 pm    Post subject: Reply with quote

As far as I understand it isn't the problem with my make.conf file. I mean seeing as nothing will install

so far I have tried

samba

xine

mplayer

lib-xine

mozilla

mozilla-firebird

and a whole slew of apps and nothing will compile, and I can't beleive that everyone else finds there g4 so useless.

I tried different ebuilds gor gtk and none of the 2 or 1 releases worked and that does not seem normal.

Does anyone out there have a g4 ibook? and are you able to install software using ebuild? a testamonial would go a long way to bolstering my confidence.

Have a good day

IgnuU2
Back to top
View user's profile Send private message
ignuu2
n00b
n00b


Joined: 05 Aug 2003
Posts: 17

PostPosted: Wed Feb 18, 2004 2:21 pm    Post subject: swap Reply with quote

cat /proc/swap

Filename Type Size Used Priority
/dev/ide/host0/bus0/target0/lun0/part7 partition 1023992 0 -1

free
total used free shared buffers cached
Mem: 643356 274116 369240 0 18096 172544
-/+ buffers/cache: 83476 559880
Swap: 1023992 0 1023992


looks ok to me but thanks
Back to top
View user's profile Send private message
ckdake
l33t
l33t


Joined: 10 Apr 2003
Posts: 889
Location: Atlanta, GA

PostPosted: Wed Feb 18, 2004 3:06 pm    Post subject: Reply with quote

gtk is used by a lot of programs as a gui library even if you are in kde. Chances are you have one problem and it is with building gtk2. What is in your USE valriable in /etc/make.conf? Can you post the last 15 lines or so of output before the compile fails?
_________________
http://ckdake.com/
Back to top
View user's profile Send private message
ignuu2
n00b
n00b


Joined: 05 Aug 2003
Posts: 17

PostPosted: Wed Feb 18, 2004 3:30 pm    Post subject: Reply with quote

I run as root

emerge /usr/portage/x11-libs/gtk+/gtk+-2.2.4-r1.ebuild


result/output

gdk -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DG_DISABLE_CAST_CHECKS -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -O2 -pipe -Wall -c gdkwindow-x11.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -DG_LOG_DOMAIN=\"Gdk\" -DGDK_COMPILATION -I../.. -I../../gdk -I../../gdk -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DG_DISABLE_CAST_CHECKS -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -O2 -pipe -Wall -c gdkwindow-x11.c -fPIC -DPIC -o .libs/gdkwindow-x11.o
gdkwindow-x11.c: In function `gdk_window_maximize':
gdkwindow-x11.c:3650: Internal compiler error in verify_local_live_at_start, at flow.c:586
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:https://bugs.gentoo.org/> for instructions.
make[3]: *** [gdkwindow-x11.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/gtk+-2.2.4-r1/work/gtk+-2.2.4/gdk/x11'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gtk+-2.2.4-r1/work/gtk+-2.2.4/gdk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gtk+-2.2.4-r1/work/gtk+-2.2.4'
make: *** [all-recursive-am] Error 2

!!! ERROR: x11-libs/gtk+-2.2.4-r1 failed.
!!! Function src_compile, Line 66, Exitcode 2
!!! (no error message)
Back to top
View user's profile Send private message
fuchsmi
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2003
Posts: 118

PostPosted: Wed Feb 18, 2004 4:38 pm    Post subject: Reply with quote

my iBook G3 500 had the same problems. onece it was the swap space, once it was a bad disk.
I didn't thought it was the disk, but after I booted from the livecd and checked for bad sectors everything was working fine.

generaly I would say: there are a few ebuilds that makes problems with ppc, and if you have so many problems theres an error somewhere else (Swap, RAM, HD, make.conf, etc.).
Back to top
View user's profile Send private message
ckdake
l33t
l33t


Joined: 10 Apr 2003
Posts: 889
Location: Atlanta, GA

PostPosted: Wed Feb 18, 2004 7:50 pm    Post subject: Reply with quote

Do you come to the same error each time: Look for these lines to check:
Code:
gdkwindow-x11.c: In function `gdk_window_maximize':
gdkwindow-x11.c:3650: Internal compiler error in verify_local_live_at_start, at flow.c:586

_________________
http://ckdake.com/
Back to top
View user's profile Send private message
ignuu2
n00b
n00b


Joined: 05 Aug 2003
Posts: 17

PostPosted: Thu Feb 19, 2004 2:01 am    Post subject: Reply with quote

Thanks so much for all your help everyone.

I ran an fsck on my fs and everything seemed ok. I managed to get kaffeine to emerge but not xine-lib, it hangs on

config.status: creating src/post/goom/Makefile

it just sits there.

I need to learn more about kaffeine cuz it doesn't play videos real well they are super choppy, but it's a start.

In any case mozilla is still no go and I will continue to work on this.

is there a way I can install xine-lib but get it to ommit goom?

is there some option I can pass emerge?

If you don't know where can I find doc on how to really use emerge to it's fullest, I read man but I was hoping for something with examples, something that would work for an idiot like me.

Thanks again for the help and I will post more soon with my problems and successes.

later

IgnuU2
Back to top
View user's profile Send private message
ckdake
l33t
l33t


Joined: 10 Apr 2003
Posts: 889
Location: Atlanta, GA

PostPosted: Thu Feb 19, 2004 2:53 am    Post subject: Reply with quote

For one thing, get mozilla-firefox instead of just plain ole mozilla. Its a very sweet web browser.

To learn lots about emerge: http://www.gentoo.org/doc/en/portage-user.xml and to lear even more http://www.gentoo.org/doc/en/portage-manual.xml
_________________
http://ckdake.com/
Back to top
View user's profile Send private message
D Hill
n00b
n00b


Joined: 29 Feb 2004
Posts: 5

PostPosted: Tue Mar 02, 2004 1:38 am    Post subject: Reply with quote

I just ran into the same problem myself. Lucky me. Swap space is fine... I'm assuming - Gentoo has yet to actually -use- my swap partition by the looks of it - but it mounts and everything fine at boottime.

GTK2 compiled beautifully - but, unfortunately, the only GTK program I ever seem to want to compile is Gnome itself - everything else explicitely wants GTK+ 1.2. Every single ebuild fails with the same:

!!! ERROR: x11-libs/gtk+-1.2.10-r11 failed.
!!! Function src_compile, Line 57, Exitcode 2
!!! (no error message)

error. Although - not always in the same spot!
Back to top
View user's profile Send private message
ckdake
l33t
l33t


Joined: 10 Apr 2003
Posts: 889
Location: Atlanta, GA

PostPosted: Tue Mar 02, 2004 3:58 am    Post subject: Reply with quote

post the 10 or 15 lines of the compiler output above that and someone might be able to help you out.
_________________
http://ckdake.com/
Back to top
View user's profile Send private message
D Hill
n00b
n00b


Joined: 29 Feb 2004
Posts: 5

PostPosted: Tue Mar 02, 2004 2:08 pm    Post subject: Reply with quote

I would happily do so - but, true to my experience with Linux on PPC so far, the problem went away. O.o

Probably something silly on my part that I was forgetting about. Either way, I had to reboot the system (Battery ran down on me,) and when I brought it back up, I tried the compile again - and lo and behold! It went through fine.

Now if only I could compile Firefox - or at least keep epiphany or mozilla from crashing all the time (usually when I'm in the middle of a long post somewhere, of course.)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum