Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x doet raar
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Arjan
n00b
n00b


Joined: 13 Aug 2003
Posts: 25

PostPosted: Mon Feb 23, 2004 1:37 pm    Post subject: x doet raar Reply with quote

Sinds ik twee dagen geleden een nieuwe kernel heb gebakken doet X raar, t, van 2.6.0 naar 2.6.3

soms als ik GDM opstart werkt mijn toetsenbord niet meer. ook als ik quake3 start dan reageert mijn toetsenbord heeel erg traag. ook kan ik niet meer scrollen met mijn muis wat
erg vervelend begint te worden :(

ik heb xf86config al een paar keer opnieuw geprobeerd, maar het haalt niet

heeft iemand hier een oplossing voor?

Code:

Section "Module"

    Load        "dbe"     # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load        "speedo"
    Load       "glx"

EndSection
Section "Files"

    RgbPath   "/usr/X11R6/lib/X11/rgb"

    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
#    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType/"
#    FontPath   "/usr/X11R6/lib/X11/fonts/freefont/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"

EndSection

Section "InputDevice"

    Identifier   "Keyboard1"
    Driver   "Keyboard"

    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "microsoft"
    Option "XkbLayout"   "us"
    Option "XkbVariant"   "us"

EndSection

Section "InputDevice"

    Identifier   "Mouse1"
    Driver   "mouse"
Option     "Protocol"     "IMPS/2"
Option     "Device"       "/dev/psaux"
Option     "ZAxisMapping" "4 5"

EndSection

Section "Monitor"

    Identifier  "LG915FT+"
    HorizSync   30-107
    VertRefresh 50-200

EndSection

Section "Device"
    Identifier  "GeForce2GTS"
    Driver      "nvidia"
#    Driver   "nvidia"
    #VideoRam    32768
    # Insert Clocks lines here if appropriate
EndSection

Section "Screen"

    Identifier  "Screen 1"
    Device      "GeForce2GTS"
    Monitor     "LG915FT+"
    DefaultDepth 24

    Subsection "Display"
        Depth       24
        Modes       "1600x1200"
        ViewPort    0 0
    EndSubsection

EndSection

Section "ServerLayout"

    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

_________________
AMD XP 1800+ // 1024 DDR @ 400 // Radeon 9600XT
Gentoo LInux : Kernel ~unstable
Back to top
View user's profile Send private message
Arjan
n00b
n00b


Joined: 13 Aug 2003
Posts: 25

PostPosted: Mon Feb 23, 2004 2:53 pm    Post subject: Reply with quote

ok opnieuw mijn kernel gebakken, nu zonder VIA82CXXXX ondersteuning (in ata/atapi/etc)
nu lijkt het goed te werken, echer het volgende probleem. ik heb geen DMA ondersteuning meer
en kan dit ook niet aanzetten.

als ik : hdparm -d1 /dev/hda
doe, dan krijg ik permission denied

[edit] heb even opgezocht, ik heb de VIA8235 SouthBridge
_________________
AMD XP 1800+ // 1024 DDR @ 400 // Radeon 9600XT
Gentoo LInux : Kernel ~unstable
Back to top
View user's profile Send private message
Fubarovic
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2003
Posts: 115
Location: Belgium

PostPosted: Tue Feb 24, 2004 5:59 pm    Post subject: Reply with quote

Tipje voor een betere framerate in OpenGL apps: zet DBE uit.
Ik heb er wat mee getest en mijn framerate werd er veel onregelmatiger door: bij glxgears gaf het de ene run een hoge FPS, dan weer een lagere. Als DBE uitstond bleef de framerate iets lager dan de hoge score met DBE, maar wel constant. Dit is veel handiger bij het gamen.

Verder kan ik je helaas niet echt helpen.
_________________
Orbis non sufficit
Back to top
View user's profile Send private message
frenkel
Veteran
Veteran


Joined: 13 May 2003
Posts: 1034
Location: .nl

PostPosted: Wed Feb 25, 2004 2:25 pm    Post subject: Reply with quote

DMA kun je niet meer aanzetten, omdat je ondersteuning voor je chipset hebt uitgeschakeld. Het lijkt me nogal logisch dat dit dan niet meer werkt...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum