Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
G3 ibook install woes - stage 2 or stage 3, take your pick!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
D Hill
n00b
n00b


Joined: 29 Feb 2004
Posts: 5

PostPosted: Sun Feb 29, 2004 3:54 am    Post subject: G3 ibook install woes - stage 2 or stage 3, take your pick! Reply with quote

I've installed the x86 version of Gentoo multiple times, and each time it's been relatively painless - so when I finally got tired of waiting on OSX whenever I'd do, oh well, ANYTHING, I decided I'd give the PPC release of Gentoo a shot.

Which has, consequently, lead to the two most painful days of my life.

Is there some secret "How to REALLY install Gentoo on a PowerMac" document out there that I'm not finding? From reading the various posts here in an effort to find some help, I get the feeling that it /is/ possible, and in fact, quite a large number of people are doing it JUST fine. Myself, however, keep running into rather solid (and painful,) walls wherever I turn.

I first started with a Stage 3 install, since I like the quickness of their installs. For the most part, everything worked beautifully. I never /was/ able to get X to work (all I got was a black screen with faintly flickering lines going across my LCD - hinting that the frequencies were off for the monitor.. except they weren't.)
Stupidly, at one point, I decided to do an 'emerge -u system'. the baselayout package kept failing due to it not having permissions to write to a directory (Sorry, I forget which - this happened yesterday.) - and then, after that proc wouldn't mount on reboot - freezing the system.

Since I hadn't actually done anything with the system yet - I decided to reinstall today, going from a stage 2 this time, since I got the feeling that if I did a stage 3, the emerge -u would just fail again.

First, pam refused to compile due to dependencies on packages that wouldn't get compiled until AFTER pam (automake, if I recall - the iBook is upstairs.)

The biggest problems seem to come with what I've since dubbed the 'evil trio'. Perl, automake, and autoconf.

See, each one of these packages is dependant upon each of the others (Well, perl may not be with automake - I don't remember.) so, no matter which one I install, it fails - because it tries to install one of the other dependancies first, which is of course, dependant on what I'm trying to install.

Obviously, I'm missing something here, and probably something right in front of my face, too. What is the trick for getting this to install on a stage 2? 'emerge system' isn't it - because it just keeps running into this loop.

Do I need to add -perl to my USE variable (and then reinstall perl later,) or will this just cause it to fail somewhere else? (I'm unsure how dependant on perl the base system packages are... you know, never having any problems in the past!)
Back to top
View user's profile Send private message
ralph
Advocate
Advocate


Joined: 02 Mar 2003
Posts: 2001
Location: Hamburg

PostPosted: Sun Feb 29, 2004 9:26 am    Post subject: Reply with quote

Hi, sounds bad and I don't have the slightest idea what it is you are doing that is causing this problems. As for the secret document, did you take a look at this one?

http://www.desertsol.com/~kevin/ppc/
_________________
The computer can't tell you the emotional story. It can give you the exact mathematical design, but what's missing is the eyebrows.
- Frank Zappa
Back to top
View user's profile Send private message
D Hill
n00b
n00b


Joined: 29 Feb 2004
Posts: 5

PostPosted: Sun Feb 29, 2004 2:59 pm    Post subject: Reply with quote

Sounds bad is putting it lightly! ^.^ On the plus side however (and true to the nature of forums, of course,) late last night, I did some off the wall search that I figured wouldn't find anything - provided me with a helpful topic in the forums.
I can't easily provide a link right now, unfortunately, since I'm stuck in lynx at the moment while I read through and decide which kernel to bring down. As it turns out though, with stage2 - if you get the autoconf/automake/perl problem with 'emerge system' like I did all you have to do is uncompress the three packages (say in your /tmp directory,) and then compile and install them manually.
After that, emerge system works like a charm (reinstalling those 3 packages as well, but it works, and that's what's important!)

So, for now, problem solved! For now. Until kernel 2.6 decides to blow up my iBook at least ^_~

Oh! And thanks for the URL - I hadn't seen that document at all - think I'll pour through it for any caveats or other info before I continue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum