Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
D-Link DWL-122 Wireless USB Adapter HOWTO
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
echo6
Guru
Guru


Joined: 04 Jan 2003
Posts: 587

PostPosted: Sat May 22, 2004 6:28 pm    Post subject: Reply with quote

OK, I've remastered the Knoppix cd with the latest linux-wlan-ng drivers etc, the device is seen but I need to conifgure it with my AP manually. As I'm using the Knoppix boot cd I can't edit the /etc/wlan/wlancfg-DEFAULT config file.

Is there a way of configuring WEP etc using the wlanctl-ng command?

I've worked out the following;
Code:
wlanctl-ng wlan0 lnxreq_autojoin="opensystem" ssid="myssid"
wlanctl-ng wlan0 lnxreq_hostwep encrypt=true decrypt=true


There doesn't seem to be away to specify a wep key as you can with iwconfig :-(

btw it works if I disable WEP on my AP, also how do I enable ad-hoc mode?

Anyone??
Back to top
View user's profile Send private message
juliancoccia
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2004
Posts: 91
Location: Opensource World

PostPosted: Tue Sep 14, 2004 12:28 am    Post subject: Reply with quote

I've got it working on Knoppix 3.4 but I have compiled my own kernel (2.6.7) and I have stripped off the hardware recognition on bootup. I am also using ifplugd to configure it automatically when plugged in.
_________________
http://julian.coccia.com
http://www.linuxespanol.com
Back to top
View user's profile Send private message
puelly
n00b
n00b


Joined: 19 Sep 2004
Posts: 3

PostPosted: Sun Sep 19, 2004 10:42 am    Post subject: Reply with quote

I have foloowed the instruction to getting the dwl-122 to wrk. I have been successful to an extent. It only works after i type the ifconfig and route commands. If there a way that I can have hotplug doing this when it loads the drivers? Or is there a was to make it load on boot by using /etc/conf.d/net.

I really want to load the wireless network on boot.

Hope u can help.
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7692
Location: Pelotas, BR

PostPosted: Tue Sep 28, 2004 1:44 pm    Post subject: Reply with quote

Moved from K&H
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
hug0
Guru
Guru


Joined: 02 Mar 2004
Posts: 303

PostPosted: Thu Dec 16, 2004 10:34 pm    Post subject: Reply with quote

hi...
dwl-122 works great but:
Code:

iwlist wlan0 scan
wlan0     Interface doesn't support scanning : Function not implemented


any ideas or is scanning not supported in the prism2 chip?
Back to top
View user's profile Send private message
toaster666
n00b
n00b


Joined: 17 Apr 2004
Posts: 41
Location: Berlin

PostPosted: Tue Jan 04, 2005 3:59 pm    Post subject: Reply with quote

hug0 wrote:
hi...
dwl-122 works great but:
Code:

iwlist wlan0 scan
wlan0     Interface doesn't support scanning : Function not implemented


any ideas or is scanning not supported in the prism2 chip?


Hi,

I got scanning working with following command, where bssid is the MAC of my wlan-device. I have not used all channels because I did not need to scan all :).

Code:
wlanctl-ng wlan0 dot11req_scan bsstype=infrastructure bssid=00:11:95:88:07:A8 ssid="" scantype=both probedelay=200 minchanneltime=100 maxchanneltime=1000 channellist=01:02:03:04:05:06:07:08:09


The results can be fetched with
Code:
wlanctl-ng wlan0 dot11req_scan_results bssindex=0
where bssindex is the index of the result (0 is the first).

I also successfully joined with the
Code:
wlanctl-ng wlan0 lnxreq_autojoin="opensystem" ssid="myssid"
command mentioned above but I can't get an IP. Any ideas? I also do not want to join manually when I plug in the adaptor. Is there a way to do it all automagically?

greetz

>toaster
Back to top
View user's profile Send private message
CrazyYoyimbo
n00b
n00b


Joined: 27 Jun 2005
Posts: 11

PostPosted: Mon Jul 04, 2005 4:10 am    Post subject: Reply with quote

i have the d-link dwl-122. followed the instructions, got it to compile and configure, however i get the following in my dmesg:
Code:
prism2_usb: Unknown symbol p80211netdev_rx
prism2_usb: Unknown symbol register_wlandev
prism2_usb: Unknown symbol wlan_unsetup
prism2_usb: Unknown symbol unregister_wlandev
prism2_usb: Unknown symbol p80211netdev_hwremoved
prism2_usb: Unknown symbol wlan_setup
prism2_usb: Unknown symbol p80211netdev_rx
prism2_usb: Unknown symbol register_wlandev
prism2_usb: Unknown symbol wlan_unsetup
prism2_usb: Unknown symbol unregister_wlandev
prism2_usb: Unknown symbol p80211netdev_hwremoved
prism2_usb: Unknown symbol wlan_setup


any help is greatly appreciated,
CrazyYoyimbo
Back to top
View user's profile Send private message
CrazyYoyimbo
n00b
n00b


Joined: 27 Jun 2005
Posts: 11

PostPosted: Mon Jul 04, 2005 10:47 pm    Post subject: Reply with quote

alright, i've tried using the current ebuild (pre23) and i've also tried manually configuring it from the tar. Manually doing it resulted in an unusable kernel mod. This new module loads, just doesn't work.
if anyone has any ideas of where i can get the pre17 or even pre16 ebuild, it would help out a lot. I've tried googling the filename, but the only results that contain the pre17 ebuilds are the google cache.

thank you for your help,
CrazyYoyimbo
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3221

PostPosted: Tue Jul 26, 2005 5:10 pm    Post subject: Reply with quote

Does anyone know when the pre26 ebuild will be released. There is a bug report for it on bugs.gentoo.org. I tried to use the ebuild posted in the report, but I got some errors, so it looks like I will need to wait for it to officially get into the portage tree.

PS - I'm having troubles with linux-wlan-ng-pre23 and the 2.6.12 kernel. I keep getting hangups when starting /etc/init.d/wlan.
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3221

PostPosted: Mon Aug 01, 2005 2:23 pm    Post subject: Reply with quote

mikegpitt wrote:
Does anyone know when the pre26 ebuild will be released. There is a bug report for it on bugs.gentoo.org. I tried to use the ebuild posted in the report, but I got some errors, so it looks like I will need to wait for it to officially get into the portage tree.

PS - I'm having troubles with linux-wlan-ng-pre23 and the 2.6.12 kernel. I keep getting hangups when starting /etc/init.d/wlan.

I was able to get the pre26 ebuild to work. (I was making a stupid mistake.)

The pre26 seems to stop the hangups I was getting with the pre23 ebuild in the 2.6.12 kernel.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum