Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage problems [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
BlueShift
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2002
Posts: 114
Location: Belgium

PostPosted: Thu Mar 04, 2004 10:19 am    Post subject: Portage problems [solved] Reply with quote

Since a few days I am having all kinds of problems while trying to update packages. For example when I do emerge -up system I get
Code:
$ emerge -up system

These are the packages that I would merge, in order:

Calculating system dependencies |
!!! all ebuilds that could satisfy ">=sys-libs/db-4.1.25" have been masked.
!!! possible candidates are:
- sys-libs/db-4.1.25_p1-r3 (masked by: profile)
- sys-libs/db-4.2.52_p1 (masked by: profile, package.mask, ~keyword)
!!!    (dependency required by "sys-libs/pam-0.77" [ebuild])

!!! Problem with ebuild sys-apps/baselayout-1.8.6.13
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.

and when I try `emerge -up binutils` I get
Code:
$ emerge -up binutils

These are the packages that I would merge, in order:

Calculating dependencies   
!!! all ebuilds that could satisfy "binutils" have been masked.
!!! possible candidates are:
- sys-devel/binutils-2.13.90.0.16-r1 (masked by: profile)
- sys-devel/binutils-2.14.90.0.4.1-r1 (masked by: profile, -keyword)
- sys-devel/binutils-2.11.92.0.12.3-r2 (masked by: profile, missing keyword)
- sys-devel/binutils-2.11.92.0.7 (masked by: profile, missing keyword)
- sys-devel/binutils-2.14.90.0.6-r2 (masked by: profile, ~keyword)
- sys-devel/binutils-2.13.90.0.18 (masked by: profile)
- sys-devel/binutils-2.12.90.0.15 (masked by: profile)
- sys-devel/binutils-2.14.90.0.6-r3 (masked by: profile, ~keyword)
- sys-devel/binutils-2.13.90.0.18-r1 (masked by: profile, ~keyword)
- sys-devel/binutils-2.14.90.0.2 (masked by: profile)
- sys-devel/binutils-2.14.90.0.6-r6 (masked by: profile)
- sys-devel/binutils-2.14.90.0.6-r7 (masked by: profile, ~keyword)
- sys-devel/binutils-2.14.90.0.7-r1 (masked by: profile, ~keyword)
- sys-devel/binutils-2.14.90.0.5-r1 (masked by: profile, ~keyword)
- sys-devel/binutils-2.14.90.0.7 (masked by: profile, -keyword)
- sys-devel/binutils-2.14.90.0.7-r2 (masked by: profile, -keyword)
- sys-devel/binutils-2.14.90.0.7-r3 (masked by: profile, ~keyword)
- sys-devel/binutils-2.14.90.0.7-r4 (masked by: profile, ~keyword)
- sys-devel/binutils-2.14.90.0.8 (masked by: profile, ~keyword)
- sys-devel/binutils-2.14.90.0.8-r1 (masked by: profile, ~keyword)

!!! Error calculating dependencies. Please correct.

So the problem seems to be some profile setting. And indeed, when I look in /usr/portage/profiles/ the only ppc files I find are
Code:
./default-ppc
./default-ppc-1.0
./default-ppc64-1.4
./default-ppc-1.4
./selinux-ppc-1.4
./default-ppc64-2004.0
./default-ppc-2004.0

While I am using Gentoo 1.2 (always kept up to date, but still using gcc-2.95)

Do you think this is something that can be fixed or will I be forced to do the full tedious compiler update to 1.4 or just reinstall Gentoo 2004.0
Thanks for any info,

Jan.


Last edited by BlueShift on Wed Mar 31, 2004 11:33 am; edited 1 time in total
Back to top
View user's profile Send private message
tlcinillinois
n00b
n00b


Joined: 23 Mar 2004
Posts: 2
Location: Urbana, IL

PostPosted: Sun Mar 28, 2004 5:40 pm    Post subject: Reply with quote

I had a similar problem on my sparc. After I did:

Code:

emerge sync


The portage was updated (for the first time) and emerge worked beautifully afterwards.

Good luck,

tlc
Back to top
View user's profile Send private message
BlueShift
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2002
Posts: 114
Location: Belgium

PostPosted: Mon Mar 29, 2004 11:10 am    Post subject: Reply with quote

Thanks, but I think I tried that (would be one of the first things to try I guess) Anyway, I can't check anymore now since I'm reinstalling Gentoo 2004.0 now (it's about time!)

Jan.
Back to top
View user's profile Send private message
SeJo
Retired Dev
Retired Dev


Joined: 08 Oct 2002
Posts: 298
Location: Belgium

PostPosted: Mon Mar 29, 2004 11:30 am    Post subject: Reply with quote

BlueShift,


let us know if it works now.... (will probably work with new install)

greetings
_________________
"I am not bound to please thee with my answers."
Back to top
View user's profile Send private message
BlueShift
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2002
Posts: 114
Location: Belgium

PostPosted: Wed Mar 31, 2004 11:32 am    Post subject: Reply with quote

I 've updated to Gentoo 2004.0 (reinstall) and everything works perfectly now.

Jan.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum