Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Installing Internet Explorer 6 with wine
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Fri Jul 30, 2004 7:28 pm    Post subject: Reply with quote

When I install IE on 20040716 I don't need to modify system.reg. The first instructions work for me. Downgrade to 20040615 and try to install IE again, then upgrade.
And Frank's Corner is down. :?


Last edited by Mirrorball on Sat Jul 31, 2004 7:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
Zoombie
n00b
n00b


Joined: 11 Oct 2003
Posts: 8
Location: Boston

PostPosted: Sat Jul 31, 2004 7:52 pm    Post subject: Reply with quote

I followed your instructions exactly for 20040716, and it's working pretty well. I can start Internet Explorer and browse web pages. However, I have 3 problems: IE won't display PNG images, it won't run Javascript, and it crashes occasionally while entering a new address in the location bar.

The third problem I don't mind so much, but I installed IE so that I could test my web designs without rebooting. I need to be able to see PNGs and run JS to do so. Has anybody else had these same problems?
_________________
Hail Doros.
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Sat Jul 31, 2004 7:56 pm    Post subject: Reply with quote

Quote:

8b) PNG support
Extract ADVAUTH.CAB from ~/.wine/fake_windows/Windows/Windows Update Setup Files with cabextract. Copy pngfilt.dll to ~/.wine/fake_windows/Windows/System/
Back to top
View user's profile Send private message
Zoombie
n00b
n00b


Joined: 11 Oct 2003
Posts: 8
Location: Boston

PostPosted: Sat Jul 31, 2004 9:56 pm    Post subject: Reply with quote

Mirrorball wrote:
Quote:

8b) PNG support
Extract ADVAUTH.CAB from ~/.wine/fake_windows/Windows/Windows Update Setup Files with cabextract. Copy pngfilt.dll to ~/.wine/fake_windows/Windows/System/

That's not in the instructions for 20040716. After following the first set of instructions, I have no directory called "Windows Update Setup Files." There is a file in Windows/System called pngfilt.dll...

Shoud I rerun the installer and choose "Download Only?"
_________________
Hail Doros.
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Sat Jul 31, 2004 11:37 pm    Post subject: Reply with quote

If pngfilt.dll is already on Windows/System I don't know why IE doesn't display PNGs. Install IE again using wine 20040615.
Back to top
View user's profile Send private message
franzb
n00b
n00b


Joined: 16 Jul 2004
Posts: 32
Location: Italy

PostPosted: Thu Aug 05, 2004 6:28 am    Post subject: msjvm Reply with quote

thanks to the guides here the installation of ie6 with ssl was quite easy.

Unfortunately I'm not able to install the jvm from ms. During Installation an error occurs: "Unhandled exception 0x80000004..." and afterwards java is not working.

It would be nice if you could give me any help.

franzb
Back to top
View user's profile Send private message
eee
Tux's lil' helper
Tux's lil' helper


Joined: 29 May 2003
Posts: 115
Location: MD

PostPosted: Mon Aug 09, 2004 12:13 pm    Post subject: Reply with quote

Zoombie wrote:
I followed your instructions exactly for 20040716, and it's working pretty well. I can start Internet Explorer and browse web pages. However, I have 3 problems: IE won't display PNG images, it won't run Javascript, and it crashes occasionally while entering a new address in the location bar.

The third problem I don't mind so much, but I installed IE so that I could test my web designs without rebooting. I need to be able to see PNGs and run JS to do so. Has anybody else had these same problems?

For PNG support, I found that I had to install the reg from the second install method. I couldn't figure out how to get the png dll to register otherwise. I thought about trying to isolate the particular registry entry that was necessary, but didn't think that it was worth the bother.

I haven't tried javascript and probably won't. I'm of the camp that believes javascript can be used to improve the UI experience, but should not be required to actually use a web app. So what if the little JS icon is showing up in the status bar? They're just IE users after all :wink:

As for the crashing when entering a new address, I was able to prevent that after disabling address bar autocomplete. Tools -> Options -> Content -> AutoComplete. I disabled all of the auto complete options. They enhance everyday use, but IE is only useful for testing applications and these options just get in the way of that.

Hope that helps!

Chris
Back to top
View user's profile Send private message
DebentooGaoX
n00b
n00b


Joined: 24 Aug 2004
Posts: 5

PostPosted: Tue Aug 24, 2004 2:09 pm    Post subject: Reply with quote

I use the first method of the Howto,I can get the IE6 SP1 working by wine20040716,but it can't run any ActiveX pages coirrectly.for example,the site http://bt.btchina.net , it can't search out anything by its searchtools,but IE in CrossOverOffice Demo version 3.0.1 can find out many results.it can't automaticlly display any plugin install windowm now,like flash plugins

Please help me.
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Tue Aug 24, 2004 3:43 pm    Post subject: Reply with quote

DebentooGaoX wrote:
I use the first method of the Howto,I can get the IE6 SP1 working by wine20040716,but it can't run any ActiveX pages coirrectly.for example,the site http://bt.btchina.net , it can't search out anything by its searchtools,but IE in CrossOverOffice Demo version 3.0.1 can find out many results.it can't automaticlly display any plugin install windowm now,like flash plugins


I suggest you downgrade to 20040615.
Back to top
View user's profile Send private message
DebentooGaoX
n00b
n00b


Joined: 24 Aug 2004
Posts: 5

PostPosted: Wed Aug 25, 2004 3:09 am    Post subject: Reply with quote

Mirrorball wrote:
DebentooGaoX wrote:
I use the first method of the Howto,I can get the IE6 SP1 working by wine20040716,but it can't run any ActiveX pages coirrectly.for example,the site http://bt.btchina.net , it can't search out anything by its searchtools,but IE in CrossOverOffice Demo version 3.0.1 can find out many results.it can't automaticlly display any plugin install windowm now,like flash plugins


I suggest you downgrade to 20040615.


Can I emerge 20040615-r1,My arch is ~x86,there's only 20040615-r1 in my portage
Back to top
View user's profile Send private message
DebentooGaoX
n00b
n00b


Joined: 24 Aug 2004
Posts: 5

PostPosted: Wed Aug 25, 2004 6:04 am    Post subject: Reply with quote

When I run wine2004-615-r1,it crashed

debentoogao@finalbaby ~ $ WINEDLLOVERRIDES="ole32=n" wine dcom98.exe
/usr/bin/wine: line 55: 17936 Segmentation fault WINEDEBUG=-all "$RUNWINE" "$@"
I use the 'nptl" USE
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Wed Aug 25, 2004 9:37 am    Post subject: Reply with quote

r1 never worked well for me. Modify the ebuild, deleting some of the patches applied.
Back to top
View user's profile Send private message
DebentooGaoX
n00b
n00b


Joined: 24 Aug 2004
Posts: 5

PostPosted: Wed Aug 25, 2004 10:31 am    Post subject: Reply with quote

Mirrorball wrote:
r1 never worked well for me. Modify the ebuild, deleting some of the patches applied.

Could you give me ebuild? I don't know where should I edit. Thanks a lot
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Wed Aug 25, 2004 6:49 pm    Post subject: Reply with quote

Code:

# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20040615-r1.ebuild,v1.3 2004/08/03 15:44:30 mholzer Exp $

inherit eutils base

DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
HOMEPAGE="http://www.winehq.com/"
SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
         mirror://gentoo/${P}-fake_windows.tar.bz2
         mirror://gentoo/${P}-misc.tar.bz2"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 -*"
IUSE="X alsa arts cups debug nas nptl opengl tcltk"

DEPEND="sys-devel/gcc
        sys-devel/flex
        >=sys-libs/ncurses-5.2
        >=media-libs/freetype-2.0.0
        X? ( virtual/x11 )
        tcltk? ( dev-lang/tcl dev-lang/tk )
        arts? ( kde-base/arts )
        alsa? ( media-libs/alsa-lib )
        nas? ( media-libs/nas )
        cups? ( net-print/cups )
        opengl? ( virtual/opengl )
        >=sys-apps/sed-4"

src_unpack() {
        unpack Wine-${PV}.tar.gz
        cd ${S}
        epatch ${FILESDIR}/winearts-kdecvs-fix.patch
        epatch ${FILESDIR}/QueryActCtxw_Photoshop7.0.diff
        # epatch ${FILESDIR}/scrollbars.diff
}

src_compile() {
        # there's no configure flag for cups, arts, alsa and nas, it's supposedto be autodetected

        unset CFLAGS CXXFLAGS LDFLAGS

        ac_cv_header_jack_jack_h=no \
        ac_cv_lib_soname_jack= \
        ./configure \
                --prefix=/usr/lib/wine \
                --sysconfdir=/etc/wine \
                --host=${CHOST} \
                --enable-curses \
                `use_enable opengl` \
                `use_with nptl` \
                `use_enable debug trace` \
                `use_enable debug` \
                || die "configure failed"

        cd ${S}/programs/winetest
        sed -i 's:wine.pm:include/wine.pm:' Makefile

        # No parallel make
        cd ${S}
        make depend all || die
        cd programs && emake || die
}

src_install() {
        local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"

        ### Install wine to ${D}
        make ${WINEMAKEOPTS} install || die
        cd ${S}/programs
        make ${WINEMAKEOPTS} install || die

        # Needed for later installation
        dodir /usr/bin

        ### Creation of /usr/lib/wine/.data
        # Setting up fake_windows
        dodir /usr/lib/wine/.data
        cd ${D}/usr/lib/wine/.data
        tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
        chown root:root fake_windows/ -R

        # Unpacking the miscellaneous files
        tar jxvf ${DISTDIR}/${P}-misc.tar.bz2
        chown root:root config

        # moving the wrappers to bin/
        insinto /usr/bin
        dobin regedit-wine wine winedbg wine-pthread
        rm regedit-wine wine winedbg wine-pthread

        # copying the wine.inf into .data (used to be winedefault.reg)
        cd ${S}
        dodir /usr/lib/wine/.data
        insinto /usr/lib/wine/.data
        doins tools/wine.inf
        insinto /usr/lib/wine/.data/fake_windows/Windows/System
        doins tools/wine.inf
        insinto /usr/lib/wine/.data/fake_windows/Windows/Inf
        doins tools/wine.inf

        ### Misc tasks
        # Take care of the documentation
        cd ${S}
        dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README

        # Manpage setup
        cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
        doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
        rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
        doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
        rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5

        # Remove the executable flag from those libraries.
        cd ${D}/usr/lib/wine/lib/wine
        chmod a-x *.so
}

pkg_postinst() {
        einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
        einfo "which will take care of everything else."
        einfo ""
        einfo "if you have problems with nptl, use wine-pthread to start wine"
        einfo ""
        einfo "Use /usr/bin/regedit-wine to import registry files into the"
        einfo "wine registry."
}
Back to top
View user's profile Send private message
spav
n00b
n00b


Joined: 09 Jun 2004
Posts: 1

PostPosted: Fri Aug 27, 2004 1:25 pm    Post subject: Reply with quote

And what about JavaScript? Is there any method to use it in IE under Gentoo?
Back to top
View user's profile Send private message
tomthewombat
Apprentice
Apprentice


Joined: 29 Mar 2003
Posts: 244
Location: NY State

PostPosted: Sat Aug 28, 2004 12:50 am    Post subject: Reply with quote

I am having some trouble doing the first method on any version of wine.

At the end of installing dcom98.exe, wine will just hang up at 100% CPU usage. I ctrl+c out and run ie6setup, but it just hangs up after folder does not exist, would you like to create folder.

nptl, reiser4.. but i doubt those should matter. oh yeah, pic, but i haven't run prelink. I would really like to get this working again to make checking my sites easier.
_________________
http://www.wombatorium.net
Back to top
View user's profile Send private message
tomthewombat
Apprentice
Apprentice


Joined: 29 Mar 2003
Posts: 244
Location: NY State

PostPosted: Sun Aug 29, 2004 1:48 am    Post subject: Reply with quote

Reiser4 was the problem. Don't try to run a fake_windows as Reiser4 (and don't mount your / as z: if it's reiser4)
_________________
http://www.wombatorium.net
Back to top
View user's profile Send private message
chrono325
n00b
n00b


Joined: 13 Jul 2004
Posts: 39

PostPosted: Fri Sep 03, 2004 3:46 am    Post subject: Reply with quote

Okay, I have IE installed, and when I try to run it, it shows up for like a half second, and then goes away. I am running wine version 20040716. I get the following errors when I run WINEDEBUG=warn+all wine ~/.wine/fake_windows/Program\ Files/Internet\ Explorer/IEXPLORE.EXE
Code:
warn:dosfs:DOSFS_FindUnixName L"Profiles\\Administrator" not found in '/home/frochild/.wine/dosdevices/c:/Windows'
warn:dosfs:DOSFS_FindUnixName L"system32\\config\\system" not found in '/home/frochild/.wine/dosdevices/c:/Windows'
warn:dosfs:DOSFS_FindUnixName L"system.dat" not found in '/home/frochild/.wine/dosdevices/c:/Windows'
warn:dosfs:DOSFS_FindUnixName L"reg.dat" not found in '/home/frochild/.wine/dosdevices/h:/iesetup'
warn:file:CreateFileW Unable to get full filename from L".\\reg.dat" (GLE 2)
warn:dosfs:DOSFS_FindUnixName L"reg.dat" not found in '/home/frochild/.wine/dosdevices/c:/Windows/System'
warn:file:CreateFileW Unable to get full filename from L"C:\\Windows\\System\\reg.dat" (GLE 2)
warn:dosfs:DOSFS_FindUnixName L"reg.dat" not found in '/home/frochild/.wine/dosdevices/c:/Windows'
warn:file:CreateFileW Unable to get full filename from L"C:\\Windows\\reg.dat" (GLE 2)
warn:dosfs:DOSFS_FindUnixName L"reg.dat" not found in '/home/frochild/.wine/dosdevices/c:/Windows'
warn:file:CreateFileW Unable to get full filename from L"c:\\Windows\\reg.dat" (GLE 2)
warn:dosfs:DOSFS_FindUnixName L"reg.dat" not found in '/home/frochild/.wine/dosdevices/c:/Windows/System'
warn:file:CreateFileW Unable to get full filename from L"c:\\Windoows\\System\\reg.dat" (GLE 2)
And so on. A window, titled "Download could not complete!" says "http_400.htm from C:\Windows\System\shdoclc.dll" I am sure that I have "mshtml"="native" in my ~/.wine/config
_________________
Person me = new N00b();

Playing russian roulette with Reiser4 since 9/10/04.
Pentium 4 Northwood 2.4Ghz, NPTL, udev, initng, gentoo-sources-2.6.11-r6 with reiser4: How would you like to hardlock today?
Back to top
View user's profile Send private message
TazG
Guru
Guru


Joined: 22 May 2004
Posts: 320
Location: Canada

PostPosted: Thu Sep 23, 2004 11:28 am    Post subject: Reply with quote

I need some help here. When I run ie6setup it gives a bunch of errors about ThunkConnect and it crashes when it tries to start downloading, saying it was unable to download. In the meantime Wine is giving me this error
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
over and over. I tried running ie6setup again after downloading setupx.dll but the same thing happened.
Back to top
View user's profile Send private message
Cheesepie
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 154

PostPosted: Tue Sep 28, 2004 9:06 am    Post subject: Reply with quote

following the original guide with the latest version of wine, when I do a "wine wineboot" after installing IE I get "ThunkConnect32 Failure!"

Its the exact same problem TazG is having :|


----
Nevermind, I got it working by upgrading to version *615

Now someone needs to create an IE button for kroller :)

----

Nevermind again. Heres a transparent 128x128 IE.png for karamba/kroller users:
http://cheesepie.net/p/speakerguy/ie.png
Back to top
View user's profile Send private message
cptmorgan
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jan 2004
Posts: 129
Location: California

PostPosted: Mon Oct 04, 2004 4:34 am    Post subject: Re: No system.reg! Reply with quote

ravingsanity wrote:
I'm running wine 20040716 and I followed the first set of directions. Everything seemed to go well and just as expected. However, when I try to run IEXPLORE.EXE, nothing happens. The command prompt returns with no errors and no IE either! I saw a couple other posts in here that suggested to me that I needed the system.reg file (and, btw, that's step 11 from the second set of directions but it is absent in the first set! It goes from 10 directly to 12) but when I went to the link, Frank's Corner had been taken down! Does anyone know where I can get this file or another way to work around this problem?


I get the same exact results and still have yet to find a answer.... anyone know a way to debug even though no error being displayed
Back to top
View user's profile Send private message
RealGeizt
l33t
l33t


Joined: 22 Apr 2003
Posts: 700

PostPosted: Sun Oct 10, 2004 12:04 pm    Post subject: Reply with quote

I'm trying to install Internet Explorer but Windows Update isn't downloading any files.
The Setup says that i have no connection to the internet but my internet works.
What can i do?
Back to top
View user's profile Send private message
RealGeizt
l33t
l33t


Joined: 22 Apr 2003
Posts: 700

PostPosted: Sun Oct 10, 2004 9:33 pm    Post subject: Reply with quote

the second way worked for me!
thank you for this great howto :)
Back to top
View user's profile Send private message
pontifikas
Tux's lil' helper
Tux's lil' helper


Joined: 17 Aug 2003
Posts: 138
Location: Greece

PostPosted: Sun Oct 17, 2004 2:51 pm    Post subject: Reply with quote

How about mplayer support?Does it have one?

I only need IE to listen to a specific radiostation on-line.
It uses media-player and it does not open on firefox.
_________________
Crimes against humanity??Dunno!!Maybe that chimp-face guy over there can help you.
Ehrr...don't push him hard though.He's kinda slow.
Back to top
View user's profile Send private message
Illissius
Guru
Guru


Joined: 31 Jul 2004
Posts: 395
Location: Hungary

PostPosted: Tue Oct 19, 2004 4:29 pm    Post subject: Reply with quote

A variation on kanaric's method finally worked for me. Here's what I did, in case it's of help to anyone. This is with wine 20040716.

Code:
mkdir ~/iesetup
cd iesetup
/* download dcom98, setupx.dll, and ie6setup.exe */
rm -rf ~/.wine
wine
WINEDLLOVERRIDES="ole32=n" wine DCOM98.EXE
cp setupx.dll ~/.wine/fake_windows/Windows/System/
wine ie6setup.exe  /* at installation options, go to 'advanced', select download only (this is so you don't have to redownload everything if it ends up not working) */
cp ~/.wine/fake_windows/Windows\ Update\ Setup\ Files/* .
cp ~/.wine/config .
/* edit iesetup/config according to kanaric's post, or whatever else you feel like trying */

That was preparing things so you only have to do a minimal amount of stuff between retries.
Then:

Code:
rm -rf ~/.wine; wine; mkdir ~/.wine/fake_windows/Windows\ Update\ Setup\ Files/; cp ~/iesetup/* ~/.wine/fake_windows/Windows\ Update\ Setup\ Files/; WINEDLLOVERRIDES="ole32=n" wine DCOM98.EXE; cp setupx.dll ~/.wine/fake_windows/Windows/System/; cp config ~/.wine/config
cd ~/.wine/fake_windows/Windows\ Update\ Setup\ Files/
wine ie6setup.exe /* minimal install, delete a \ from the path, unselect everything except 'internet explorer 6 browser'. you might leave vbscript enabled, but I didn't because it's useless; I had a single error during the install process, but it didn't crash - I got to the end and clicked the 'Finish' button */
wine wineboot /* I had an error or two here, but nothing close to the minutes of continually pressing 'ok' to ThunkConnect errors and whatever that I had with previous, unsuccessful attempts */
wine ~/.wine/fake_windows/Program\ Files/Internet\ Explorer/IEXPLORE.EXE http://www.google.com/ (msn is the default site, and some sort of script on it causes IE to crash - the irony...)


Don't ask me what the difference is between kanaric's method and this, because I don't see much, but that the former didn't work for me, and this does. *shrug*
_________________
Work is punishment for failing to procrastinate effectively.
last.fm
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 10, 11, 12  Next
Page 6 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum