Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Installing Internet Explorer 6 with wine
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
EricHsu
Bodhisattva
Bodhisattva


Joined: 03 May 2004
Posts: 591
Location: Aragon Consulting Group, Beijing, China

PostPosted: Thu Oct 21, 2004 1:52 pm    Post subject: Reply with quote

hey guys, i've got IE6 installed successfully with this howto! that's
great!

why did i finally have to use IE?! because a damned recruitment
website requires only >=IE 5.0 with ActiveX support to apply jobs
listed on them! There're jobs I really want! and the company (you
guess, one of biggest "monsters" in the world) offers even
Linux/Unix related jobs via this recruitment website! that means, I,
the one who has his box running gentoo only, have to run IE, to
apply those linux jobs!! :evil:

now, the ie6 runs, but, but, but... each time i log on that website
and the recruitment webpage provided by the company, IE says:

Code:

Your current security settings prohibit running ActiveX control on
this page. As a result, the page may not display correctly.


I've set the security to "low" via Tools -> Internet Options -> Security
... so here comes my question:

1. doesn't wine support activex already?
2. if so, is this problem has something to do with the privilege
settings of the ~/.wine dir?
_________________
- http://nkbit.com
- http://twitter.com/xuyihua
Back to top
View user's profile Send private message
Florianbur
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2004
Posts: 83

PostPosted: Sat Oct 23, 2004 8:18 pm    Post subject: Reply with quote

Illissius wrote:
A variation on kanaric's method finally worked for me. Here's what I did, in case it's of help to anyone. This is with wine 20040716.

Code:
mkdir ~/iesetup
cd iesetup
/* download dcom98, setupx.dll, and ie6setup.exe */
rm -rf ~/.wine
wine
WINEDLLOVERRIDES="ole32=n" wine DCOM98.EXE
cp setupx.dll ~/.wine/fake_windows/Windows/System/
wine ie6setup.exe  /* at installation options, go to 'advanced', select download only (this is so you don't have to redownload everything if it ends up not working) */
cp ~/.wine/fake_windows/Windows\ Update\ Setup\ Files/* .
cp ~/.wine/config .
/* edit iesetup/config according to kanaric's post, or whatever else you feel like trying */

That was preparing things so you only have to do a minimal amount of stuff between retries.
Then:

Code:
rm -rf ~/.wine; wine; mkdir ~/.wine/fake_windows/Windows\ Update\ Setup\ Files/; cp ~/iesetup/* ~/.wine/fake_windows/Windows\ Update\ Setup\ Files/; WINEDLLOVERRIDES="ole32=n" wine DCOM98.EXE; cp setupx.dll ~/.wine/fake_windows/Windows/System/; cp config ~/.wine/config
cd ~/.wine/fake_windows/Windows\ Update\ Setup\ Files/
wine ie6setup.exe /* minimal install, delete a \ from the path, unselect everything except 'internet explorer 6 browser'. you might leave vbscript enabled, but I didn't because it's useless; I had a single error during the install process, but it didn't crash - I got to the end and clicked the 'Finish' button */
wine wineboot /* I had an error or two here, but nothing close to the minutes of continually pressing 'ok' to ThunkConnect errors and whatever that I had with previous, unsuccessful attempts */
wine ~/.wine/fake_windows/Program\ Files/Internet\ Explorer/IEXPLORE.EXE http://www.google.com/ (msn is the default site, and some sort of script on it causes IE to crash - the irony...)


Don't ask me what the difference is between kanaric's method and this, because I don't see much, but that the former didn't work for me, and this does. *shrug*


Just wanted to give some feedback...

Still new to linux, I got this working without any problems...

If you are new to wine, like me, don't bother reading the wine installation guide. Well you can, but it isn't necessary. Simply emerge ~x86 wine, don't run wine before switching to ur user and then follow above guide. The URLs are not all working anymore, but just enter the file name into google.

Thanks for all the work done by others :)
Back to top
View user's profile Send private message
Illissius
Guru
Guru


Joined: 31 Jul 2004
Posts: 395
Location: Hungary

PostPosted: Sat Oct 23, 2004 11:02 pm    Post subject: Reply with quote

Update: the install seems to have gotten b0rked somehow, which is odd as I didn't do anything particularly abusive with it. long story short, now whenever I go to a site, instead of opening it, it asks to save it (as if it were a .exe or something IE can't open natively) - if I select 'open' on the save dialog, it gives an error something like
Code:
couldn't open file "\\C:\path\to\file"
the odd part is how that \\ got there... (the " is either before or after the \\, can't remember). Anyways, a reinstall will probably fix it, but I don't want to right now, and I'm wondering why it even got b0rked in the first place o_O.
_________________
Work is punishment for failing to procrastinate effectively.
last.fm
Back to top
View user's profile Send private message
Lepaca Kliffoth
l33t
l33t


Joined: 28 Apr 2004
Posts: 737
Location: Florence, Italy

PostPosted: Wed Nov 03, 2004 2:29 pm    Post subject: Reply with quote

Ugh I can't install dcom98. Wine just takes up 100% cpu and stays there. This happens right after I accept the agreement.
_________________
It isn't enough to win - everyone else must lose, and you also have to rub it in their face (maybe chop off an arm too for good measure).
Animebox!
Back to top
View user's profile Send private message
Gnufsh
Guru
Guru


Joined: 28 Dec 2002
Posts: 400
Location: Portland, OR

PostPosted: Wed Nov 03, 2004 4:36 pm    Post subject: Reply with quote

If IE just tries to download the file, you need to set "mshtml" = "native" in the appdefaults dlloverides for iexplore.exe.

I have the same problem with dcom98. I tried killing it and going on with the installation, but no luck here.
Back to top
View user's profile Send private message
theonlymcc
Apprentice
Apprentice


Joined: 16 Sep 2003
Posts: 274
Location: NC

PostPosted: Wed Nov 10, 2004 4:15 pm    Post subject: Reply with quote

I am using wine-20041019 and I get page-faults when trying to install IE6. Tried all sorts of wine-configs, dlloverrides, etc. Maybe wine-20041019-r3 might help
Back to top
View user's profile Send private message
jhgz1
Retired Dev
Retired Dev


Joined: 16 Dec 2003
Posts: 115
Location: Gainesville

PostPosted: Sat Nov 13, 2004 2:26 am    Post subject: Reply with quote

running wine-20041019, no way getting it working.
the strange thing is: it doesn't even work with a clean install of crossover office.
i completely redid my system, but there were nearly no changes...this could be from sp1 for ie6, but i doubt it.
_________________
Bei Gentoo mithelfen wollen und kein Programmierer? Gentoo sucht Übersetzer, die bereit sind kontinuierlich mitzuarbeiten.
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Sat Nov 13, 2004 4:20 am    Post subject: Reply with quote

I couldn't get it to work with the new Wine either. Isn't it strange that things stop working with new, supposedly better versions of a program?
Back to top
View user's profile Send private message
Skinkie
n00b
n00b


Joined: 13 Nov 2004
Posts: 27
Location: The Netherlands

PostPosted: Sat Nov 13, 2004 7:40 pm    Post subject: Reply with quote

Mirrorball wrote:
I couldn't get it to work with the new Wine either. Isn't it strange that things stop working with new, supposedly better versions of a program?

I get IE6 installed, but when trying to run it, wine just stops right after hitting enter. With -r3 new version I can't even install via method one.
_________________
Support Eachother, Copy Dutch Property!
Back to top
View user's profile Send private message
tscolari
l33t
l33t


Joined: 02 May 2004
Posts: 602
Location: curitiba - pr - Brazil

PostPosted: Mon Nov 15, 2004 3:19 am    Post subject: Reply with quote

have anyone tested this with winex/cedega?

like there are games that need ie to run, maybe with it installed...
_________________
------------------------------------
Tiago Scolari
Back to top
View user's profile Send private message
navert
n00b
n00b


Joined: 03 Sep 2004
Posts: 7

PostPosted: Tue Nov 16, 2004 4:17 pm    Post subject: Javascript in IE/Wine Reply with quote

The intructions were great. It was easier than I thought, though I had a huge pause in the installation before the error showed which worried me. You might want to mention that, if it is common.

My question is that javascript doesn't seem to be working for me. I have forced IE to confirm all the scripts, which it dutifully does, so it knows they are there. But it won't run them. I am developing a site that the main users are Windows IE (they can't use firefox because of internal websites that need activeX) and the site needs some javascript functionality (I have tried to design it without javascript, but it is quite difficult and not as user friendly). I would like to be able to test it while in Linux, without having to reboot. It seems that firefox parses javascript a bit differently than IE. So does any one know how to make javascript work in IE on wine? Or does anyone know a linux based javascript engine that renders identical to IE (I just need to make sure that the script is cross-browser)?

Thanks
Back to top
View user's profile Send private message
gentoo_lan
l33t
l33t


Joined: 08 Sep 2004
Posts: 890
Location: Charles Town, WV

PostPosted: Fri Nov 19, 2004 11:26 am    Post subject: Reply with quote

Is there any way to change the homepage or do you have to have MSN as your homepage?
Back to top
View user's profile Send private message
tscolari
l33t
l33t


Joined: 02 May 2004
Posts: 602
Location: curitiba - pr - Brazil

PostPosted: Sun Nov 21, 2004 10:47 pm    Post subject: Reply with quote

are there somehow to install java/flash plugins on it?
_________________
------------------------------------
Tiago Scolari
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Tue Nov 23, 2004 10:16 pm    Post subject: Reply with quote

It's possible to install Flash.
Back to top
View user's profile Send private message
tscolari
l33t
l33t


Joined: 02 May 2004
Posts: 602
Location: curitiba - pr - Brazil

PostPosted: Tue Nov 23, 2004 10:59 pm    Post subject: Reply with quote

Mirrorball wrote:
It's possible to install Flash.


everything i tryed says that my current security settings prohibit me from runing ActiveX controls on this page...

Ive even setted the lowest security and still this =/
_________________
------------------------------------
Tiago Scolari
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Sun Nov 28, 2004 4:22 pm    Post subject: Reply with quote

Has anyone tried this script?

http://sidenet.ddo.jp/winetips/config.html

Yes, it works. :D


Last edited by Mirrorball on Mon Nov 29, 2004 12:56 am; edited 1 time in total
Back to top
View user's profile Send private message
Illissius
Guru
Guru


Joined: 31 Jul 2004
Posts: 395
Location: Hungary

PostPosted: Sun Nov 28, 2004 5:32 pm    Post subject: Reply with quote

How? For me it just gives unhandled page faults and hangs.
_________________
Work is punishment for failing to procrastinate effectively.
last.fm
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Mon Nov 29, 2004 12:54 am    Post subject: Reply with quote

Maybe it's because I didn't update to wine-20041019-r3.
Back to top
View user's profile Send private message
Illissius
Guru
Guru


Joined: 31 Jul 2004
Posts: 395
Location: Hungary

PostPosted: Tue Nov 30, 2004 3:58 pm    Post subject: Reply with quote

Mirrorball wrote:
Maybe it's because I didn't update to wine-20041019-r3.

Yep, downgraded to the previous version and it works now.
_________________
Work is punishment for failing to procrastinate effectively.
last.fm
Back to top
View user's profile Send private message
rrrkkkttt
Tux's lil' helper
Tux's lil' helper


Joined: 02 Oct 2003
Posts: 96

PostPosted: Wed Dec 01, 2004 12:45 am    Post subject: Reply with quote

what version did you downgrade it to? I have that same ~x86 ver and ie6setup.exe quits in the middle of install and the wine-sidenet-config setup script keeps on running ie setup again and again...
Back to top
View user's profile Send private message
Illissius
Guru
Guru


Joined: 31 Jul 2004
Posts: 395
Location: Hungary

PostPosted: Wed Dec 01, 2004 4:48 pm    Post subject: Reply with quote

Code:
$ etcat versions wine
[ Results for search key           : wine ]
[ Candidate applications found : 3 ]

 Only printing found installed programs.

*  app-emulation/wine :
        [  I] 20040716 (0) OVERLAY
        [   ] 20041019 (0) OVERLAY
        [ ~ ] 20041019-r3 (0) OVERLAY

I still get an error somewhere (before IE), to which you have to say 'no' or it hangs, but IE itself installs (and works) fine after that.
_________________
Work is punishment for failing to procrastinate effectively.
last.fm
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Wed Dec 01, 2004 11:54 pm    Post subject: Reply with quote

IE installs perfectly here on Wine 20041019-r3. I compiled Wine with there USE flags: "+X +alsa +arts +cups -debug +doc +gif -glut -jack +jpeg +lcms -nas +ncurses +opengl +oss". Script v. 1.62 and not silent installation.
Back to top
View user's profile Send private message
Debentoo_Gao
Tux's lil' helper
Tux's lil' helper


Joined: 21 Nov 2003
Posts: 85
Location: Shanghai,China

PostPosted: Thu Dec 02, 2004 5:33 am    Post subject: Reply with quote

Mirrorball wrote:
IE installs perfectly here on Wine 20041019-r3. I compiled Wine with there USE flags: "+X +alsa +arts +cups -debug +doc +gif -glut -jack +jpeg +lcms -nas +ncurses +opengl +oss". Script v. 1.62 and not silent installation.

I use the wine-20041019,but when the IE installation finnished,it hanged,no errors
_________________
More Love~~More Dream~~More Happiness

Free Your Mind~~Free Your Body~~Free Your Life

http://www.myblue.ws
Back to top
View user's profile Send private message
navert
n00b
n00b


Joined: 03 Sep 2004
Posts: 7

PostPosted: Fri Dec 03, 2004 3:40 pm    Post subject: Javascript? Reply with quote

I was wondering if any of you have javascript running properly with IE on wine-20040716. It looks like IE finds the javascripts because when I tell IE to ask for confirmation before running a script, it does just that. But, the script doesn't work. Anybody have any idea, or can point me to a place that could solve my problem?

Thanks
Back to top
View user's profile Send private message
Gnufsh
Guru
Guru


Joined: 28 Dec 2002
Posts: 400
Location: Portland, OR

PostPosted: Fri Dec 03, 2004 11:15 pm    Post subject: Reply with quote

Looks like a new version of wine is in ~x86, maybe this one will work for me (previously both dcom98 and ie setup have hung at various points with 100% cpu useage). I'll try this evening.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 10, 11, 12  Next
Page 7 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum