Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Installing Internet Explorer 6 with wine
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 7, 8, 9, 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Sat Dec 04, 2004 10:12 pm    Post subject: Reply with quote

I'm compiling it too and if it works, I'm going to post the procedure in detail.
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Mon Dec 06, 2004 2:33 am    Post subject: Reply with quote

It works but the programs are slow and the toolbar icons disappeared. :(
Back to top
View user's profile Send private message
fatboyjim
Apprentice
Apprentice


Joined: 12 Jul 2004
Posts: 227
Location: UK

PostPosted: Tue Dec 07, 2004 12:15 am    Post subject: Reply with quote

Anybody got that script to work?

I'm just getting an error :'(

Checking if ie6setup needs to be re-started.. or something :D
_________________
-----------------------
fatboyjim
Gentoo/AMD64 Arch Tester (Inactive)
Back to top
View user's profile Send private message
fatboyjim
Apprentice
Apprentice


Joined: 12 Jul 2004
Posts: 227
Location: UK

PostPosted: Wed Dec 08, 2004 5:45 pm    Post subject: Reply with quote

rrrkkkttt wrote:
what version did you downgrade it to? I have that same ~x86 ver and ie6setup.exe quits in the middle of install and the wine-sidenet-config setup script keeps on running ie setup again and again...


Yup, same problem here

Can't get the ebuild on page 7 to work either... :cry:

Jim
_________________
-----------------------
fatboyjim
Gentoo/AMD64 Arch Tester (Inactive)
Back to top
View user's profile Send private message
dju`
Retired Dev
Retired Dev


Joined: 11 Feb 2003
Posts: 370

PostPosted: Wed Dec 08, 2004 7:07 pm    Post subject: Reply with quote

https won't work with the sidenet script, or did i miss something?
Back to top
View user's profile Send private message
rrrkkkttt
Tux's lil' helper
Tux's lil' helper


Joined: 02 Oct 2003
Posts: 96

PostPosted: Thu Dec 09, 2004 8:27 am    Post subject: Reply with quote

fatboyjim wrote:
rrrkkkttt wrote:
what version did you downgrade it to? I have that same ~x86 ver and ie6setup.exe quits in the middle of install and the wine-sidenet-config setup script keeps on running ie setup again and again...


Yup, same problem here

Can't get the ebuild on page 7 to work either... :cry:

Jim



Did you figure out any way to get the script to work?
Back to top
View user's profile Send private message
markandrew
Apprentice
Apprentice


Joined: 04 Feb 2004
Posts: 176
Location: Manchester, UK

PostPosted: Thu Dec 09, 2004 11:36 am    Post subject: Reply with quote

the sidenet script installs ie for me ok, but all the fonts are buggered - all the characters are question-marks (with a few squares for good measure). is there a simple solution to this, like a font setting in the config file or something? i selected 'en' for the language but evidently that makes no difference...
Back to top
View user's profile Send private message
fatboyjim
Apprentice
Apprentice


Joined: 12 Jul 2004
Posts: 227
Location: UK

PostPosted: Fri Dec 10, 2004 12:55 am    Post subject: Reply with quote

There is a config file to download from the same website as the script, copy that to ./wine/config ?

That's just a guess mind... mine doesn't work ;-)

Jim
_________________
-----------------------
fatboyjim
Gentoo/AMD64 Arch Tester (Inactive)
Back to top
View user's profile Send private message
fatboyjim
Apprentice
Apprentice


Joined: 12 Jul 2004
Posts: 227
Location: UK

PostPosted: Fri Dec 10, 2004 1:40 am    Post subject: Reply with quote

Mine now works fine

/etc/portage/package.keywords

Code:
/app-emulation/wine ~x86


emerge wine

extract wine-config-sidenet-1.7.1.tgz to /home/username

Then, making sure you're in the X Server... (yes I did make that mistake once) ;)

Code:
]cd /home/username/wine-config-sidenet
./setup

Just Install Minimal and away you go

Shortcut is automatically added to desktop

Jim
_________________
-----------------------
fatboyjim
Gentoo/AMD64 Arch Tester (Inactive)
Back to top
View user's profile Send private message
markandrew
Apprentice
Apprentice


Joined: 04 Feb 2004
Posts: 176
Location: Manchester, UK

PostPosted: Fri Dec 10, 2004 2:57 pm    Post subject: Reply with quote

mu understanding is that the script alters the config file anyway - the one on the website is just there for ppl who don't want to use the script. but i'll double now...
Back to top
View user's profile Send private message
planetsheinker
Guru
Guru


Joined: 26 Feb 2004
Posts: 403
Location: Israel

PostPosted: Sat Dec 11, 2004 3:05 pm    Post subject: Re: HOWTO: Installing Internet Explorer 6 with wine Reply with quote

Mirrorball wrote:
MOD EDIT: This thread resides in Documentation, Tips & Tricks because that's exactly what it is. If you want to debate the reasons for running IE in Linux, use this thread where we've collected all earlier posts to that end. However, since we're unable to merge individual posts from one thread into an existing other thread, every future post in here that attempts to question the sanity of the approach will simply get deleted. --plate

Installation method for Wine 20041019

There is a script that installs IE here: http://sidenet.ddo.jp/winetips/config.html

Here is what I get when running this script:
Code:
planetsheinker@mycomp wine-config-sidenet $ ./setup

wine-config-sidenet version 1.7.2 installer
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY.
USE AT YOUR OWN RISK.

Read readme.en or readme.ja.euc carefully before running setup.

This script will install wine-config-sidenet.
Continue(y/n)?y

Setup started on 200412111703.
which: no wineserver in (/usr/local/bin:/usr/bin:/bin)
ERROR: Could not find "wineserver".
       Please check your wine installation.
Setup aborted.

Can somebody help?

And what is "wineserver"?


Last edited by planetsheinker on Sat Dec 11, 2004 5:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
skyfolly
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 245
Location: Dongguan & Hong Kong, PRC

PostPosted: Sat Dec 11, 2004 3:39 pm    Post subject: Reply with quote

Now this seems very useful since I really need IE for some bloody websites. I am giving it a try.
_________________
I am the only being whose doom
No tongue would ask no eye would mourn
I never caused a thought of gloom
A smile of joy since I was born.
emily bronte
Back to top
View user's profile Send private message
markandrew
Apprentice
Apprentice


Joined: 04 Feb 2004
Posts: 176
Location: Manchester, UK

PostPosted: Sat Dec 11, 2004 5:17 pm    Post subject: Reply with quote

btw my font troubles were solved by removing the iesetup.exe file from the sidenet dir before running the script
Back to top
View user's profile Send private message
planetsheinker
Guru
Guru


Joined: 26 Feb 2004
Posts: 403
Location: Israel

PostPosted: Sun Dec 12, 2004 4:34 pm    Post subject: Reply with quote

Finely after allot of efforts got IE running in wine, but here is the strangest thing, when I change my keyboard layuot to some thing none-en, I cant seems to be to type, there is absoulutly no reaction, exept if I press numbers and not letters. Can some body please help?
Back to top
View user's profile Send private message
skyfolly
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 245
Location: Dongguan & Hong Kong, PRC

PostPosted: Tue Dec 14, 2004 10:11 am    Post subject: Reply with quote

damn it, can not get it work! so stupid.

I just heard that Netscape is going to release a new browser version 0.56 with both IE and FireFox core. I hope they will make it usable on Linux as well, otherwise, those screwedup Active-X websites will never work on my linux box.
_________________
I am the only being whose doom
No tongue would ask no eye would mourn
I never caused a thought of gloom
A smile of joy since I was born.
emily bronte
Back to top
View user's profile Send private message
Lepaca Kliffoth
l33t
l33t


Joined: 28 Apr 2004
Posts: 737
Location: Florence, Italy

PostPosted: Wed Dec 15, 2004 11:25 am    Post subject: Reply with quote

The scripts itself seems to work; the problem is, the IE install pops up and I don't know what to do. Whatever I choose, the install program hangs up when it should connect to the net and download the install files. I have no idea what I should do, the english documentation in the script dir is useless.
_________________
It isn't enough to win - everyone else must lose, and you also have to rub it in their face (maybe chop off an arm too for good measure).
Animebox!
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Thu Dec 16, 2004 3:41 pm    Post subject: Reply with quote

Are you behind a proxy server or a firewall?
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Thu Dec 16, 2004 4:08 pm    Post subject: yes it's likely problem with proxies Reply with quote

any way to get around the hanging problem that has been mentioned 2 posts ago?

i'm behind a proxy and setup also hangs where it should download the installation files.

hmm... maybe a http_proxy variable equivalent for wine? ;-)
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
Cosmic_Crusader
n00b
n00b


Joined: 24 Dec 2003
Posts: 9
Location: Wollongong, Australia

PostPosted: Mon Dec 20, 2004 10:48 am    Post subject: Font issues fixed Reply with quote

I finally fixed the font issues, many programs would start up and not have any fonts at all.

I just rm-rf'd the ~/.fonts directory and instead simlinked it to the windows font dir within the wine c drive.

For me I chose ~/.wine/fake_windows as my C drive (to be inline with the default wine install location) so I just did a:

ln -s ~/.fonts .wine/fake_windows/windows/Fonts
Back to top
View user's profile Send private message
SnEptUne
l33t
l33t


Joined: 23 Aug 2004
Posts: 653

PostPosted: Thu Dec 23, 2004 12:41 am    Post subject: Re: HOWTO: Installing Internet Explorer 6 with wine Reply with quote

planetsheinker wrote:
Mirrorball wrote:
MOD EDIT: This thread resides in Documentation, Tips & Tricks because that's exactly what it is. If you want to debate the reasons for running IE in Linux, use this thread where we've collected all earlier posts to that end. However, since we're unable to merge individual posts from one thread into an existing other thread, every future post in here that attempts to question the sanity of the approach will simply get deleted. --plate

Installation method for Wine 20041019

There is a script that installs IE here: http://sidenet.ddo.jp/winetips/config.html

Here is what I get when running this script:
Code:
planetsheinker@mycomp wine-config-sidenet $ ./setup

wine-config-sidenet version 1.7.2 installer
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY.
USE AT YOUR OWN RISK.

Read readme.en or readme.ja.euc carefully before running setup.

This script will install wine-config-sidenet.
Continue(y/n)?y

Setup started on 200412111703.
which: no wineserver in (/usr/local/bin:/usr/bin:/bin)
ERROR: Could not find "wineserver".
       Please check your wine installation.
Setup aborted.

Can somebody help?

And what is "wineserver"?


In that case, just modify the script to hard code /usr/lib/wine/bin/wineserver or whatever your wineserver executable is located instead of using which to locate it. The script would check for /usr/lib/wine/bin/wineserver too, so maybe you have installed wine on another directory?
_________________
"There will be more joy in heaven over the tear-bathed face of a repentant sinner than over the white robes of a hundred just men." (LM, 114)
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17813

PostPosted: Thu Dec 23, 2004 5:36 pm    Post subject: Reply with quote

Cleaned up about 2 pages of non-support comments. Link in 1st post.

EDIT: Split off a conversation that should've been handled through PMs.
_________________

Believing I had supernatural powers I slammed into a brick wall.
I said hey, is this my problem? Is this my fault?
Back to top
View user's profile Send private message
fatboyjim
Apprentice
Apprentice


Joined: 12 Jul 2004
Posts: 227
Location: UK

PostPosted: Wed Dec 29, 2004 10:35 pm    Post subject: Reply with quote

Anybody getting a problem with opening new windows in Wine?

If a new window opens it crashes all running IE windows

Jim
_________________
-----------------------
fatboyjim
Gentoo/AMD64 Arch Tester (Inactive)
Back to top
View user's profile Send private message
jax79sg
n00b
n00b


Joined: 02 Dec 2004
Posts: 9

PostPosted: Thu Dec 30, 2004 6:55 am    Post subject: Reply with quote

Mine got stuck at 67% during the installation using the script.
Back to top
View user's profile Send private message
Kampi
n00b
n00b


Joined: 05 Apr 2003
Posts: 20
Location: Vienna, Austria, Europe

PostPosted: Thu Dec 30, 2004 11:43 am    Post subject: Reply with quote

jax79sg wrote:
Mine got stuck at 67% during the installation using the script.

same for me. stuck at 72%
Back to top
View user's profile Send private message
pigah1
n00b
n00b


Joined: 02 Sep 2003
Posts: 74
Location: Toronto

PostPosted: Wed Jan 05, 2005 5:19 pm    Post subject: Reply with quote

Kampi wrote:
jax79sg wrote:
Mine got stuck at 67% during the installation using the script.

same for me. stuck at 72%


mine did that until I used the ~x86 version of wine.

(in case you don't know, add
Code:

app-emulation/wine  ~x86


to the file /etc/portage/package.keywords)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 7, 8, 9, 10, 11, 12  Next
Page 8 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum