Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo 2004.0 and ibook G4 - Can't emerge some ebuilds
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
met
n00b
n00b


Joined: 15 Mar 2004
Posts: 7

PostPosted: Mon Mar 15, 2004 11:59 am    Post subject: Gentoo 2004.0 and ibook G4 - Can't emerge some ebuilds Reply with quote

Hi :)

I installed succesfully the new Gentoo release on my iBook G4 , but I get problems emerging QT library. I get this error:

Code:

make[2]: *** [topicchooser.cpp] Segmentation fault
make[2]: *** Deleting file 'topicchooser.cpp'
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/var/tmp/portage/qt-3.2.3-r1/work/qt-x11-free-3.2.3/tools/assistant'
make[1]: *** [sub-assistant] Error 2
make[1]: Leaving directory '/var/tmp/portage/qt-3.2.3-r1/work/qt-x11-free-3.2.3/tools'
make: ** [sub-tools] Error 2

!!! ERROR: x11-libs/qt3.2.3-r1 failed.
!!! Function src_compile, Line 109, Exitcode 2
!!! (no error message)


This is my make.conf:

Code:

CFLAGS="-02 -pipe -mcpu=7400 -maltivec -mabi=altivec"
CHOST="powerpc-unknown-linux.gnu"
ACCEPT_KEYWORDS="ppc"
USE="X alsa gtk2 gtk qt gnome kde dvd gd-external php"
CXXFLAGS="${CFLAGS}"
VIDEO_CARDS="radeon"


I use mcpu=7400 cause I read somewhere that gcc have some problems with 7450 and 7455 (I tried 7450 before, but I had the same error msg, so I reinstalled all).

With ACCEPT_KEYWORDS="~ppc" it emerges another QT version but I get the same error.

It also fails the emerging of Mozilla, I don't have the error code here, but it's similar.

Anyone got my problem? Could someone help me, please? :D


Last edited by met on Sat Mar 20, 2004 12:26 pm; edited 2 times in total
Back to top
View user's profile Send private message
met
n00b
n00b


Joined: 15 Mar 2004
Posts: 7

PostPosted: Mon Mar 15, 2004 6:44 pm    Post subject: Reply with quote

I'm thinking it can be a swap problem...

How can I test if my swap partition works well?

The boot doesn't write errors, i tried with swapoff and swapon and it seems to work ok.
Back to top
View user's profile Send private message
met
n00b
n00b


Joined: 15 Mar 2004
Posts: 7

PostPosted: Mon Mar 15, 2004 7:57 pm    Post subject: Reply with quote

It's not a swap problem :(
Back to top
View user's profile Send private message
met
n00b
n00b


Joined: 15 Mar 2004
Posts: 7

PostPosted: Tue Mar 16, 2004 4:01 pm    Post subject: Reply with quote

I done an emerge -u system with ACCEPT_KEYWORD="ppc" instead of "~ppc" and qt works but i still can't emerge some ebuilds like mozilla (ALL versions) or amule...
Back to top
View user's profile Send private message
chaoticmotion
n00b
n00b


Joined: 08 Jul 2004
Posts: 13

PostPosted: Fri Jul 23, 2004 7:23 pm    Post subject: Reply with quote

did you ever find a solution to this problem???
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum