Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
yaboot load error, error cant unmount filesystems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Rawn027
Apprentice
Apprentice


Joined: 01 Mar 2004
Posts: 286

PostPosted: Fri Mar 19, 2004 1:57 am    Post subject: yaboot load error, error cant unmount filesystems Reply with quote

the only error i got during my whole install was the on the reboot command...said it couldnt unmount my filesystems.

my yabootconfig doesnt work i had to do it manually and i think that there is a problem there also...my drive is teh /dev/sdb how to i set that in OpenFirmware? the only thing i see is hd: how does that dilineate from drive 1 and drive 2? please help

maybe a yaboot config file or something.
show my /etc/fstab be like /dev/BOOT or /dev/sdb2 (bootstrap) or sdb4(root)?
_________________
AMD Athlon 64 1.8
1GB DDR 400 RAM
Nvidia 6600 GT

MacBook Pro Duo 1.67
1GB DDR2 667 RAM
ATI x1600 Mobility
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 449
Location: Paris, France

PostPosted: Fri Mar 19, 2004 9:50 am    Post subject: Reply with quote

I do not understand all the problems you mention.

I had the mount problem during my install also and solved it with umount -f (force).


About yabootconfig: I had a very hard time getting it to work.
I edited the file by and and used ybin -v to get the bootloader created.

Yet, this was not enough and I eventually solved this problem with an "Open Firmware" Reset
(start and hold down the keys Apple-Option-O-F till you hear several times the startup bang and then let it restart normally and you should see the bootloader coming).

Below is my yaboot.conf

Code:

## yaboot.conf generated by yabootconfig 1.0.7
##
## run: "man yaboot.conf" for details. Do not make changes until you have!!
##
## For a dual-boot menu, add one or more of:
## bsd=/dev/hdaX, macos=/dev/hdaY, macosx=/dev/hdaZ
                                                                                         
boot=/dev/hda2
device=hd:
partition=5
root=/dev/hda5
timeout=30
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot
                                                                                         
image=/boot/vmlinux
        label=Linux
        read-only
image=/boot/vmlinux-old
        label=Anc
        read-only
macosx=/dev/hda9
enablecdboot
enableofboot


I am not sure whether sdb changes something. Hope this helps

Regards,

Xavier
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum