Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
tun problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
pinguinoferoce
Tux's lil' helper
Tux's lil' helper


Joined: 09 Sep 2003
Posts: 147

PostPosted: Sun Mar 21, 2004 5:25 pm    Post subject: tun problem Reply with quote

Hello,
i have some problem with tun driver in 2.6.3-r2 kernel .....
i compiled it as module . i mknod it in /dev/net/ (as document say)
but after modprobe tun
i do ifconfig tun0 it return error ....
why?
Back to top
View user's profile Send private message
reddan
n00b
n00b


Joined: 18 Mar 2004
Posts: 26
Location: Mumbai

PostPosted: Mon Mar 22, 2004 3:09 am    Post subject: Reply with quote

as far as I'm aware (from reading the kernel docs), there is no tun device registered with the kernel automatically.
From the kernel docs:
Quote:
In order to use the driver a program has to open /dev/net/tun and issue a corresponding ioctl() to register a network device with the kernel. A network device will appear as tunXX or tapXX, depending on the options chosen.

I have tun compiled statically into my kernel, and ifconfig doesn't normally see a tun interface. However, mol (mac on linux) automatically sets up the tun interface, so while mol is running, ifconfig lists tun1 as an available interface.

Hope that helps!
Back to top
View user's profile Send private message
pinguinoferoce
Tux's lil' helper
Tux's lil' helper


Joined: 09 Sep 2003
Posts: 147

PostPosted: Mon Mar 22, 2004 6:18 pm    Post subject: Reply with quote

thx
but how can i do with qemu?
(
Back to top
View user's profile Send private message
reddan
n00b
n00b


Joined: 18 Mar 2004
Posts: 26
Location: Mumbai

PostPosted: Mon Mar 22, 2004 11:33 pm    Post subject: Reply with quote

Code:
emerge qemu
wget http://fabrice.bellard.free.fr/qemu/linux-test-0.5.1.tar.gz


then untar linux-test-0.5.1.tar.gz. Actually, tar -zxf told me that this file wasn't gzipped, but a simple tar -xf did the trick (maybe firefox gunzipped it for me???).
anyway, then
Code:
cd linux-test
sudo cp ./qemu-ifup /etc/

then edit ./qemu.sh and change the first word 'qemu-fast' to 'qemu'

make sure your tun module is loaded, and then
./qemu.sh

in another shell type ifconfig, and you should notice a tunX interface!
These instructions are available at: /usr/doc/qemu-0.5.2/qemu-doc.html.gz
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum