Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Missing keys on AluBook 15 keyboard: @ | Del etc.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
andreas.schreier
n00b
n00b


Joined: 25 Mar 2004
Posts: 18

PostPosted: Fri Apr 02, 2004 6:31 pm    Post subject: Missing keys on AluBook 15 keyboard: @ | Del etc. Reply with quote

Hi,

I would like to use all the characters that I got used to on my x86 keyboard. For example, I need the pipe character (|). However, they are not available on my AluBook 15 keyboard. How can I activate/emulate these keys?

Thanks in advance for any replies.

Best regards
Andreas


Last edited by andreas.schreier on Fri Apr 02, 2004 7:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
sethleon
Guru
Guru


Joined: 14 Dec 2003
Posts: 394
Location: Germany

PostPosted: Fri Apr 02, 2004 6:37 pm    Post subject: Reply with quote

Have you already read the gentoo documentation about "Localisation Gentoo":
english: http://www.gentoo.org/doc/en/guide-localization.xml
german: http://www.gentoo.org/doc/de/guide-localization.xml
_________________
Mess with the best, die like the rest.
Back to top
View user's profile Send private message
andreas.schreier
n00b
n00b


Joined: 25 Mar 2004
Posts: 18

PostPosted: Fri Apr 02, 2004 7:22 pm    Post subject: Thanks Reply with quote

Hi Sethleon,

Thank you very much for referring to the documentation. Sorry for having missed them. My localisation issues are solved now.

However, there are still a lot of keys missing that I need. E.g. where is the pipe on my AluBook keyboard?

Again, thank you very much for your help.

Best regards
Andreas
Back to top
View user's profile Send private message
sethleon
Guru
Guru


Joined: 14 Dec 2003
Posts: 394
Location: Germany

PostPosted: Sat Apr 03, 2004 7:37 am    Post subject: Reply with quote

Maybe you have another keyboard layout,
change it in your XF86Config or in the KDE tool for keyboard layouts.
_________________
Mess with the best, die like the rest.
Back to top
View user's profile Send private message
andreas.schreier
n00b
n00b


Joined: 25 Mar 2004
Posts: 18

PostPosted: Sun Apr 04, 2004 8:36 am    Post subject: Which layout enables the missing keys? Reply with quote

Which keyboard layout should I choose in order to make the missing keys work on my AluBook? For example, I definitely need the pipe.

Should I go for x86 or PPC layouts? Any hints?

Thanks in advance!

Best regards
Andreas
Back to top
View user's profile Send private message
sethleon
Guru
Guru


Joined: 14 Dec 2003
Posts: 394
Location: Germany

PostPosted: Sun Apr 04, 2004 8:50 am    Post subject: Reply with quote

try changing the following part in your /etc/X11/XF86Config :
Code:
Section "InputDevice"

       Identifier       "Keyboard"
       Driver           "Keyboard"
       Option "AutoRepeat" "250 30"
       Option "XkbRules"    "xfree86"
       Option "XkbModel"    "pc105"
       Option "XkbLayout"   "de"
       Option "XkbOptions"  "grp:alt_shift_toggle,lv3:win_switch,ctrl:nocaps,grp_led:num,caps:internal"

EndSection


and in /etc/rc.conf I use the following option:
Code:
KEYMAP="de-latin1-nodeadkeys"

_________________
Mess with the best, die like the rest.
Back to top
View user's profile Send private message
andreas.schreier
n00b
n00b


Joined: 25 Mar 2004
Posts: 18

PostPosted: Sun Apr 04, 2004 9:51 am    Post subject: That helped! Reply with quote

Thank you very much for the help! I can now have the pipe via:
Fn + Alt + <

Could you please explain the function of
Option "AutoRepeat" "250 30"
Option "XkbOptions" "grp:alt_shift_toggle,lv3:win_switch,ctrl:nocaps,grp_led:num,caps:internal"

Again, thank you very much for the patient help!

Best regards
Andreas
Back to top
View user's profile Send private message
sethleon
Guru
Guru


Joined: 14 Dec 2003
Posts: 394
Location: Germany

PostPosted: Sun Apr 04, 2004 10:33 am    Post subject: Reply with quote

Following is written in XF86Config.example:
Code:
# Set the keyboard auto repeat parameters.
     Option "AutoRepeat" "500" 5"
# If you'd like to switch the position of you capslock and control keys, use:
     Option "XkbOptions" "ctrl:swapcaps"


Concerning the auto repeat parameters (key repetition):
the first number means the delay a key must be pressed before it is repeated,
the second is the amount of characters repeated per second
(holding the key pressed).

Concerning the XkbOptions:
if you use KDE, you also can go here:
Control Center > regional settings & access help > keyboard layout
in the third tab "Xkb-Options" you can find all possible settings.
_________________
Mess with the best, die like the rest.
Back to top
View user's profile Send private message
SeJo
Retired Dev
Retired Dev


Joined: 08 Oct 2002
Posts: 298
Location: Belgium

PostPosted: Mon Apr 05, 2004 6:40 am    Post subject: Reply with quote

on a albook (default) the pipe is at "alt+shift+L"
the ~ is at "alt+shift+n"

Do you have a azerty keyboard?


greetings
_________________
"I am not bound to please thee with my answers."
Back to top
View user's profile Send private message
einstein1981
Guru
Guru


Joined: 10 Mar 2004
Posts: 395
Location: Venezuela , Caracas

PostPosted: Tue Apr 06, 2004 4:37 am    Post subject: Reply with quote

Thanks for post, will have to remap my keyboard also,

The thing is that I live in venezuela, and my keyboard is american, in windows, i use a us international keyboard layout to be able to get the n with ~ on top, but here in gentoo ( i' m new at this) I can't get it to work, Do you know if this is posible in gentoo?

thanks
_________________
thesis.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum