Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Internet on startup....
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
furkan
Guru
Guru


Joined: 11 Dec 2003
Posts: 520
Location: Montreal CA

PostPosted: Sat Apr 03, 2004 11:47 am    Post subject: Internet on startup.... Reply with quote

If you use a modem slow i mean like 56kbps and you would like to connect internet on startup....
1) Install wvdial....Configure your wvdial like that
Code:
wvdialconf /etc/wvdial.conf
nano -w /etc/wvdial.conf

after in wvdial.conf you need to see something like that
Quote:
: Phone = <Your phone>
: Username = <Your user name>
: Password = <Your password>

here do like that
Quote:
Phone = Your phone
Username = Your user name
Password = Your password


2) Now we create the startup script....
first do that
Code:
cd /etc/init.d/
nano -w wvdial

after in wvdial write that
Quote:
#!/sbin/runscript
start() {
ebegin "Wvdial starting..."
start-stop-daemon --start --exec /usr/bin/wvdial \
--background -- >/home/akrep/.wvdial 2>&1
eend $?
}
stop() {
ebegin "Wvdial stopping..."
start-stop-daemon --stop --quiet --exec /usr/bin/wvdial
eend $?
}

and
Code:
chmod 755 wvdial
rc-update add wvdial default

and it is all :) after you reboot and see....when you have open your system the internet is connect...
note:don't forget to edit resolv.conf...
Back to top
View user's profile Send private message
Koala Kid
Guru
Guru


Joined: 09 May 2003
Posts: 381

PostPosted: Sat Apr 03, 2004 1:55 pm    Post subject: Reply with quote

and if you use PPPOE just put the following command in your /etc/conf.d/local.start file:
Code:

adsl-start


your machine will connect to the net before X running 8)
_________________
"People are the worst, the worst thing about music is that people play it". M. Patton.
Back to top
View user's profile Send private message
furkan
Guru
Guru


Joined: 11 Dec 2003
Posts: 520
Location: Montreal CA

PostPosted: Sat Apr 03, 2004 8:41 pm    Post subject: Reply with quote

yes i know it but in a modem 56kbps is too difficult :)
Back to top
View user's profile Send private message
davidblewett
Apprentice
Apprentice


Joined: 15 Feb 2004
Posts: 274
Location: Indiana

PostPosted: Thu Apr 15, 2004 10:23 pm    Post subject: Reply with quote

There is an /etc/init.d/net.ppp0 script already for this. Just thought I'd throw that out there...
_________________
No guilt in life, no fear in death
this is the power of Christ in me
From life’s first cry to final breath
Jesus commands my destiny
-- Newsboys, "In Christ Alone", "Adoration: The Worship Album"
Back to top
View user's profile Send private message
furkan
Guru
Guru


Joined: 11 Dec 2003
Posts: 520
Location: Montreal CA

PostPosted: Sun Apr 18, 2004 11:38 pm    Post subject: Reply with quote

davidblewett wrote:
There is an /etc/init.d/net.ppp0 script already for this. Just thought I'd throw that out there...

so i knew that....i have try it but it don't work......and after i write that script for my computer :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum