Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
não consigo atualizar o gnome 2.6 pelo emerge
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
perseu
n00b
n00b


Joined: 08 Feb 2004
Posts: 13

PostPosted: Fri Apr 09, 2004 5:06 am    Post subject: não consigo atualizar o gnome 2.6 pelo emerge Reply with quote

Pessoal,

Nâo estou conseguindo atualizar o gnome pelo emerge. Já fiz o emerge sync mas quando faço emerge -u gnome ele não faz a atualização.

Alguém já teve este problema? Alguma idéia do que pode estar errado?

Muito obrigado por qualquer ajuda.
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Fri Apr 09, 2004 4:40 pm    Post subject: Reply with quote

masked packages
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
perseu
n00b
n00b


Joined: 08 Feb 2004
Posts: 13

PostPosted: Fri Apr 09, 2004 10:57 pm    Post subject: Reply with quote

É isso. Funcionou. Você sabe qual a razão do mask no Gnome 2.6? Ele não está estável?

valeu.
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Fri Apr 09, 2004 11:37 pm    Post subject: Reply with quote

perseu wrote:
É isso. Funcionou. Você sabe qual a razão do mask no Gnome 2.6? Ele não está estável?

valeu.

O Gnome 2.6 é um "pacote" grande e complexo. Certamente ele precisará de mais alguns testes e feedbacks dos usuários até que possa ser marcado como estável.
_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Sat Apr 10, 2004 12:19 am    Post subject: Reply with quote

como o AngusYoung disse, eh o procedimento normal. Assim, quem quer testar pode, mas quem quer manter o sistema estavel e usavel continua com os pacotes testados.

Uma coisa eh o pacote ser considerado estavel pelo desenvolvedor, outra coisa eh ser testado com as versoes de bibliotecas e compiladores da distribuicao.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Enderson
Retired Dev
Retired Dev


Joined: 12 Nov 2003
Posts: 141
Location: Arapiraca/Maceió, AL, Brazil

PostPosted: Sun Apr 11, 2004 2:54 am    Post subject: Reply with quote

No meu caso, o mozilla nao funciona mais :(

O Gnome 2.6 ta rodando que e uma blz.
Deu trabalho pra instalar, relacionados ao pacote
ORBit2-2.10.0, e ao libIDL, mas
consegui resolver, o problema e que
o mozilla nao executa mais, ja fiz de tudo.

Simplesmente e assim:
Code:
$ mozilla
Exceçao de ponto flutuante


Existe alguma maneira de eu debugar
a execuçao, saber onde ele vai parar?
_________________
--
Nothing to say here!
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Sun Apr 11, 2004 3:03 am    Post subject: Reply with quote

emaia, parece problema nas tuas flags (muito agressivas talvez) ou talvez em alguma opção do kernel.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Enderson
Retired Dev
Retired Dev


Joined: 12 Nov 2003
Posts: 141
Location: Arapiraca/Maceió, AL, Brazil

PostPosted: Sun Apr 11, 2004 1:57 pm    Post subject: Reply with quote

pilla wrote:
emaia, parece problema nas tuas flags (muito agressivas talvez) ou talvez em alguma opção do kernel.


Eu compilei tudo necessário para o Gnome com as CFLGAS simples.

Code:
-march=athlon-xp -O2 -pipe


Eu removi todo o gnome, fiquei somente com o xfce4 mesmo, e o mozilla
funciona agora.

:)

Eu creio ser uma incompatibilidade com pango ou glib ou gtk+-2.4.

Não tô afim de testar mais não, é meu note, e não vou arriscar quebrar tudo.

:)
_________________
--
Nothing to say here!
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Sun Apr 11, 2004 11:09 pm    Post subject: Reply with quote

emaia wrote:
Eu removi todo o gnome, fiquei somente com o xfce4 mesmo, e o mozilla funciona agora.


Compilar o Gnome e depois jogar fora é para poucos... 8O

emaia wrote:
Eu creio ser uma incompatibilidade com pango ou glib ou gtk+-2.4.


Por acaso o Mozilla em questão é o 1.7b? Caso o problema persista quando o Gnome for considerado estável e o Mozilla não seja uma versão de testes, um bug deve ser arquivado no bugzilla (se já não não tiver sido). :wink:
Back to top
View user's profile Send private message
Enderson
Retired Dev
Retired Dev


Joined: 12 Nov 2003
Posts: 141
Location: Arapiraca/Maceió, AL, Brazil

PostPosted: Mon Apr 12, 2004 12:01 pm    Post subject: Reply with quote

fernandotcl wrote:
Compilar o Gnome e depois jogar fora é para poucos... 8O


Mas eu não compilei tudo, boa parte eu peguei em .tbz2 compilado na maquina
de um amigo mais paciente do que eu. Ele tem um notebook igual.

Quote:
Por acaso o Mozilla em questão é o 1.7b?

Não, é a versao 1.6 mesmo.
_________________
--
Nothing to say here!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum