Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE power saving on powerbook
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
aallmighty
n00b
n00b


Joined: 09 Mar 2004
Posts: 16

PostPosted: Wed Apr 14, 2004 6:27 pm    Post subject: KDE power saving on powerbook Reply with quote

When I am running KDE, and I leave the screen closed for a few minutes the computer shuts down. Also, the screen turns off when it is idle and open, but the computer stays on. Where are these settings controlled? I don't want it to turn off automatically.

I've checked power control in kde, and all of it is turned off. TIA
Back to top
View user's profile Send private message
tomasino
Apprentice
Apprentice


Joined: 11 Feb 2004
Posts: 154
Location: Italy, Bologna

PostPosted: Wed Apr 14, 2004 7:05 pm    Post subject: Reply with quote

Have you installed "pbbuttonsd"? Have you checked its config?
Back to top
View user's profile Send private message
aallmighty
n00b
n00b


Joined: 09 Mar 2004
Posts: 16

PostPosted: Wed Apr 14, 2004 10:19 pm    Post subject: Reply with quote

I have pbbuttonsd installed and here is my config. However, I don't think it did it before I installed KDE, and was using fvwm. (pbbuttonsd was installed)


Code:

# configfile for pbbuttonsd >= version 0.5
# for options see man pbbuttonsd.conf

# [MODULE POWERSAVE]
onAC_sleep              = no
onAC_dim                = no
onAC_blank              = no
onAC_Tsleep             = 0
onAC_Tdim               = 0
onAC_Thdoff             = 0
onBattery_sleep         = no
onBattery_dim           = no
onBattery_blank         = no
onBattery_Tsleep        = 0  ; time in 1/10s
onBattery_Tdim          = 0   ; time in 1/10s
onBattery_Thdoff        = 0     ; time in multiple of 5 second intervals
SleepKey                = 0
SleepKeyDelay           = no     ; yes = dangerous, if the power key is used to trigger sleep
BWL_First               = 21     ; first battery warnlevel, time in minutes
BWL_Second              = 10     ; second battery warnlevel, time in minutes
BWL_Last                = 3      ; last battery warnlevel, time in minutes
Script_BatCritical      = "/sbin/shutdown -h now"
#Script_ProfChanged     = ""
Script_HDSetup          = "/sbin/hdparm -p -S %d /dev/hda"
CPULoad_sleeplock       = yes
CPULoad_min             = 20      ; value in percent
CPULoad_period          = 20      ; time in seconds
NETLoad_sleeplock       = yes

NETLoad_sleeplock       = yes
NETLoad_min             = 4096    ; trafic in Bytes/s
NETLoad_period          = 20      ; time in seconds
NETLoad_device          = eth0

# [MODULE DISPLAY]
#Brightness             = 12      ; initial brightness level
BrightnessupKey         = 225
BrightnessdownKey       = 224
dev_framebuffer         = "/dev/fb0"
UseFBBlank              = yes

# [MODULE OSSMIXER]
dev_mixer               = "/dev/mixer"
volume                  = 50       ; initial volume level
speakers_muted          = no       ; mute after startup?
volumeupkey             = 115
volumedownkey           = 114
mutekey                 = 113
mixerinitdelay          = no

# [MODULE CDROM]
dev_cdrom               = "/dev/cdrom"
ejectcdkey              = 161
ejectcddelay            = no

# [MODULE PMAC]
dev_pmu                 = "/dev/pmu"
dev_adb                 = "/dev/adb"
tpmodeupkey             = 225 + alt
tpmodedownkey           = 224 + alt
tpmode                  = drag
kbdmode                 = fkeysfirst
replace_pmud            = yes

Back to top
View user's profile Send private message
gnomeza
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2003
Posts: 97

PostPosted: Thu Apr 15, 2004 9:27 am    Post subject: shutdowns with screen closed Reply with quote

I have exactly the same problem.
(15" PB 1.25 GHz)

Closing the lid does not turn the screen off immediately. However, after about 5 minutes the machine shuts down uncleanly.

My (mostly current) configs are at http://l003026.zseriespenguins.ihost.com/~gnome/gentoo

ciao
Mark
Back to top
View user's profile Send private message
blackphiber
Tux's lil' helper
Tux's lil' helper


Joined: 11 Sep 2003
Posts: 86
Location: IL

PostPosted: Fri Apr 16, 2004 6:53 am    Post subject: Reply with quote

yup, not a gentoo problem, its happening to me on yellow dog. don't worry I am going to get gentoo as soon as a new iso is rolled with support for my ibook g4
Back to top
View user's profile Send private message
aallmighty
n00b
n00b


Joined: 09 Mar 2004
Posts: 16

PostPosted: Sat Apr 17, 2004 9:19 pm    Post subject: Reply with quote

so can anyone confirm that the problem is with kde? It did not happen before I installed kde...
Back to top
View user's profile Send private message
Heimir Freyr
n00b
n00b


Joined: 09 Mar 2003
Posts: 43
Location: Reykjavík, Iceland

PostPosted: Tue Apr 20, 2004 10:55 pm    Post subject: Reply with quote

I too have a PowerBook and am using KDE 3.2.1. Had this problem once but fixed it by messing around with 'powerprefs' (changing the critical battery thing, ticked some boxes with settings for sleep/snooze etc etc. That fixed it for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum