Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Install: Problemen met filesystems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
yootje
n00b
n00b


Joined: 26 Jan 2004
Posts: 29
Location: Almere, The Netherlands

PostPosted: Sat Apr 17, 2004 9:07 pm    Post subject: Install: Problemen met filesystems Reply with quote

Ok, ik probeer Gentoo al tijden te installeren, maar ik krijg steeds gekoot met filesystems. Vandaag probeerde ik het opnieuw.

Ik gebruik LILO, geen genkernel (via make menuconfig dus, en daarbij vink ik ext3 ds support aan, en niet als module). Installatie ging niet zo netjes (moest 3 keer opnieuw omdat er telkens wat vastliep), maar volgens mij maakt dat niet uit voor dit probleem.

Ik heb op mijn boot en normale partitie allebei als filesystem ext3.

Nu krijg ik de volgende melding:

Checking root file system...
modprobe: Can't locate module /dev/ROOT
modprobe: Can't locate module /dev/ROOT
ext2fs_check_if_mount: no such file or directory while determining whether /dev/ROOT is mounted
modprobe: Can't locate module /dev/ROOT
fsck.ext3: No such file or directory while trying to open /dev/ROOT /dev/ROOT

(de volgende boodscap was nogal lang dus hier een samenvatting:)
Superblock could not be read or does not describe a correct ext2 filesystem, misschien is de superblock corrupt, ik zou e2fsck met alternatieve superblock moeten doen, bv. : e2fsck -b 8193

Nou, het heeft dus met filesystems te maken, maar dat is alles wat ik er wijs uit kan worden. Waar moet ik naar zoeken? Ik weet vrij zeker dat lilo.conf goed is geconfigureerd. Kan iemand een gissing doen naar wat er verkeerd gaat? Zeg het me maar als ik nog meer info moet geven.

Alvast bedankt!
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Sat Apr 17, 2004 9:31 pm    Post subject: Reply with quote

Je moet ROOT en BOOT in /etc/fstab vervangen door de echte namen van de devices, bijvoorbeeld hda1, sda1 zodat er iets als dit staat:

Code:
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hda2               /boot           ext3            noauto,noatime  1 1
/dev/hda5               /               reiserfs        noatime         0 0
/dev/hda6               none            swap            sw              0 0

_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
yootje
n00b
n00b


Joined: 26 Jan 2004
Posts: 29
Location: Almere, The Netherlands

PostPosted: Sat Apr 17, 2004 9:55 pm    Post subject: Reply with quote

Mijn eeuwige dank :)

Nogal een erg stomme fout :?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum