Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Heb ik xorg dan toch niet goed gecompileerd....
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
PieterB
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 158
Location: Aalter, Belgium

PostPosted: Mon Apr 19, 2004 6:45 pm    Post subject: Heb ik xorg dan toch niet goed gecompileerd.... Reply with quote

Wanneer ik /var/log/messages eens controleerde, ontdekte ik het volgende:

Code:

Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/Type1 (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/Speedo (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/CID (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/util (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/local (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/Speedo (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/truetype (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/sharefont (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/default/Type1 (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/ttf/decoratives (unreadable)
Apr 19 20:37:30 gentoobox xfs: ignoring font path element /usr/share/fonts/ttf/western (unreadable)


Nochthans werkt gnome perfect. Enkel in kde had ik een aantal ambetantigheden met de fonts. Ik heb forum-howto gevolgd voor de installatie van xorg....
Zou er toch iets mis kunnen zijn? Of is dit doordat de rest van linux soms nog wat problemen heeft met xorg-x11?[/code]
_________________
LinuxUser: #310384
Back to top
View user's profile Send private message
adaptr
Watchman
Watchman


Joined: 06 Oct 2002
Posts: 6730
Location: Rotterdam, Netherlands

PostPosted: Mon Apr 19, 2004 7:03 pm    Post subject: Reply with quote

Ik zou het niet weten hoor - ik ging gisteren over op xorg, en heb gewoon onder xfce4 eerst xfree ge-unmerged (blocking...) en toen direct xorg-x11 gemerged.
Even geherstart, en het werkte als een trein!
Okee, ik gebruik xfce4 en niet gnome, maar de basis van beide is gtk+...
Ik zal ook es in den logs kieken, maar heb geen problemen an sich.
_________________
>>> emerge (3 of 7) mcse/70-293 to /
Essential tools: gentoolkit eix profuse screen
Back to top
View user's profile Send private message
coax
Apprentice
Apprentice


Joined: 08 Sep 2003
Posts: 231
Location: Antwerp - Belgium

PostPosted: Mon Apr 19, 2004 8:49 pm    Post subject: Reply with quote

Kijk misschien eens naar de permissies.
Code:
ls -al /usr/share/fonts
ofzo
(en kijk of ze wel readable zijn)
_________________
- There is no such thing as having too many computers -
Back to top
View user's profile Send private message
PieterB
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 158
Location: Aalter, Belgium

PostPosted: Tue Apr 20, 2004 4:35 am    Post subject: Reply with quote

Lijkt me in orde

Code:

pieter $ ls -al /usr/share/fonts/
totaal 228
drwxr-xr-x   20 root root  4096 apr 14 09:58 .
drwxr-xr-x  267 root root  8192 apr 19 22:26 ..
drwxr-xr-x    2 root root 65536 apr 14 09:58 100dpi
drwxr-xr-x    2 root root 65536 apr 14 09:58 75dpi
drwxr-xr-x    2 root root  4096 apr 14 09:47 artwiz
drwxr-xr-x    2 root root  4096 apr 14 09:48 CID
drwxr-xr-x    2 root root  4096 apr 14 09:47 corefonts
drwxr-xr-x    2 root root  4096 apr 14 09:58 cyrillic
drwxr-xr-x    3 root root  4096 apr 20 06:27 encodings
-rw-r--r--    1 root root   336 apr 14 19:08 fonts.cache-1
drwxr-xr-x    2 root root  4096 apr 14 09:58 freefont
drwxr-xr-x    2 root root  4096 apr 14 09:47 latex-xft-fonts
drwxr-xr-x    2 root root  4096 apr 14 09:47 local
drwxr-xr-x    2 root root 16384 apr 14 09:58 misc
drwxr-xr-x    2 root root  4096 apr 14 09:58 Speedo
drwxr-xr-x    3 root root  4096 apr 14 09:47 ttf
drwxr-xr-x    2 root root  4096 apr 14 09:58 TTF
drwxr-xr-x    2 root root  4096 apr 14 09:47 ttf-bitstream-vera
drwxr-xr-x    2 root root  4096 apr 14 09:58 Type1
drwxrwxr-x    2 root root  4096 apr 14 09:48 ukr
drwxr-xr-x    2 root root  4096 apr 14 09:58 util


Als gewone gebruiker moet ik toch géén write access hebben hé?
_________________
LinuxUser: #310384
Back to top
View user's profile Send private message
adaptr
Watchman
Watchman


Joined: 06 Oct 2002
Posts: 6730
Location: Rotterdam, Netherlands

PostPosted: Tue Apr 20, 2004 11:21 am    Post subject: Reply with quote

Lijkt me niet nee.
Draaiter een font server misschien ? Die werken net iets anders.
_________________
>>> emerge (3 of 7) mcse/70-293 to /
Essential tools: gentoolkit eix profuse screen
Back to top
View user's profile Send private message
PieterB
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 158
Location: Aalter, Belgium

PostPosted: Tue Apr 20, 2004 4:28 pm    Post subject: Reply with quote

Ahja natuurlijk: xfs hé ;-)
Zijn er mensen die dat niet draaien ofzo? En is deze boodschap dan normaal? Heb me nog niet bezig gehouden met de techniek van font-servers ;-)
_________________
LinuxUser: #310384
Back to top
View user's profile Send private message
adaptr
Watchman
Watchman


Joined: 06 Oct 2002
Posts: 6730
Location: Rotterdam, Netherlands

PostPosted: Tue Apr 20, 2004 8:07 pm    Post subject: Reply with quote

De reden van de fout heb ik uit een andere thread :
XOrg gebruikt de (nieuwe) lokatie /usr/share/fonts om alle fonts op te slaan, echter xfree (en de afzonderlijke font-* packages) zet ze ergens anders neer.
Je zult ze dus zelf even moeten verhuizen of kopuleren naar /usr/share/fonts.

Voor wat de font server betreft, dat zit zo: zolang je op 1 PC 1 X server draait is een fontserver totaal niet nodig - deze techniek is bedoeld om font directories over een netwerk te kunnen delen, zodat meerdere gebruikers van dezelfde fonts gebruik kunnen maken.
Altijd een voordeel bij administratie van een netwerk.

Maar het voordeel dat xfs biedt voor een enkele gebruiker is dat de configuratie en het laden en bijhouden van de fonts door xfs geregeld wordt, zodat de X server zich daar niet mee bezig hoeft te houden.

Eigen keus - zoals gewoonlijk ;-)
_________________
>>> emerge (3 of 7) mcse/70-293 to /
Essential tools: gentoolkit eix profuse screen
Back to top
View user's profile Send private message
PieterB
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 158
Location: Aalter, Belgium

PostPosted: Tue Apr 20, 2004 8:42 pm    Post subject: Reply with quote

eh welja het werkt allemaal wel goed.... en ik werk met xfs....
maar waarom krijg ik dan die errors als ik als men fonts zich wel hier bevinden? Ik wist dat xorg ze op deze plaats bijhoud en heb dan ook alles gedaan volgens de howto.... (fc-cache opnieuw aangemaakt, corefonts en nog wat zaken opnieuw gemerged en dergerlijke)....

Wel bedankt voor het antwoord etc ;-)
_________________
LinuxUser: #310384
Back to top
View user's profile Send private message
adaptr
Watchman
Watchman


Joined: 06 Oct 2002
Posts: 6730
Location: Rotterdam, Netherlands

PostPosted: Tue Apr 20, 2004 9:40 pm    Post subject: Reply with quote

"Werkt niet iedereen met xfs" - nou, nee, ik niet! ;-)
Ik heb gewoon de schone xfree ge-unmerged en toen xorg gemerged.
Zelfde instellingen, zelfde configs, niets veranderd - het draaide METEEN!
xfs heb ik nooit gebruikt, en in mijn xorg.0.log laad hij de fonts gewoon vanaf de oude locatie (zoals in xfree).

Dat zal het wel zijn dus...
_________________
>>> emerge (3 of 7) mcse/70-293 to /
Essential tools: gentoolkit eix profuse screen
Back to top
View user's profile Send private message
PieterB
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 158
Location: Aalter, Belgium

PostPosted: Wed Apr 21, 2004 5:54 am    Post subject: Reply with quote

Welja alles werkt goed dus ik ga er niet verder op ingaan.... zal het wel merken als ik ooit eens een 'break' heb ;-)

In Xorg.0.log leek me alles in orde... er wordt wel melding gemaakt van hetzelfde probleem
Code:

Could not init font path element /usr/share/fonts/local/, removing from list!
Could not init font path element /usr/share/fonts/Speedo/, removing from list!
Could not init font path element /usr/share/fonts/Type1/, removing from list!
Could not init font path element /usr/share/fonts/corefonts, removing from list!


Men xorg draaide ook meteen zodus :P

Bedankt voor de vlugge respons in ieder geval
_________________
LinuxUser: #310384
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum