Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hda changed to hdc after install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
danns
n00b
n00b


Joined: 20 Apr 2004
Posts: 18

PostPosted: Tue Apr 20, 2004 5:37 pm    Post subject: hda changed to hdc after install Reply with quote

I'm not sure how this happened but after installing gentoo on a Powerbook 12" hda is not hdc and my cdrom is hda. This messed up the boot process a bit but I was able to fix it eventually.

Is there a reason this happened? Will this be a problem later on down the line now that have changed fstab and yaboot.conf to reflect this?
Back to top
View user's profile Send private message
sstacha
n00b
n00b


Joined: 03 Sep 2003
Posts: 68

PostPosted: Tue Apr 20, 2004 6:00 pm    Post subject: rebuild with kernel param should fix it Reply with quote

I ran across this too early on. If you rebuild your kernel and build in the option <boot kuwi 100 first> it should fix it. BTW im working off memory here the option should look similar but not exact. I'm pretty sure it's in the same section as most of the other mac powerbook options. Let me know if you still can't find and ill look it up for you. Also, tell me what kernel version you are using as well. NOTE: don't forget to reset the yaboot stuff back before rebooting. Good luck!
Back to top
View user's profile Send private message
danns
n00b
n00b


Joined: 20 Apr 2004
Posts: 18

PostPosted: Tue Apr 20, 2004 6:34 pm    Post subject: Reply with quote

I think I found the option: Probe Internal Kauai ATA/100 first under the IDE, ATA, ATAPI Block devices. I will enable this and see what happens.

I am running 2.4.24-ppc-r4.
Back to top
View user's profile Send private message
sstacha
n00b
n00b


Joined: 03 Sep 2003
Posts: 68

PostPosted: Tue Apr 20, 2004 6:42 pm    Post subject: yep that's it Reply with quote

ps. don't forget to change the fstab and yaboot.conf image info before rebooting
Back to top
View user's profile Send private message
danns
n00b
n00b


Joined: 20 Apr 2004
Posts: 18

PostPosted: Tue Apr 20, 2004 6:45 pm    Post subject: Reply with quote

Will do.
Back to top
View user's profile Send private message
danns
n00b
n00b


Joined: 20 Apr 2004
Posts: 18

PostPosted: Wed Apr 21, 2004 3:22 am    Post subject: Reply with quote

That did it, enabling Probe Internal Kauai ATA/100 first. Now everything is back to hda.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum