Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't load into kernel, iBook shuts down
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
sienarot
n00b
n00b


Joined: 24 Sep 2003
Posts: 52
Location: Calgary, Alberta, Canada

PostPosted: Sat May 01, 2004 4:39 pm    Post subject: Can't load into kernel, iBook shuts down Reply with quote

Has anyone seen this happen? I'm in the middle of trying to install Gentoo 2004.1 and I've gotten as far as setting up Yaboot. However, whenever I select linux to boot (kernel 2.6.1), it starts to load, but half a second later, the screen fades out and the entire iBook shutdowns down and reboots. Does anyone have any idea why this might be like this? I'm pulling my hair out now!
Back to top
View user's profile Send private message
pvdabeel
Retired Dev
Retired Dev


Joined: 25 Mar 2003
Posts: 188
Location: Belgium

PostPosted: Sun May 02, 2004 12:50 am    Post subject: Re: Can't load into kernel, iBook shuts down Reply with quote

sienarot wrote:
Has anyone seen this happen? I'm in the middle of trying to install Gentoo 2004.1 and I've gotten as far as setting up Yaboot. However, whenever I select linux to boot (kernel 2.6.1), it starts to load, but half a second later, the screen fades out and the entire iBook shutdowns down and reboots. Does anyone have any idea why this might be like this? I'm pulling my hair out now!


Does appending video=ofonly as kernel argument help?
Back to top
View user's profile Send private message
sienarot
n00b
n00b


Joined: 24 Sep 2003
Posts: 52
Location: Calgary, Alberta, Canada

PostPosted: Sun May 02, 2004 5:20 am    Post subject: Reply with quote

I'll give it a try, but where would I do that? In /etc/yaboot.conf?
Back to top
View user's profile Send private message
sienarot
n00b
n00b


Joined: 24 Sep 2003
Posts: 52
Location: Calgary, Alberta, Canada

PostPosted: Sun May 02, 2004 7:20 am    Post subject: Reply with quote

pvdabeel, thanks for your help! I actually ended up installing kernel 2.6.4 as well as adding the line

Code:

append = "video=ofonly"


in the linux image block in my /etc/yaboot.conf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum