Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Booting problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
xaeroman
n00b
n00b


Joined: 24 Apr 2004
Posts: 12

PostPosted: Mon May 03, 2004 7:26 pm    Post subject: Booting problem Reply with quote

Hi All,
I am trying to install 2004.1 on a PPC.
I've been successful in compiling a kernel (2.6.1) for eMac G4, ATIRaedon.
The compiled kernel initially boots properly but after some time(precisely after the USB Keyboard is detected) a message is echoed whichsays, "Restarting System" and the system is restarted..
The same thing keeps on continuously happening..
The LiveCD boots up properly though..

Thanks,
Saket
Back to top
View user's profile Send private message
Immortal Q
Apprentice
Apprentice


Joined: 14 Sep 2003
Posts: 241
Location: Silicone Valley

PostPosted: Tue May 04, 2004 12:52 am    Post subject: Reply with quote

Can you use the liveCD to check the kernel logs (for the one you compiled)?
_________________
Osmos.org
Now with 20% fewer rabid primates.
Back to top
View user's profile Send private message
xaeroman
n00b
n00b


Joined: 24 Apr 2004
Posts: 12

PostPosted: Tue May 04, 2004 3:57 am    Post subject: Reply with quote

I have no idea where to find them...

plz let me know where should I look ? Or what file should I post here..

Thanks,
Saket
Back to top
View user's profile Send private message
d_m
Guru
Guru


Joined: 12 Jun 2003
Posts: 570
Location: Philadelphia, PA, USA

PostPosted: Sun Jun 06, 2004 12:41 am    Post subject: Reply with quote

I've had the same problem today.

I was installing a 2.6 kernel on an 867 MHz Quicksilver G4 (the tower). The install went fine, and I rebooted. Once I got yaboot set up, I was able to boot into OS X with it no problem.

When I booted linux, the console came up and starting printing information. It was right after detecting the USB hid devices (keyboard, mouse) that it paused, then printed:

"Restarting System"

and then the machine just rebooted. I tried letting it boot 4-5 times, and each time it died in the same place. I tried unplugging the USB devices, but then it just stopped right before it would have loaded them and rebooted.

I will try to find/check the kernel logs now, and will reply if I find anything else.

-- Erik

P.S. xaeroman, when you were installing, did you notice that you had to run 'ybin' from outside the /mnt/gentoo chroot (the LiveCD is 2.4, my environment was 2.6, and they did not jive well together)?
Back to top
View user's profile Send private message
xaeroman
n00b
n00b


Joined: 24 Apr 2004
Posts: 12

PostPosted: Sun Jun 06, 2004 7:09 pm    Post subject: Reply with quote

I used the conf file from the 'ppc config db' sourceforge project.
And added video=ofonly (kindly confirm the syntax) to the kernel's startup params in /etc/yaboot.conf
Keep me posted..

Thanks,
Saket
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum