Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
radeon fb on ibook G4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
nicoske
n00b
n00b


Joined: 05 May 2004
Posts: 14
Location: Brussels

PostPosted: Wed May 05, 2004 9:34 pm    Post subject: radeon fb on ibook G4 Reply with quote

Hi,

When my custom kernel boot (with video=radeonfb), my monitor is fading out to black.. the computer is still available by ssh. I've enabled radeonfb and radeon dri in the kernel, and tried 2.4.25-ben1 & 2.5.6 vanilla.

Works fine if I force video=ofonly, but with this I can't use Xfree.

This is a new ibook G4 12" 1ghz.

Here is my dmesg: http://www.nectarine.be/files/dmesg
And my kernel config: http://www.nectarine.be/files/config
lspci output: http://www.nectarine.be/files/lspci
Back to top
View user's profile Send private message
nicoske
n00b
n00b


Joined: 05 May 2004
Posts: 14
Location: Brussels

PostPosted: Thu May 06, 2004 1:54 pm    Post subject: Reply with quote

I tried too without drm in kernel, same problem :-(
Back to top
View user's profile Send private message
homar
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jun 2002
Posts: 94

PostPosted: Thu May 06, 2004 3:28 pm    Post subject: Reply with quote

Working 2.6 config: http://homepage.ntlworld.com/super_ice/files/ppc/ibook-g4.config

Should also apply this patch: http://homepage.ntlworld.com/super_ice/files/ppc/ibook_g4_7447a.diff
Back to top
View user's profile Send private message
sienarot
n00b
n00b


Joined: 24 Sep 2003
Posts: 52
Location: Calgary, Alberta, Canada

PostPosted: Thu May 06, 2004 7:26 pm    Post subject: Reply with quote

I seem to have the same problem. I'm going to try using that config file as well as applying the patch. Question though... What comes first? Applying the patch then recompiling the kernel? Or compiling the kernel first then applying the patch?
Back to top
View user's profile Send private message
homar
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jun 2002
Posts: 94

PostPosted: Fri May 07, 2004 9:04 am    Post subject: Reply with quote

Apply the patch first, otherwise the screen will flicker.
Back to top
View user's profile Send private message
nicoske
n00b
n00b


Joined: 05 May 2004
Posts: 14
Location: Brussels

PostPosted: Fri May 07, 2004 3:03 pm    Post subject: Reply with quote

Thanks for your patch, I applied it (got a hunk) then recompiled my kernel from scratch with your config, I got the same problem :-/ black screen at boot.

Wich version of kernel do you use ? 2.6.5 ? vanilla or benh ?

Thx!
Back to top
View user's profile Send private message
overholt
n00b
n00b


Joined: 06 May 2004
Posts: 2

PostPosted: Fri May 07, 2004 3:42 pm    Post subject: Reply with quote

homar wrote:
Working 2.6 config: http://homepage.ntlworld.com/super_ice/files/ppc/ibook-g4.config

Should also apply this patch: http://homepage.ntlworld.com/super_ice/files/ppc/ibook_g4_7447a.diff


I applied the patch to a 2.6.4 tree and built. For some reason, though, I'm getting:

warning: unable to open initial console

Any ideas?

Thanks,

Andrew
Back to top
View user's profile Send private message
nicoske
n00b
n00b


Joined: 05 May 2004
Posts: 14
Location: Brussels

PostPosted: Fri May 07, 2004 4:43 pm    Post subject: Reply with quote

Ok, it's working fine now with your patch, I'm too stupid.. i've forget to relanch ybin :-p

Thanks !!
Back to top
View user's profile Send private message
sienarot
n00b
n00b


Joined: 24 Sep 2003
Posts: 52
Location: Calgary, Alberta, Canada

PostPosted: Fri May 07, 2004 8:19 pm    Post subject: Reply with quote

overholt wrote:
I applied the patch to a 2.6.4 tree and built. For some reason, though, I'm getting:

warning: unable to open initial console

Any ideas?

Thanks,

Andrew


I'm getting the same thing and the iBook reboots after that (I'm also using 2.6.4).

Also when I try to apply the patch, I get the following error:
Code:

Hunk #1 FAILED at 653.
1 out of 1 hunk FAILED -- saving rejects to a file linux/drivers/video/aty/radeon_monitor.c.rej


Any ideas?

nicoske: what kernel are you using?
Back to top
View user's profile Send private message
nicoske
n00b
n00b


Joined: 05 May 2004
Posts: 14
Location: Brussels

PostPosted: Sat May 08, 2004 12:51 pm    Post subject: Reply with quote

I'm using 2.6.5 vanilla, I got the hunk too, but it's only a warning.
X accelerated works fine with X 4.3.99 and radeon driver !
Back to top
View user's profile Send private message
nicoske
n00b
n00b


Joined: 05 May 2004
Posts: 14
Location: Brussels

PostPosted: Sun May 09, 2004 12:38 pm    Post subject: Reply with quote

One more question: Is it possible to don't use FBdev ? because playing dvd is laggy..
& glxgears give me only 400fps
Back to top
View user's profile Send private message
strider2003
Apprentice
Apprentice


Joined: 14 Sep 2003
Posts: 151
Location: Spain

PostPosted: Sun May 23, 2004 12:46 pm    Post subject: Reply with quote

I'm getting the same error:
Unable to open an initial console.
I'm using ppc-development-sources/2.6.5_rc2-r1 and I have patched the kernel with the patch above.
It's the third time I fail installing linux in my new iBook (first gentoo, then debian, again gentoo).
Please, help me if you can. Thanx.
Back to top
View user's profile Send private message
reddan
n00b
n00b


Joined: 18 Mar 2004
Posts: 26
Location: Mumbai

PostPosted: Sun May 23, 2004 10:54 pm    Post subject: Reply with quote

Kernel 2.6.3-benh2 (sys-kernel/ppc-development-sources-2.6.3-r2) works flawlessly on my iBook G4 800. I'm even using a FW drive as my boot/root drive.

I'm using xorg, and the radeon card works absolutely great. The machine boots up in fb mode and is fine.

My suggestion - pull your kernel back to 2.6.3. I tried 2.6.4 but that has *really* flaky firewire behaviour (ie kernel oops all over the place).

If you want my kernel .config or other config files just let me know.

cheers, dan.
Back to top
View user's profile Send private message
sienarot
n00b
n00b


Joined: 24 Sep 2003
Posts: 52
Location: Calgary, Alberta, Canada

PostPosted: Mon May 24, 2004 7:44 am    Post subject: Reply with quote

strider2003 wrote:
I'm getting the same error:
Unable to open an initial console.
I'm using ppc-development-sources/2.6.5_rc2-r1 and I have patched the kernel with the patch above.
It's the third time I fail installing linux in my new iBook (first gentoo, then debian, again gentoo).
Please, help me if you can. Thanx.


Did you enable PTY support in your kernel?

I'm pretty sure that's what you need to do. I had this problem as well and did a search on it and I believe that was the solution.
Back to top
View user's profile Send private message
strider2003
Apprentice
Apprentice


Joined: 14 Sep 2003
Posts: 151
Location: Spain

PostPosted: Mon May 24, 2004 11:35 am    Post subject: Reply with quote

Yes, I enabled PTY, just as the output of emerge development-source says, but I get the same error.
Now I have tried with development-sources/2.6.6, and the config file from the livecd, but I get another error during kernel compilation.
Back to top
View user's profile Send private message
strider2003
Apprentice
Apprentice


Joined: 14 Sep 2003
Posts: 151
Location: Spain

PostPosted: Mon May 24, 2004 7:31 pm    Post subject: Reply with quote

Finally I have made X work. I emerged development-sources/2.6.5 and used the config from the LiveCD.
I uninstalled Xfree and emerged Xorg. Now I can have X, booting with "video=radeonfb" but the screen does like an interlacing.
How can I correct it?
Back to top
View user's profile Send private message
strider2003
Apprentice
Apprentice


Joined: 14 Sep 2003
Posts: 151
Location: Spain

PostPosted: Mon May 24, 2004 7:46 pm    Post subject: Reply with quote

I'm stupid. I have applied the patch above, and it works fine.
Back to top
View user's profile Send private message
colinleroy
n00b
n00b


Joined: 24 Nov 2003
Posts: 50

PostPosted: Wed May 26, 2004 11:52 am    Post subject: Unable to open an initial console. Reply with quote

Quote:
Unable to open an initial console.

Friend of mine got this too, and found out he had no getty installed. He used agetty (emerge util-linux).

hth,
Colin
Back to top
View user's profile Send private message
Detronizator
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2003
Posts: 134
Location: Brusciano (Napoli - Italy)

PostPosted: Thu May 27, 2004 9:04 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic.php?p=1162612#1162612
_________________
Linux is Better!
...Love is too much complicated!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum