Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2004.1 livecd on PISMO [TEST-REQUEST]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
pvdabeel
Retired Dev
Retired Dev


Joined: 25 Mar 2003
Posts: 188
Location: Belgium

PostPosted: Thu May 06, 2004 12:31 am    Post subject: 2004.1 livecd on PISMO [TEST-REQUEST] Reply with quote

Apparently an extra hdc=ide-scsi is needed for the livecd to detect the cdrom. Can anybody verify?
Back to top
View user's profile Send private message
fatpiper
n00b
n00b


Joined: 10 Sep 2003
Posts: 18
Location: UK

PostPosted: Sat May 08, 2004 9:13 am    Post subject: Reply with quote

Peter,

I was the guy on IRC a couple days ago trying to troubleshoot my Pismo because it wasn't booting.

I just tried this, but it didn't work, gave the same error message:

Quote:

Examining locations for live environments:
>>> device /dev/cdroms/*
losetup: /mnt/live/mnt/cdrom/livecd.gcloop: No such file or directory
mount: Mounting /dev/loop/0 on /mnt/live/mnt/live-env failed: Invalid argument
(... cp a whole bunch of stuff fails ...)
/linuxrc: 245: mount: not found
/linuxrc: 246: cannot open dev/console: No such file
Kernel Panic: Rebooting in 180 seconds


If you have any other suggestions, I'm happy to test them

Thanks,
Dan
Back to top
View user's profile Send private message
genfoo
Apprentice
Apprentice


Joined: 17 Apr 2003
Posts: 192

PostPosted: Sat May 08, 2004 4:26 pm    Post subject: Reply with quote

IIRC ... the pismo's (and wallstreets) need an extra kernel option turned on for media bay support ... the hardware has to have this to power up the media bay before it detects (or tries to detect) the cd device...

This was covered once a long time ago by you guys in the forums here I think .. around the original 1.4 rc releases if i'm not mistaken.

I would venture a guess this may be the problem.
Back to top
View user's profile Send private message
fatpiper
n00b
n00b


Joined: 10 Sep 2003
Posts: 18
Location: UK

PostPosted: Mon May 10, 2004 10:42 pm    Post subject: Reply with quote

You wouldn't remember which kernel argument that is, would you?

I'll try to search for it.

edit
Found the original post from 2003, turns out they didn't mention what the specific kernel argument was in there either. Oh well. Suffice to know that there was one, and that it's supposedly mentioned somehwere the in the kernel configs.
https://forums.gentoo.org/viewtopic.php?t=11234
/edit

That said, I've finally got OS X.3 working on the Pismo, so I won't be installing Gentoo for now, but for posterity it's probably worth discovering exactly how to make 2004.1 work :)
_________________
--
"The power of accurate observation is commonly called cynicism by those who do not have it." -- George Bernard Shaw
Back to top
View user's profile Send private message
fatpiper
n00b
n00b


Joined: 10 Sep 2003
Posts: 18
Location: UK

PostPosted: Mon May 10, 2004 11:55 pm    Post subject: Reply with quote

Okay I found the thread bugreport where this stuff was originally discussed: https://bugs.gentoo.org/show_bug.cgi?id=6269

Current bug that pvdabeel filed for this is https://bugs.gentoo.org/show_bug.cgi?id=50151.

Please see the rest of this bug's unfolding there.
_________________
--
"The power of accurate observation is commonly called cynicism by those who do not have it." -- George Bernard Shaw
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum