Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[litl tip] Thomson Speedtouch 330 USB *silver* - firmware
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Lepaca Kliffoth
l33t
l33t


Joined: 28 Apr 2004
Posts: 737
Location: Florence, Italy

PostPosted: Sat May 08, 2004 11:29 am    Post subject: [litl tip] Thomson Speedtouch 330 USB *silver* - firmware Reply with quote

[Beware: I'm italian and I'm writing in english...]

This is a small tip abut getting the silver adsl modem to work. If you followed the guide you're probably using either the firmware provided with windows' drivers (ouch) or something you downloaded from the speedtouch official website. You must know there is a better firmware out there, which at this time is still not available on the speedtouch website. If you are experiencing any one of the following:

- disconnections without any apparent reason
- if you get disconnected you need to detach and reattach your modem, otherwise it doesn't work
- if you get disconnected you need to reboot your pc, otherwise the modem doesn't work
- lots of error messages "USBDEVFS_BULK failed" in your /var/log/messages even if you're launching modem_run with the "-s" option
- long delays before the modem synchs (before the "adsl" led on it stops blinking)

...then you DEFINITELY have to give this other firmware a shot. To put it simply, it solved all my problems.
Because of copyright issues I don't feel like distributing it through my ftp, so just PM me. The fastest way to obtain it however is running a search on google. The firmware is a set of 2 files, ZZZLP1.eni and ZZZLP2.eni . While ZZZLP2 is the actual firmware, ZZZLP1 is needed as well since it contains the boot code - this is essential for the modem to work. Now let's say you have obtained both these cute files. Here is the only configuration file you have to change (/etc/conf.d/speedtouch); of course I'm not going to rewrite the whole speedtouch installation guide, but this is crucial so here it is:

Code:

GNU nano 1.3.2                                  File: /etc/conf.d/speedtouch                                   

# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# $Header: /home/cvsroot/gentoo-x86/net-dialup/speedtouch/files/speedtouch.confd,v 1.3 2004/03/04 19:13:39 vapier Exp $

# Config file for the speedtouch ebuild

# Set the microcode path
MICROCODE="/root/adsl/ZZZLP2.eni"

# Set verbose level for modem_run
VERBOSE="1"

# Set the peer filename
# This should be in /etc/ppp/peers/
PEER="adsl"

# Extra options to modem_run
# Some modems will need -s, if in doubt then leave blank
MODEM_RUN_EXTRAOPTS="-s -k -a /root/adsl/ZZZLP1.eni"


As you can see I placed both files in /root/adsl/; I'm using ZZLP2 as the actual microcode. Now put EXTRA attention reading the MODEM_RUN_EXTRAOPTS line:
-s : stops the "USBDEVFS_BULK failed" error messages.
-k : just look at the modem_run man page
-a /path/to/boot/code.eni : That's how you tell modem_run to use the boot code ZZZLP1.eni

That's it. When you connect the "adsl" led will blink 4/6 times and you're synched. No strange errors. If you get disconnected, you'll see the "adsl" led start blinking again. It'll take 4/6 blinks (again) to get back online. You DON'T have to detach it or anything, just wait.

I hope it'll work for you too ;)
_________________
It isn't enough to win - everyone else must lose, and you also have to rub it in their face (maybe chop off an arm too for good measure).
Animebox!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum