Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: qmail vpopmail courier-imap qmail-scanner etc (NEW)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 23, 24, 25  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
flashingcurser
n00b
n00b


Joined: 25 Mar 2004
Posts: 34

PostPosted: Tue Jul 06, 2004 3:23 am    Post subject: Problems with rcpthosts Reply with quote

1. I can create accounts with vadduser -- except for the accounts to actualy work I have to ln -s .maildir with Maildir -- anyone found a way around this?

2. Recieving email works -- Ya!

3. QmailAdmin works except you cannot create accouts because you have to work around in #1

4. Cannot send emails--In outlook exspress I get the error

Code:
The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was '????dan@sbcglobal.net'. Subject 'asdf', Account: '????.????.org', Server: '192.168.2.254', Protocol: SMTP, Server Response: '553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)', Port: 25, Secure(SSL): No, Server Error: 553, Error Number: 0x800CCC79


(Names have been changed to protect the guilty)

I have somewhat narrowed the problem down and maybe some of you can help me from here.
If I put sbcglobal.net in the /var/qmail/control/rcpthosts it sends just fine

Before someone asks--
Code:
# Qmail-Scanner disabled for mail from 127.0.0.1
127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue"
# Qmail-Scanner enabled (virus only) for mail from local network
192.168.2.1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"
192.168.2.2:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"
192.168.2.3:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"
192.168.2.4:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"
192.168.2.5:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"
192.168.2.6:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"
# Qmail-Scanner enabled (virus and spam) for mail from external internet
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"



Any thoughts guys?

Thanks[/b]
Back to top
View user's profile Send private message
rjreb
n00b
n00b


Joined: 19 Aug 2003
Posts: 40

PostPosted: Tue Jul 06, 2004 10:25 pm    Post subject: Reply with quote

I've tried to search this but didn't find anything. Is anyone else having problems where people try to check their email via POP and get as far as (for example) downloading 3 of 20 messages and it just stops. If they turn off their email scanner (seems to be a Nortons issue) running locally it will then download okay. I've tried to convince them it's not necessary to run an email scanner locally but that's unacceptable for a few. Is there something in the headers that Nortons doesn't like?
Back to top
View user's profile Send private message
xkb
n00b
n00b


Joined: 13 Jun 2002
Posts: 20
Location: Netherlands

PostPosted: Wed Jul 07, 2004 8:20 am    Post subject: Reply with quote

Hi, since my last upgrade to ~86 qmail-scanner and vpopmail the cronjob of qmail-scanner fails:

Code:

cannot write to /var/spool/qmailscan/qmail-scanner-queue-version.txt.tmp - Permission denied at /var/qmail/bin/qmail-scanner-queue.pl line 1589.


Problem seems to be incorrect permissions on the qmail-scanner /var/spool dir. Anyone else having this problem? How did you solve it?
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Wed Jul 07, 2004 1:08 pm    Post subject: Reply with quote

xkb wrote:
Hi, since my last upgrade to ~86 qmail-scanner and vpopmail the cronjob of qmail-scanner fails:...

I had the same problem. The problem was permissions for qmail-scanner. Did you follow the part of the howto below:
Code:
Please log into the "qmaild" account  and run
/var/qmail/bin/qmail-scanner-queue.pl -g
 
If you see the error "Can't do setuid", or "Permission denied", then
refer to the FAQ.
 
(e.g.  "setuidgid qmaild "/var/qmail/bin/qmail-scanner-queue.pl -g"
or "su qmaild -c "/var/qmail/bin/qmail-scanner-queue.pl -g")

_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Wed Jul 07, 2004 1:15 pm    Post subject: Re: Problems with rcpthosts Reply with quote

flashingcurser wrote:
1. I can create accounts with vadduser -- except for the accounts to actualy work I have to ln -s .maildir with Maildir
The only way I could get maildir to work properly for me was to put "maildir -mbox" in my use flags. Maybe try putting those in your use flags and re-emerge qmail and vpopmail.
Not sure about your other problem.
_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
Tilly
n00b
n00b


Joined: 20 Apr 2003
Posts: 35

PostPosted: Wed Jul 07, 2004 7:27 pm    Post subject: Reply with quote

Hey

I am having the smae problem.

Code:
The SMTP server returned an error. Subject 'asdf', Account: '192.168.1.100', Server: '192.168.1.100', Protocol: SMTP, Server Response: 'Permission denied', Port: 25, Secure(SSL): No, Error Number: 0x800CCC60


I followed all the things that i should do to solve the problem but it doesnt work. And what FAQ do i look at.

Tilly
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Thu Jul 08, 2004 2:06 pm    Post subject: Re: Problems with rcpthosts Reply with quote

flashingcurser wrote:
1. I can create accounts with vadduser -- except for the accounts to actualy work I have to ln -s .maildir with Maildir -- anyone found a way around this?

Make sure you have the correct use flags in /etc/make.conf. (maildir, mbox, ...)
Also make sure you emerged the correct versions of the packages used by this guide. Older pakkages has problems with maildir.

flashingcurser wrote:

4. Cannot send emails--In outlook exspress I get the error

Code:
The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was '????dan@sbcglobal.net'. Subject 'asdf', Account: '????.????.org', Server: '192.168.2.254', Protocol: SMTP, Server Response: '553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)', Port: 25, Secure(SSL): No, Server Error: 553, Error Number: 0x800CCC79


You got a lot of local ip adresses in your /etc/tcp.smtp. Are your sure the pc you're sending from is included among them? Did you run the tcp rules update after updating the file?
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Thu Jul 08, 2004 2:09 pm    Post subject: Reply with quote

rjreb wrote:
I've tried to search this but didn't find anything. Is anyone else having problems where people try to check their email via POP and get as far as (for example) downloading 3 of 20 messages and it just stops. If they turn off their email scanner (seems to be a Nortons issue) running locally it will then download okay. I've tried to convince them it's not necessary to run an email scanner locally but that's unacceptable for a few. Is there something in the headers that Nortons doesn't like?


I haven't had that problem with the qmail/courier server, but had something similar with an other mailserver. Disabeling local virus check is probably not a good idea as e-mail is only one of many way a virus comes.
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Thu Jul 08, 2004 2:12 pm    Post subject: Reply with quote

Tilly wrote:
Hey

I am having the smae problem.

Code:
The SMTP server returned an error. Subject 'asdf', Account: '192.168.1.100', Server: '192.168.1.100', Protocol: SMTP, Server Response: 'Permission denied', Port: 25, Secure(SSL): No, Error Number: 0x800CCC60


I followed all the things that i should do to solve the problem but it doesnt work. And what FAQ do i look at.

Tilly


Is the computer your sending mail from included in the /ect/tcp.smtp ?
Try to switch on or off (depending on current state) SSL in your client.
Back to top
View user's profile Send private message
Tilly
n00b
n00b


Joined: 20 Apr 2003
Posts: 35

PostPosted: Thu Jul 08, 2004 3:02 pm    Post subject: Reply with quote

Hey

That is the error i get when i try to send mail with qmail-scanner enabled in tcp.smtp. When i have it disabled, I can send email just fine.

Tilly
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Fri Jul 09, 2004 9:08 am    Post subject: Reply with quote

Tilly wrote:
Hey

That is the error i get when i try to send mail with qmail-scanner enabled in tcp.smtp. When i have it disabled, I can send email just fine.

Tilly


Try to reemerge qmail-scanner. The reconfigure it like the howto say.
Back to top
View user's profile Send private message
maxulanhot
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2003
Posts: 89
Location: Northeast China

PostPosted: Fri Jul 09, 2004 2:27 pm    Post subject: Reply with quote

well , it is a wonderful guide.
But I'm wondering how to use mutt to read/send mail?
Anybody has idea?
_________________
-- The Most Gentooer --
Back to top
View user's profile Send private message
Tilly
n00b
n00b


Joined: 20 Apr 2003
Posts: 35

PostPosted: Fri Jul 09, 2004 3:49 pm    Post subject: Reply with quote

Hey

I remerged qmail-scanner. And i stil lget the cant do setuid. WTF is up this. And what FAQ is the guy refering to in the tutorial. Am i missing a perl module.

Tilly
Back to top
View user's profile Send private message
maxulanhot
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2003
Posts: 89
Location: Northeast China

PostPosted: Sat Jul 10, 2004 10:00 am    Post subject: Reply with quote

faint!
The qmail-scanner didn't work .
I got the error of log:
Code:

 cannot open /var/spool/qmailscan/qmail-scanner-queue-version.txt - did you initialise the system by running "qmail-scanner-queue.pl -z"? - Permission denied

Code:

root qmailscan # ls -la
total 64
drwxr-xr-x  6 qmaild nofiles   416 Jul 10 17:41 ./
drwxr-xr-x  8 root   root      232 Jul 10 17:39 ../
-rw-r--r--  1 qmaild nofiles     0 Jul 10 17:39 .keep
drwxr-xr-x  5 qmaild nofiles   120 Jul 10 17:39 archive/
-rw-------  1 qmaild nofiles   635 Jul 10 17:39 qmail-queue.log
-rw-rw----  1 qmaild root       23 Jul 10 17:39 qmail-scanner-queue-version.txt
drwxr-xr-x  5 qmaild nofiles   120 Jul 10 17:39 quarantine/
-rw-r-----  1 qmaild nofiles 49152 Jul 10 17:41 quarantine-attachments.db
-rw-r--r--  1 qmaild nofiles  4279 Jul 10 17:39 quarantine-attachments.txt
-rw-r--r--  1 qmaild nofiles     0 Jul 10 17:39 quarantine.log
drwxr-xr-x  2 qmaild nofiles    72 Jul 10 17:39 tmp/
lrwxrwxrwx  1 root   root       14 Jul 10 17:39 viruses.log -> quarantine.log
drwxr-xr-x  5 qmaild nofiles   120 Jul 10 17:39 working/

Did above correctly?
_________________
-- The Most Gentooer --
Back to top
View user's profile Send private message
Tilly
n00b
n00b


Joined: 20 Apr 2003
Posts: 35

PostPosted: Sat Jul 10, 2004 4:18 pm    Post subject: Reply with quote

Hey

What version of qmail scanner are you running.

Tilly
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Sat Jul 10, 2004 7:19 pm    Post subject: Reply with quote

Looks like your permissions are messed up maxulanhot.
Mine are:
Code:
drwxr-xr-x  6 qscand qscand      448 Jul 10 03:12 .
drwxr-xr-x  8 root   root        224 Jun 18 18:07 ..
-rw-r--r--  1 root   root          0 Jul  5 23:54 .keep
drwxr-xr-x  5 qscand qscand      120 May 24 23:35 archive
-rw-------  1 qscand nofiles   53710 Jul  8 23:21 mailstats.csv
-rw-------  1 qscand qscand  1079598 Jul 10 03:12 qmail-queue.log
-rw-------  1 qscand root         43 Jul 10 03:12 qmail-scanner-queue-version.txt
drwxr-xr-x  5 qscand qscand      120 May 24 23:35 quarantine
-rw-r-----  1 qscand qscand    49152 Jul  6 00:10 quarantine-attachments.db
-rw-r--r--  1 qscand qscand     4279 Jul  5 23:54 quarantine-attachments.txt
-rw-r--r--  1 qscand qscand        0 Jul 10 13:20 quarantine.log
drwx------  2 qscand qscand       48 Jul  9 03:11 tmp
lrwxrwxrwx  1 root   root         14 Jul  5 23:54 viruses.log -> quarantine.log
drwxr-xr-x  5 qscand qscand      120 May 24 23:35 working

my version of qmail-scanner is 1.20
_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Sun Jul 11, 2004 4:46 pm    Post subject: Reply with quote

Tilly wrote:
Hey

I remerged qmail-scanner. And i stil lget the cant do setuid. WTF is up this. And what FAQ is the guy refering to in the tutorial. Am i missing a perl module.

Tilly


You have quite a few options to run stuff as the qmail user. The easiest for you might be to edit /etc/passwd. Make a backup of it before you edit! Goto the line with the username you want to run as (qmail). Replace /bin/false with /bin/bash. Save, exit.
Then run "su qmail"
Run the script
exit
restore /etc/passwd from the backup.
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Sun Jul 11, 2004 4:51 pm    Post subject: Reply with quote

maxulanhot wrote:
faint!
The qmail-scanner didn't work .
I got the error of log:
Code:

 cannot open /var/spool/qmailscan/qmail-scanner-queue-version.txt - did you initialise the system by running "qmail-scanner-queue.pl -z"? - Permission denied


Well, did you initialise the system by running "qmail-scanner-queue.pl -z"?
Back to top
View user's profile Send private message
capitanjackal
n00b
n00b


Joined: 26 Aug 2003
Posts: 69
Location: Quarata (CALIFORNIA)

PostPosted: Mon Jul 12, 2004 10:34 am    Post subject: Reply with quote

I'have a little question about spamassassin:

If I use default options it works (SPAMD_OPTS="-a -c"), but if I change the /etc/conf.d/spamd in:

SPAMD_OPTS="-a -v -x -u vpopmail -C /var/vpopmail/.spamassassin/local.cf"

It gives 0 points to all email.

any idea ?

thanks

Giacomo
_________________
Meglio una Fiat 500 con 500 watts che una Fiat Punto con punti watts!
PS: ho comprato la punto! sono un l00s3r
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Tue Jul 13, 2004 4:48 am    Post subject: Reply with quote

capitanjackal wrote:
I'have a little question about spamassassin:

If I use default options it works (SPAMD_OPTS="-a -c"), but if I change the /etc/conf.d/spamd in:

SPAMD_OPTS="-a -v -x -u vpopmail -C /var/vpopmail/.spamassassin/local.cf"

It gives 0 points to all email.

any idea ?

thanks

Giacomo


I had a hard time getting it to work too. Try:
Code:
SPAMD_OPTS="-v -u vpopmail --siteconfigpath=/etc/mail/spamassassin/local.cf"

_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
Benji-Boy
n00b
n00b


Joined: 13 Jul 2004
Posts: 13

PostPosted: Wed Jul 14, 2004 5:10 am    Post subject: Reply with quote

Dear SaberX,

This is my first post!
I have not had to ask a question so far having converted from Win XP because of this forum.

Thanks for the great tutorial so far.
I am running an email server to collect legitimate and spam emails for research i am doing at uni.

One little problem i have had so far:
step 4) last line

Code:

bash-2.05b# /etc/init.d/courier-imapd start
 * Starting authdaemond.plain...                                          [ ok ]
 * Starting courier-imapd...                                              [ ok ]
bash-2.05b# /etc/init.d/courier-pop3d start
 * Starting courier-pop3d...
bind: Address already in use
ll_daemon_start: Resource temporarily unavailable                         [ !! ]


any ideas? I believe others have the same problem...


Gentoo has the best forums!
Thanks for all being so helpful and patient.
_________________
How can one learn if one does not try?
Failure is temporary.
[>=We are what we choose to do=<]


Last edited by Benji-Boy on Wed Jul 14, 2004 7:42 am; edited 1 time in total
Back to top
View user's profile Send private message
Benji-Boy
n00b
n00b


Joined: 13 Jul 2004
Posts: 13

PostPosted: Wed Jul 14, 2004 5:17 am    Post subject: Reply with quote

Just one other thing:

mutt

which package do i emerge it from?

I assume it is a command line exe but I haven't installed it yet.

Cheers,
Benji-Boy
_________________
How can one learn if one does not try?
Failure is temporary.
[>=We are what we choose to do=<]
Back to top
View user's profile Send private message
Benji-Boy
n00b
n00b


Joined: 13 Jul 2004
Posts: 13

PostPosted: Wed Jul 14, 2004 7:37 am    Post subject: Reply with quote

Ok so the first part of the last post was really dumb :oops:
emerge mutt ;)

Next (silly) question what are the config steps, where does one pont mutt to the maildirectory/database?

nepenthe wrote:
I am afraid I do not know the login for qmail admin... as well I am missing the command vadddomain


I've read about vadddomain and vadduser being used to creat accounts but I wanted to point out these commands are not in /usr/bin THE ARE located in.

Code:
 /var/vpopmail/bin


or alterntively

Code:
 source /etc/profile


Also on a security note:
I want to get all email passed through on this server as it is for research purposes and I don't want any spamassassination or virus filtering on incoming mail, ( it is part of the solution that we're working on).

However as i am not suicidal either 8) are their any recommendations of virus software & installation that i should have running to protect the rest of the system from the nasty emails?

Thanks Guys.[/code]
_________________
How can one learn if one does not try?
Failure is temporary.
[>=We are what we choose to do=<]


Last edited by Benji-Boy on Thu Jul 15, 2004 12:54 am; edited 2 times in total
Back to top
View user's profile Send private message
xkb
n00b
n00b


Joined: 13 Jun 2002
Posts: 20
Location: Netherlands

PostPosted: Wed Jul 14, 2004 8:11 am    Post subject: Reply with quote

Hi,

I dug up a new problem. After getting a working mailsystem by following the HOWTO, I wanted to filter spam-tagged mail automatically server based. I choose Maildrop for it as it got installed allready with qmail-scanner.

I'm not having any luck though. I searched google where someone stated I should run makeuserdb and vchkpw2userdb. I did.

I created a .qmail file in the users virtual home dir under /var/vpopmail/domains/mydomain.net/user/.qmail

It contains:
|/usr/bin/maildrop

the users virtual dir contains a .mailfilter file thats vpopmail:vpopmail 600

So far so good. However maildrop keeps complaining about the following:
Code:

@4000000040f4e7743248a864 delivery 95: deferral: /usr/bin/maildrop:_Invalid_home_directory_permissions_-_world_writable./

Whereas the virtual homedir of the user is:
Code:

cp15766-b user # ls -l /var/vpopmail/domains/mydomain.net/
total 1
drwx------  3 vpopmail vpopmail 136 Jul 14 10:00 user


Any clues how to solve this?
Back to top
View user's profile Send private message
ievil
n00b
n00b


Joined: 22 Mar 2003
Posts: 10

PostPosted: Thu Jul 15, 2004 11:43 am    Post subject: Problems with checking mail... Reply with quote

Everything (!?!?!?) works perfectly when my server is delivering mail...
But when I try to collect it through imap or pop3 I get some strange behavior.

Code:
Jul 15 13:39:23 trance imapd: Connection, ip=[::ffff:1.2.3.4]
Jul 15 13:39:23 trance imapd: LOGIN: DEBUG: ip=[::ffff:1.2.3.4], command=CAPABILITY
Jul 15 13:39:23 trance imapd: LOGIN: DEBUG: ip=[::ffff:1.2.3.4], command=LOGIN
Jul 15 13:39:23 trance imapd: LOGIN: DEBUG: ip=[::ffff:1.2.3.4], username=arnvid@mydomain.com
Jul 15 13:39:23 trance imapd: LOGIN: DEBUG: ip=[::ffff:1.2.3.4], password=mypass
Jul 15 13:39:28 trance imapd: LOGIN FAILED, ip=[::ffff:1.2.3.4]
Jul 15 13:39:28 trance imapd: LOGIN: DEBUG: ip=[::ffff:1.2.3.4], command=LOGOUT
Jul 15 13:39:28 trance imapd: LOGOUT, ip=[::ffff:1.2.3.4]



Not really to much information here at all :(

[/code]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 23, 24, 25  Next
Page 8 of 25

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum