Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: qmail vpopmail courier-imap qmail-scanner etc (NEW)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 23, 24, 25  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Sun Jan 09, 2005 2:59 pm    Post subject: Reply with quote

I was using this configuration for quite some time when I did an emerge sync and emerge -uD world -- well for some reason, it broke the whole thing.

I don't see anything horribly wrong in the qmail logs, however, when I try "telnet mail.myserver.com 25" -- it tells me that the host isn't responding, but I can get a promt on port 143, and I can use qmail-admin still, but I cannot send any mail... maybe other things wrong after that, but that's as far as I got.

I verified the config files are exactly like in the tutorial.

Am I missing something? Anyone else had this problem?
Back to top
View user's profile Send private message
Gatak
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2004
Posts: 126

PostPosted: Sun Jan 09, 2005 4:56 pm    Post subject: Reply with quote

seriousmoose wrote:
I was using this configuration for quite some time when I did an emerge sync and emerge -uD world -- well for some reason, it broke the whole thing.

I don't see anything horribly wrong in the qmail logs, however, when I try "telnet mail.myserver.com 25" -- it tells me that the host isn't responding, but I can get a promt on port 143, and I can use qmail-admin still, but I cannot send any mail... maybe other things wrong after that, but that's as far as I got.

I verified the config files are exactly like in the tutorial.

Am I missing something? Anyone else had this problem?
check your messages log and see if qmail (svscan) is starting at all.

You can do a netstat -anp|grep 25 to see if anything is listening on port 25.

I have learned the hard way too that upgrading qmail, qmail-queue or spamassassin or perl can be bad. Perl is needed for both spamassassin and qmail-queue/qmail-scanner. In more recent versions, they have added security features making qmail-queue to fail. You should check into that.
Back to top
View user's profile Send private message
stripe
n00b
n00b


Joined: 04 Jan 2004
Posts: 72
Location: Prague

PostPosted: Sun Jan 09, 2005 8:09 pm    Post subject: Reply with quote

seriousmoose wrote:
I was using this configuration for quite some time when I did an emerge sync and emerge -uD world -- well for some reason, it broke the whole thing.



check the logs, mail.err mail.log, qmail-queue.log, if there are some "permission denied" items, if so, please go back in this thread and concern on my posts about upgrading....
_________________
Sick of computers? Well, Czech girls and beer solve it! Trust me :-)
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Mon Jan 10, 2005 3:03 am    Post subject: Reply with quote

thanks for taking time to help!

Yes, it seems weird that it's listening on 0.0.0.0:

Code:
tcp        0      0 0.0.0.0:993             0.0.0.0:*               LISTEN      25631/couriertcpd
tcp        0      0 0.0.0.0:995             0.0.0.0:*               LISTEN      25867/couriertcpd
tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN      25787/couriertcpd
tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN      25709/couriertcpd
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      25950/tcpserver


I remember when installing it, it detected ... the ips it should be listening on... I'll look at that to see if there's a problem.

I've only looked at the logs in /var/log/qmail for errors... I'll check the others if I get nothing.

thanks again
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Mon Jan 10, 2005 4:12 am    Post subject: Reply with quote

actually, that's not really the problem

-------------------

I looked into /etc/tcprules.d/tcp.qmail-smtp and everything looked good there...

specifically, this is the error I get when trying to connect with outlook express:

Your 'Inbox' folder was not polled for its unread count. Your IMAP server has closed the connection. This may occur if you have left the connection idle for too long. Account: 'mail.ushcare.com', Server: 'mail.ushcare.com', Protocol: IMAP, Server Response: 'Temporary problem, please try again later', Port: 993, Secure(SSL): Yes, Error Number: 0x800CCCDD

I get the same error when using plain (nonssl) on 143.

EDIT:

Errors fixed (I think):
there was a broken table in vpopmail database

Errors outstanding:
#1 --- /etc/init.d/spamd restart doesn't work -- no way for me to test this yet
#2 --- I still cannot connect to imap or smtp -- still can't figure out why
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Mon Jan 10, 2005 2:55 pm    Post subject: Reply with quote

seriousmoose: May it helps to unemerge and reemerge qmail?
It worked for me when I had similar problems. (Can't remember if I did the same with vpopmail.)
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Mon Jan 10, 2005 4:00 pm    Post subject: Reply with quote

many times I've done it.

I even did

rm -rf /var/qmail/*

and recreated everything... still no go

does anyone have this configuration running on qmail-1.03-r15 and the latest vpopmail and courier???

if I can't figure out in a few more hours, I'm going to try downgrading to see if it's the packages that are causing the problems....

------------------------------

/var/log/qmail doesn't have any errors
/var/log/messages doesn't have any errors

am I missing something?

------------------------------

edit: making progress... I got courier-imap working and authenticating with vpopmail now. still qmail is not cooperating (if anyone cares, the courier-authlib needs to be recompiled, then don't make same mistake as me and forget to restart the service)

emerge courier-authlib
/etc/init.d/courier-authlib restart
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Tue Jan 11, 2005 1:54 am    Post subject: ucspi-tcp problem: can't relay Reply with quote

:(

Recently, i've upgraded several packages on my system BIG STUPIDITY! because it's a production server. One of this package was ucspi-tcp-0.88-r8 to sys-apps/ucspi-tcp-0.88-r9

When finished upgrade show me the message:
* We have started a move to get all tcprules files into
* /etc/tcprules.d/, where we have provided a Makefile to
* easily update the CDB file.


I found the Makefile but I can't do nothing with it (dunno). I only copied /etc/tcp.* to /etc/tcprules.d folder and did

#make *.cdb
make: `tcp.pop3.cdb' is up to date.
make: `tcp.qmqp.cdb' is up to date.
make: `tcp.qmtp.cdb' is up to date.
make: `tcp.smtp.cdb' is up to date.


What else should i do with this file ??? :?

Now i can't relay neither from any of my LAN computers nor localhost via Squirrelmail. Everytime it show me the message:

553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)

The only way my users can send email is trough smtp-auth. However when I tried the following everything seems ok:

#TCPREMOTEIP="127.0.0.1" tcprulescheck tcp.smtp.cdb
rule 127.0.0.1:
set environment variable RELAYCLIENT=
set environment variable RBLSMTPD=
set environment variable QMAILQUEUE=/var/qmail/bin/qmail-queue
allow connection


Actually my /etc/tcp/tcp.smtp.cdb and /etc/tcprules.d/tcp.smtp.cdb, both look like:

127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue"
X.Y.Z.64-95:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"



Ohhhh, almost forget this, when i tried:

#/etc/init.d/svscan restart

it only increases the curse, getting this error again and again, forever:

supervise: fatal: unable to acquire qmail-send/supervise/lock: temporary failure
supervise: fatal: unable to acquire qmail-send/supervise/lock: temporary failure
supervise: fatal: unable to acquire qmail-send/supervise/lock: temporary failure

Pleeeeaseeee, what can i do? I'm really desperate. My web users wanna kill me. They can't send email for the last 2 days. :cry:

Any ideas?
Back to top
View user's profile Send private message
Gatak
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2004
Posts: 126

PostPosted: Tue Jan 11, 2005 4:18 am    Post subject: Reply with quote

perhaps it is a permissions failure so that it cannot creat or open the lock files? check them.
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Tue Jan 11, 2005 5:42 am    Post subject: Reply with quote

if it makes you feel better, I have a lot of the same errors as you !!!

----------------------

So far, all I've fixed the courier-imap so I can download mail from the server though pop3 and imap, then I fixed qmail so it can get receive email, and such, but I cannot, under any circumstances fix the server my users can send mail either. I'll let you know if I fix that one.

After I get this working, I'm going to rewrite the howto, because the steps have changed so much with the new qmail, and some general changes in courier-imap.

----------------------

I can help you with some of your errors though...

For the supervise: fata: one, I had to fix that one, by unmerging qmail, deleting the /services directory, then deleting the /var/qmail/* directories too. (remember to backup your /var/qmail/users/ directory first though... you may want to just move the dir, instead of deleting it)

Then, I applied the patch found in this bug:

https://bugs.gentoo.org/show_bug.cgi?id=71571

After that, I emerged qmail, and then I had to redo my control configs (no big deal) then, there may have been a few other retarded bugs, but nothing that can't be solved by running the appropriate vpopmail utils.

EDIT:

also, when I update my .cdb files, they have differnt names:
srv1 tcprules.d # make *.cdb
make: `tcp.qmail-pop3.cdb' is up to date.
make: `tcp.qmail-qmqp.cdb' is up to date.
make: `tcp.qmail-qmtp.cdb' is up to date.
make: `tcp.qmail-smtp.cdb' is up to date.
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Tue Jan 11, 2005 7:03 am    Post subject: Reply with quote

Quote:

For the supervise: fata: one, I had to fix that one, by unmerging qmail, deleting the /services directory, then deleting the /var/qmail/* directories too. (remember to backup your /var/qmail/users/ directory first though... you may want to just move the dir, instead of deleting it)


I really appreciate it. But i don't want to take that risk yet. I will try to reemerge qmail in worse case.

Quote:

Then, I applied the patch found in this bug:

https://bugs.gentoo.org/show_bug.cgi?id=71571


The patch applies to qmail-1.03-r15 and I'm using qmail-1.03-r13. Anyway i found that my /var/qmail/supervise directories were already owned by root . I tried chowning to root:qmail but didn't work either.

Quote:
also, when I update my .cdb files, they have differnt names:
srv1 tcprules.d # make *.cdb
make: `tcp.qmail-pop3.cdb' is up to date.
make: `tcp.qmail-qmqp.cdb' is up to date.
make: `tcp.qmail-qmtp.cdb' is up to date.
make: `tcp.qmail-smtp.cdb' is up to date.


Are you ACCEPTING_KEYWORDS="~x86" ??? because i remember one time i did something like that in other server and my tcp files look like yours. After hours of experiments and headaches i decided to keep my productions servers as stable as possible and far away of last updates. That's why I never updated my qmail-scanner 1.23-r3+ f-prot TO qmail-scanner 1.24 + clamav.

This time i broke that rule with uscpi-tcp and these are the consequences. I'm really tired of all that stress with gentoo-updates. At least everything else is working fine.
Back to top
View user's profile Send private message
Gatak
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2004
Posts: 126

PostPosted: Tue Jan 11, 2005 7:10 am    Post subject: Reply with quote

Are you sure you have the right name for the tcp*.cdb files?

I have seen two variants:
Code:

-rw-r--r--  1 root root  335 Apr  4  2004 /etc/tcp.pop3
-rw-r--r--  1 root root 2072 Apr  4  2004 /etc/tcp.pop3.cdb
-rw-r--r--  1 root root   90 Apr  4  2004 /etc/tcp.qmqp
-rw-r--r--  1 root root 2168 Apr  4  2004 /etc/tcp.qmqp.cdb
-rw-r--r--  1 root root   90 Apr  4  2004 /etc/tcp.qmtp
-rw-r--r--  1 root root 2168 Apr  4  2004 /etc/tcp.qmtp.cdb
-rw-r--r--  1 root root  684 Sep 11 03:01 /etc/tcp.smtp
-rw-r--r--  1 root root 2408 Jan  3 01:00 /etc/tcp.smtp.cdb
Code:

-rw-r--r--  1 root root  335 Apr  4  2004 /etc/tcprules.d/tcp.qmail-pop3
-rw-r--r--  1 root root 2072 Apr  4  2004 /etc/tcprules.d/tcp.qmail-pop3.cdb
-rw-r--r--  1 root root   90 Apr  4  2004 /etc/tcprules.d/tcp.qmail-qmqp
-rw-r--r--  1 root root 2168 Apr  4  2004 /etc/tcprules.d/tcp.qmail-qmqp.cdb
-rw-r--r--  1 root root   90 Apr  4  2004 /etc/tcprules.d/tcp.qmail-qmtp
-rw-r--r--  1 root root 2168 Apr  4  2004 /etc/tcprules.d/tcp.qmail-qmtp.cdb
-rw-r--r--  1 root root  588 Jan  2 22:25 /etc/tcprules.d/tcp.qmail-smtp
-rw-r--r--  1 root root 2408 Jan  3 00:59 /etc/tcprules.d/tcp.qmail-smtp.cdb
The tcp.qmail-smtp looks like this:
Code:

# Qmail-Scanner disabled for mail from 127.0.0.1
127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue"
::1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue"
# Qmail-Scanner enabled (virus only) for mail from local network
192.168.0.:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue"
# Qmail-Scanner enabled (virus and spam) for mail from external internet
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Tue Jan 11, 2005 7:21 am    Post subject: Reply with quote

Well, I really have no idea what is wrong for me...

btw, I just downgraded to qmail-1.03-r13 and it doesn't give me the error that you had. I don't understand why it's not working:

listening:
Code:
tcp        0      0 0.0.0.0:993             0.0.0.0:*               LISTEN      9444/couriertcpd
tcp        0      0 0.0.0.0:2401            0.0.0.0:*               LISTEN      2452/cvsd
tcp        0      0 0.0.0.0:995             0.0.0.0:*               LISTEN      9600/couriertcpd
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      1876/mysqld
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      2661/smbd
tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN      9522/couriertcpd
tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN      9366/couriertcpd
tcp        0      0 127.0.0.1:783           0.0.0.0:*               LISTEN      4120/local.cf


-r13 seems to not use the tcprules.d:
Code:
# ps aux | grep tcpserver
qmaild   15458  0.0  0.1   2864   812 pts/1    S    23:03   0:00 /usr/bin/tcpserver -p -v -R -x /etc/tcp.smtp.cdb -c 40 -u 201 -g 200 0.0.0.0 smtp /var/qmail/bin/qmail-smtpd mail.ushcare.com /var/vpopmail/bin/vchkpw /bin/true


my servers seem to be running fine:
Code:
# svstat /service/qmail-smtpd /service/qmail-smtpd/log
/service/qmail-smtpd: up (pid 15556) 83 seconds
/service/qmail-smtpd/log: up (pid 15567) 83 seconds


telnet doesn't work though:
Code:
telnet mail.ushcare.com 25
Connecting To mail.ushcare.com...Could not open connection to the host, on port
25: Connect failed


no configuration errors:
Code:
# /etc/init.d/svscan stop
 * Stopping service scan ...    [ ok ]
 * Stopping services ...          [ ok ]
 * Stopping service logging ...[ ok ]
# qmail-start
status: local 0/10 remote 0/20

# /usr/bin/tcpserver -p -v -R -x /etc/tcp.smtp.cdb -c 40 -u 201 -g 200 0.0.0.0 smtp /var/qmail/bin/qmail-smtpd mail.ushcare.com /var/vpopmail/bin/vchkpw /bin/true
tcpserver: status: 0/40


my tcp rules are identical to yours, which are (I think) identical to the suggested ones in this post.

I don't get it... everything looks as if it's working. There are no errors in the logs that I know of either.

ACCEPT_KEYWORDS -- more like unmasked package to try and see if it helps to have a different version... doesn't though. I'm gonna mask the latest "ucspi-tcp" and see if that helps...

>I will try to reemerge qmail in worse case.

If that doesn't work, try renaming all the dirs inside of /var/qmail besides "queue" and "users" -- as those are essential. Then just setup the "control" configs again

-------------------------

yes, once this works, I'm gonna either never run sync again, or mask all the packages greater than the ones that I have that work in /etc/portage
Back to top
View user's profile Send private message
Gatak
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2004
Posts: 126

PostPosted: Tue Jan 11, 2005 7:28 am    Post subject: Reply with quote

There is nothing listening on port 25/SMTP for you. This is a problem!

I am also using qmail-1.03-r13.

My tcpserver is running like this.
Code:
 /usr/bin/tcpserver -p -v -R -x /etc/tcp.smtp.cdb -c 40 -u 201 -g 200 ::0 smtp /var/qmail/bin/qmail-smtpd mail.tnonline.net /var/vpopmail/bin/vchkpw /bin/true
netstat -anp|grep tcpserver
Code:
tcp        0      0 :::25                   :::*                    LISTEN      8531/tcpserver
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Tue Jan 11, 2005 7:42 am    Post subject: Reply with quote

Gatak wrote:
There is nothing listening on port 25/SMTP for you. This is a problem!

I am also using qmail-1.03-r13.

My tcpserver is running like this.
Code:
 /usr/bin/tcpserver -p -v -R -x /etc/tcp.smtp.cdb -c 40 -u 201 -g 200 ::0 smtp /var/qmail/bin/qmail-smtpd mail.tnonline.net /var/vpopmail/bin/vchkpw /bin/true
netstat -anp|grep tcpserver
Code:
tcp        0      0 :::25                   :::*                    LISTEN      8531/tcpserver


well, in my case everything looks fine ... can you see something wrong? I'm running qmail-1.03-r13 too. Simply my tcpserver it's not working but it's working 8O

Code:

/usr/bin/tcpserver -H -l 0 -p -v -R -x /etc/tcp.smtp.cdb -c 128 -u 201 -g 200 0.0.0.0 smtp /var/qmail/bin/qmail-smtpd mail.group.com /var/vpopmail/bin/vchkpw /bin/true

#netstat -anp|grep tcpserver
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      4137/tcpserver   
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Tue Jan 11, 2005 7:52 am    Post subject: Reply with quote

ARRRRRRRRRRRRRRGGGGGGGGGGGGGGHHHHHHHHHHHHHHHHHHHH!!!!!!!!!!!

Wow, am I pissed...

I'm debugging remotely from a different location and I was telneting remotely to the host, and the reason why I can't send mail is because the stupid ISP I'm on right now blocks port 25...

UGH

well, the good news is, -r15 works fine, even with the new tcprules.d and ucspi-tcp-0.88-r9, sorry for wasting people's time.

EDIT:

actually, it was listening... I just copied and pasted the wrong part... I've been working on this a while, sorry about that.
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Tue Jan 11, 2005 8:03 am    Post subject: Reply with quote

sucarino, do this:

/etc/init.d/svscan stop
qmail-start

and see if there are configuration errors...

also,what is the output of "telnet localhost 25" ??? (you get telnet by netkit-telnetd)

test to see if authentication is working ok... see if you can log into qmailadmin

I also used queue-repair -- I don't know if that had an effect or not...
http://www.qcc.ca/~charlesc/software/queue_repair/

I actually recommend upgrading qmail to -15 -- it seems to install a little cleaner than the previous ... you only have to worry about tcprules.d directory, which matches the the other one -r9

lemme know... I'm pretty adept at troubleshooting this stuff now :)


Last edited by seriousmoose on Tue Jan 11, 2005 8:04 am; edited 1 time in total
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Tue Jan 11, 2005 8:04 am    Post subject: Reply with quote

seriousmoose wrote:
ARRRRRRRRRRRRRRGGGGGGGGGGGGGGHHHHHHHHHHHHHHHHHHHH!!!!!!!!!!!

Wow, am I pissed...

I'm debugging remotely from a different location and I was telneting remotely to the host, and the reason why I can't send mail is because the stupid ISP I'm on right now blocks port 25...

UGH

well, the good news is, -r15 works fine, even with the new tcprules.d and ucspi-tcp-0.88-r9, sorry for wasting people's time.

EDIT:

actually, it was listening... I just copied and pasted the wrong part... I've been working on this a while, sorry about that.


Well i already tried any kind of tricks... reemerging didn't work. If you say r-15 works i will try a last time.... i'm glad to hear your systems works, one less stres out! :D
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Tue Jan 11, 2005 8:23 am    Post subject: Reply with quote

ok, it only shows:

# qmail-start
status: local 0/10 remote 0/20

Quote:
also,what is the output of "telnet localhost 25" ??? (you get telnet by netkit-telnetd)


# telnet localhost 25
Trying 127.0.0.1...
Connected to mail.group.com.
Escape character is '^]'.
220 mail.group.com ESMTP
Quote:

test to see if authentication is working ok... see if you can log into qmailadmin


both are working ok, i can auth in qmailadmin (???) and can send emails from home remotely via SMTP-AUTH

Quote:
I actually recommend upgrading qmail to -15 -- it seems to install a little cleaner than the previous ... you only have to worry about tcprules.d directory, which matches the the other one -r9


Anyway i will try r15....
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Tue Jan 11, 2005 8:27 am    Post subject: Reply with quote

what exactly is going wrong then??? everything looks good from here.
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Tue Jan 11, 2005 9:19 am    Post subject: Reply with quote

seriousmoose wrote:
what exactly is going wrong then??? everything looks good from here.


i tried qmail-1.03-r15 .. didn't work. I'm getting crazy... tcpserver is working fine, everything is working fine ... just I can't relay without auth from my trusted networks, localhost included

my webmail users need relaying from localhost, of course.... i can't send emails from mutt either!

as i stated before, tcprules are working perfect:


#TCPREMOTEIP="127.0.0.1" tcprulescheck /etc/tcprules.d/tcp.qmail-smtp.cdb
rule 127.0.0.1:
set environment variable RELAYCLIENT=
set environment variable RBLSMTPD=
set environment variable QMAILQUEUE=/var/qmail/bin/qmail-queue
allow connection

qmail is just looking at rcphost....everytime i get same error:

Server replied: 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)

this is from qmail-smtpd log file, everytime i try to relay:

@4000000041e396e2048fb78c tcpserver: status: 1/128
@4000000041e396e20496379c tcpserver: pid 17300 from 127.0.0.1
@4000000041e396e204a9a82c tcpserver: ok 17300 localhost:::ffff:127.0.0.1:25 localhost:::ffff:127.0.0.1::32781
@4000000041e396e206ecc614 tcpserver: end 17300 status 256
@4000000041e396e206ecd5b4 tcpserver: status: 0/128

and my #ps aux

qmaild ... /usr/bin/tcpserver -p -v -R -x /etc/tcprules.d/tcp.qmail-smtp.cdb -c 128 -u 201 -g 200 0.0.0.0 smtp /var/qmail/bin/qmail-smtpd mail.group.com /var/vpopmail/bin/vchkpw /bin/true
root ... supervise qmail-smtpd
root ... supervise log
root ... supervise qmail-send
root ... supervise log

Other ideas? Could be something with user "qmaild".???
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Tue Jan 11, 2005 9:27 am    Post subject: Reply with quote

i deleted the rcpthosts file... at least it works for the web people off at my workplace :(

from now on i oficially declare my server as another open relay !

:twisted:
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Tue Jan 11, 2005 9:49 am    Post subject: Reply with quote

ok... I'm not totally sure how to check to see if I'm an open relay, but I did manage to get ssl tunneling with TLS authentication required, so I doubt that it's open (cause I think it need a username and password)

Well, I'm unable to check to see how port 25 responds, but I just installed SSL tunneling so I can send on a different port that my stupid isp doesn't block.

my rcpthosts contains my fqdn -- eg. if your domain is domain.com and the mailserver is mail.domain.com, then my rcpthosts file contains just "domain.com"

I can send to any domain I please.

as for your settings you posted... they are all exactly the same as mine...

EDIT:

if you want info on how to tunnel ssmtp, I'll post the settings

EDIT:

abuse.net has a relay tester... pretty cool
http://www.abuse.net/relay.html

EDIT:

some more info on rcpthosts...
http://www.palomine.net/qmail/relaying.html
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Tue Jan 11, 2005 9:48 pm    Post subject: Reply with quote

Quote:
ok... I'm not totally sure how to check to see if I'm an open relay, but I did manage to get ssl tunneling with TLS authentication required, so I doubt that it's open (cause I think it need a username and password)



from point i deleted the rcpthosts file, automatically qmail starts to act as an open relay ... i have no more ideas, maybe i will try POP before SMTP but i'm not sure if this will work with webmail (squirrelmail)

i already test my server, i'm 100% an open relay now... for some weird reason Qmail is actually circunvent tcpserver.... or should I use something like relay-ctrl?


please any help?
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Wed Jan 12, 2005 1:17 am    Post subject: Reply with quote

I don't really know what to tell you... for me, all I had to do is put my domain in the rcpthosts file, and that's it... the reason why it works is because -r15 seems to require TLS auth before you can send the message. Try it out, but this means that all of your users will have to go into their outlook settings and enable (I can't remember exactly) the setting that sends username and password when sending mail.

That's the best I got for now... I'm kinda unable to test open/closed relays because my port 25 is blocked, so I can only tunnel to it through SSL.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 23, 24, 25  Next
Page 18 of 25

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum