Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: qmail vpopmail courier-imap qmail-scanner etc (NEW)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 23, 24, 25  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Thu Jan 13, 2005 1:52 am    Post subject: tcpserver is working weird Reply with quote

guys, this is completely unusual... my qmail+vpopmail+qmail-scanner+SA, etc is working very well,. just that something is really happening causing that tcpserver is unable to match the right rule. look at this:

when a normal email arrives from outside, /var/log/qmail/qmail-smtpd/current shows:

Code:
@4000000041e5c8ff1ac497ac tcpserver: status: 1/128
@4000000041e5c8ff1ac9e324 tcpserver: pid 3202 from 209.200.129.5
@4000000041e5c8ff1ad52dc4 tcpserver: ok 3202 mail.xxxxxx.com:::ffff:196.x.y.z:25 :::ffff:209.200.129.5::54402
@4000000041e5c90434006e6c X-Qmail-Scanner-1.23st: We have reasons to believe this mail is SPAM
@4000000041e5c90501be115c tcpserver: end 3202 status 0
@4000000041e5c90501be20fc tcpserver: status: 0/128


but when i try to send an email using webmail, or just without auth from my internal network then i can see:

Code:
@4000000041e5cb510f2cd1ac tcpserver: status: 1/128
@4000000041e5cb510f32f014 tcpserver: pid 3458 from 127.0.0.1
@4000000041e5cb510f47200c tcpserver: ok 3458 localhost:::ffff:127.0.0.1:25 localhost:::ffff:127.0.0.1::32841
@4000000041e5cb511145e1f4 tcpserver: end 3458 status 256
@4000000041e5cb511145f194 tcpserver: status: 0/128


Note status 0 vs. status 256

In my /etc/tcp.smtp.cdb i have the rules :

Code:
127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue"
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"


what is happening to me is that tcpserver never match the first rule for localhost, that's the reason why my webmail users can't relay... no matter where the connection came from tcpserver is assigning the last values all the time

if i add RELAYCLIENT="" to the second line then every user, no matter where they are, could send/relay emails without problems . Of course i don't want that because then qmail-scanner-queue.pl do nothing regarding SPAM because that implies the email is coming from a trusted user.

However, testing tcpserver is ok as you can see:
Code:

mail etc #  TCPREMOTEIP="127.0.0.1" tcprulescheck /etc/tcp.smtp.cdb
rule 127.0.0.1:
set environment variable RELAYCLIENT=
set environment variable RBLSMTPD=
set environment variable QMAILQUEUE=/var/qmail/bin/qmail-queue
allow connection


if i write down anything on this test, let's say "schemp" it always match the second rule:

Code:
mail etc # TCPREMOTEIP="schemp" tcprulescheck /etc/tcp.smtp.cdb
rule :
set environment variable QMAILQUEUE=/var/qmail/bin/qmail-scanner-queue.pl
allow connection


So, IMHO tcpserver is receiving wrong values when my users try to connect on port 25 from trusted locations. That's why when they authenticate can send emails without problems, as they were at opposite side of the earth.

But if you guys double check what i wrote above, /var/log/qmail/qmail-smtp/current is saying that tcpserver is receiving the connection from 127.0.0.1 :(

Code:
localhost:::ffff:127.0.0.1:25 localhost:::ffff:127.0.0.1::32841


and as far as i know my tcpserver is running with right parameters:

Code:
mail etc # ps aux | grep tcpserver
qmaild    4078  0.0  0.1  2648  808 pty/s1   S    20:25   0:00 /usr/bin/tcpserver -H -P -v -R -x /etc/tcp.smtp.cdb -c 128 -u 201 -g 200 0.0.0.0 smtp /var/qmail/bin/qmail-smtpd mai.xxxxx.com /var/vpopmail/bin/vchkpw /bin/true


SO, WHAT THE HELL IS HAPPENING? I already remerge every single package, i even compiled the kernel again avoiding any non usual option at network or security categories... nothing i can do fix this fuc*^*& problem....

Please, any help will be appreciated!
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Thu Jan 13, 2005 2:11 am    Post subject: Re: tcpserver is working weird Reply with quote

wait, wait, wait !

i can't understand some differences. if i use tcprulescheck that way it doesn't work as expected.... do not let relay

Code:
mail etc # tcprulescheck tcp.smtp.cdb 127.0.0.1   
rule :
set environment variable QMAILQUEUE=/var/qmail/bin/qmail-scanner-queue.pl
allow connection


that is exactly as same on my server...but how can i fix that?

and why in the following way it show me other results:

Code:
mail etc # TCPREMOTEIP="127.0.0.1" tcprulescheck /etc/tcp.smtp.cdb
rule 127.0.0.1:
set environment variable RELAYCLIENT=
set environment variable RBLSMTPD=
set environment variable QMAILQUEUE=/var/qmail/bin/qmail-queue
allow connection



????????????
:roll:
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Thu Jan 13, 2005 2:49 am    Post subject: Re: tcpserver is working weird Reply with quote

Finally it is working.... the solution was posted here:

https://forums.gentoo.org/viewtopic.php?t=276084&highlight=tcpserver

uscpi-tcp should be emerged with "-ipv6" if you are not using ipv6 at all.

ahhhhhhh... i'm really tired

:x
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Thu Jan 13, 2005 10:33 pm    Post subject: Reply with quote

In this post I'll write notes as I read, so please don't kill me If I write something that has already been said.

Something general on upgrading: emerge world might not be the smartest thing to do when you're not doing it every month. What I do is run a emerge -pvUD world. Then I look for the first package listed that I know I've emerged. Then I run emerge -pvUD packagename > /root/emergelog/worldxxxxxxx (xxxxx is a number I increase by one every time).
Then I run emerge -UD packagename.
When done I update configs using etc-update in interactive mode, and I test if the system works. If everything works I do the same thing over again, until all packages are updated.
I do not use the ~x86 keyword unless I know it's useful in one particular package - and then I do leave all packages I would like to use the ~keyword until the everything else is updated. That's the thing with the -U parameter to emerge - it does not downgrade packages that was emerged with the ~keyword in the first place.

If you had qmail-1.03-r15 and did an emerge world without the ~keyword and without the -U parameter you will have r13 installed now! That WILL make trouble with the tcprules!
If you did do an emerge world with the ~keyword .... oh man! You might as well delete all your systemfiles and start installing the OS and all programs all over!

If the perl package was updated you should / have to recompile everything that is using perl... i.e. qmail-scanner.

If change between qmail-1.03-r13 and qmail-1.03-r15 you have to check out your tcprules. It might not be reading the files you think it is reading. (/etc/tcp* or /etc/tcprules.d/*)

When updating Qmail-scanner from 1.1X to 1.2X QMAILQUEUE in tcp.smtp (or whatever it's correct name is) should be changed from /var/qmail/bin/qmail-queue.pl to /var/qmail/bin/qmail-queue

If you get temporary problem when sending / recieving mail or when logging in on pop/imap there is probably a problem with the vpopmail - mysql communication. Eigther the /etc/vpopmail.conf does not contain the correct information, or it's format is wrong. Old versions of vpopmail reads one parameter per line, the new version reads all parameters at only two lines. If in doubt use both formats in the file at the same time - for details read one of my posts earlier in this thread.
This is important to check when upgrading vpopmail

sucarino wrote:

#/etc/init.d/svscan restart
it only increases the curse, getting this error again and again, forever:
supervise: fatal: unable to acquire qmail-send/supervise/lock: temporary failure

That might be the problem for the relay problem. Does the symlionks in /service point to the correct place? The lockfile might be something that is made when a service is started, then should be removed when service is stoped - if it exists the service should not start - try rename it or as Gatak say check it's permission and the folders permission.

sucarino wrote:

from point i deleted the rcpthosts file, automatically qmail starts to act as an open relay ... i have no more ideas, maybe i will try POP before SMTP but i'm not sure if this will work with webmail (squirrelmail)

My rcpthosts file contains
Code:

domain.net
213.x.x.x <- server public ip adress


sucarino wrote:

Note status 0 vs. status 256

In my /etc/tcp.smtp.cdb i have the rules :

Code:
127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue"
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"


Dude! You have a setuid and/or permission and/or ownership problem on qmail-scanner, AND faulty tcprules. Try this:
# emerge -C qmail-scanner.
# rm /var/qmail/bin/qmail-scanner*
# rm -Rf /var/spool/qmail-scanner
edit your smtp tcprules to read QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"
NOT qmail-queue, NOT qmail-scanner-queue.pl
Run the tcprules update
restart tcpserver
# emerge qmail-scanner
restart tcpserver

Good for you, sucarino, that it started to work. But you should still fix the qmail-queue parameter and qmail-scanner permissions. (If not you might get a problem in the future.)



One more thing regarding systemwide updates: If you're not intending to use ipv6 add "-ipv6" to your USE flags in /etc/make.conf. Somewhere during the update it will get enabled as default, so you have to force it to not be enabled!

ALWAYS, when you emerge something, do a -pv first to see which USE flags it will use - you may need to change something!
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Thu Jan 13, 2005 10:47 pm    Post subject: Reply with quote

One more thing to add - qmail-scanner 1.2X will skip spamcheck for mail sent from localhost, so it's not wasting much resourses to have
127.0.0.1:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"
in tcprules.
(it will do virus check)

Is there any way to make it skip spamcheck when mail is comming in trough smtp-auth?
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Thu Jan 13, 2005 11:27 pm    Post subject: Reply with quote

Quote:
In my /etc/tcp.smtp.cdb i have the rules :

Code:
127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue"
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"


Dude! You have a setuid and/or permission and/or ownership problem on qmail-scanner, AND faulty tcprules. Try this:
# emerge -C qmail-scanner.
# rm /var/qmail/bin/qmail-scanner*
# rm -Rf /var/spool/qmail-scanner
edit your smtp tcprules to read QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"
NOT qmail-queue, NOT qmail-scanner-queue.pl
Run the tcprules update
restart tcpserver
# emerge qmail-scanner
restart tcpserver

Good for you, sucarino, that it started to work. But you should still fix the qmail-queue parameter and qmail-scanner permissions. (If not you might get a problem in the future.)


Thanks, petterg... for all your support. But i still have a question: why do you think i have a permission problems with my qmail-scan* files? Everything is up and running now. Furthermore i run a daily cron with "setuidgid qmaild /var/qmail/bin/qmail-scanner-queue.pl -z" to check these rights keep safe. Currently my files list looks like:

Code:
mail bin # cd /var/qmail/bin/
mail bin # ls -la qmail-scan*
-rwsr-xr-x  1 qscand qscand   3236 Sep 18 20:50 qmail-scanner-queue
-rwxr-xr-x  1 qscand qscand 131591 Jan 13 14:36 qmail-scanner-queue.pl


Is that correct?
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Fri Jan 14, 2005 8:48 am    Post subject: Reply with quote

sucarino, to quote the qmail-scanner ebuild,

* Please note that it was a call to qmail-scanner-queue.pl before,
* but this is now changed to use a wrapper to improve security!
* Once you have changed to the wrapper, you can remove the setuid
* bit on qmail-scanner-queue.pl

so, for future, it would probably be best to use the wrapper
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Fri Jan 14, 2005 9:45 am    Post subject: Reply with quote

sucarino:
Code:

:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"

If this code works as you intend it to work there is something wrong. (Assumed you use qmail-scanner 1.2X)
Back to top
View user's profile Send private message
cybris
n00b
n00b


Joined: 15 Jan 2005
Posts: 14

PostPosted: Sat Jan 15, 2005 2:47 am    Post subject: Reply with quote

Hey all I followed this How-to straight through and i'm testing my server I keep getting this when trying to recieve or send mail to any e-mail at another domain such as yahoo and msn.

This is what i get when trying to send from my server to yahoo

The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was '(my yahoo address here)@yahoo.com'. Subject 'test', Account: '(my outlook account name is here)', Server: '(my domain name is here)', Protocol: SMTP, Server Response: '553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)', Port: 25, Secure(SSL): Yes, Server Error: 553, Error Number: 0x800CCC79

When I try to send from yahoo to my server I get this as a bounced message in yahoo.

(my servers ip) does not like recipient.
Remote host said: 553 sorry, that domain isn't in my list of allowed
rcpthosts (#5.7.1)
Giving up on (my servers ip)
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Sat Jan 15, 2005 3:44 am    Post subject: Reply with quote

When you send from an ip-adress listed to allow relay from, you'll need to provide username and password for smtp auth. (from the client).
First check that you're able to send from localhost to localhost. Then from localhost to yahoo.

Are you able to login using pop or imap?
Back to top
View user's profile Send private message
cybris
n00b
n00b


Joined: 15 Jan 2005
Posts: 14

PostPosted: Sat Jan 15, 2005 4:30 am    Post subject: Reply with quote

ok i can log in pop3 using SSL on localhost or externally

what I can't do is log in via smtp using SSL on either localhost or external so something is wrong in my smtp-auth configuration I assume then.

any ideas on what i should check?
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Sat Jan 15, 2005 4:23 pm    Post subject: Reply with quote

redo the smtp-auth part of the guide to make sure you've got it right.
But there is probably something more wrong too.

What does the files in qmail/control look like?
Back to top
View user's profile Send private message
cybris
n00b
n00b


Joined: 15 Jan 2005
Posts: 14

PostPosted: Sat Jan 15, 2005 7:49 pm    Post subject: Reply with quote

well I checked my conf-smtp file in controls and the only line it that is not commented out is the one mentioned above.

QMAIL_SMTP_POST="(my domain name is here) /var/vpopmail/bin/vchkpw /bin/true"

and the only thing i changed in conf-common was the line to say

TCPSERVER_OPTS="-H -R -l 0"

all the other files mentioned just have my hostname in them which is my fqdn

ok other things i have done i noticed SSL needs to use port 465 so I did a telnet localhost 465
got a connection refused which indicated it's not open.

I also tried

Telnet localhost 25
mail from: who@whomever.com
rcpt to: alocaluser
data
<body of message here>
<carriage return>
.
got this error
qq temporary problem (*4.3.0)

which means that it did not authenticate which I believe is what is supposed to happen when using SSL becuase it should connect and authenticate through port 465 if I understand correctly?

I also did this
netstat -a | grep smtp
and got

tcp 0 0 *:smtp *:* LISTEN
tcp 0 0 localhost:smtp localhost:32900 TIME_WAIT

i'm not sure but I beleive that last line is because of qmail-scanner? cause I issued that command before and never got the second line til I setup and ran qmail-scanner?

I also tried this

netstat -a | grep smtps

and got nothing if SSL is runngin correctly I should have gotten a LISTEN result.

also tried this

openssl s_client -connect localhost:465 -state
and got
connect:Connection refused
connect:erno=29

So what I've gathered from this is i have a problem somewhere with my SSL port not being open correctly for smtp?

btw I followed the old guide here http://www.gentoo.org/doc/en/qmail-howto.xml in section 5 to setup SSL for smtp excetp the part about changing the conf-smtp file instead I did what this how-to said

I'm pretty sure I know what the problem is I know in using the tcpserver command you can set the the port it uses with a flag of smtp or smtps but i'm not sure where i need to set this at?


thanks for the help btw.
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Sat Jan 15, 2005 10:00 pm    Post subject: Reply with quote

What's the output of
Code:
# ls -l /var/vpopmail/bin/vchkpw

?

If your're following the guide I don't think you get SMTP-SSL. What you do get is TLS which is still using port 25. TLS is encryption on transport level, while ssl is no protocol / connection level. (This means that the connection is established before encryption is turned on.)

Where did you get the idea of using port 465?

Quote:

rcpt to: alocaluser

You did remember to enter @domain.tld after the username?

My conf-smtp looks like this
Code:

TCPSERVER_OPTS="${TCPSERVER_OPTS} -R"
QMAIL_SMTP_AUTHHOST=$(<${QMAIL_CONTROLDIR}/me)
[ -z "${QMAIL_SMTP_POST}" ] && QMAIL_SMTP_POST=/bin/true
#QMAIL_SMTP_CHECKPASSWORD="/bin/cmd5checkpw"
QMAIL_SMTP_CHECKPASSWORD="/var/vpopmail/bin/vchkpw"
QMAIL_SMTP_POST="${QMAIL_SMTP_AUTHHOST} ${QMAIL_SMTP_CHECKPASSWORD} ${QMAIL_SMTP_POST}"


This requires the file ${QMAIL_CONTROLDIR}/me to contain your domainname.
Your domainname must also be included in ${QMAIL_CONTROLDIR}/locals and ${QMAIL_CONTROLDIR}/defaultdomain.

${QMAIL_CONTROLDIR}/rcpthosts should look like this:
Code:

yourdomain.tld:yourdomain.tld
yourdomain.tld
youripadress


${QMAIL_CONTROLDIR}/virtualdomains should look like this:
Code:

yourdomain.tld:yourdomain.tld
youripadress:youripadress


If those files doesn't look like that you may have done a mistake when installing vpopmail. (Maybe the ipadresses are not required. I'm using ip as alias for domain.)

You do know you need to use user@domain.tld when authenticating?
Back to top
View user's profile Send private message
sucarino
n00b
n00b


Joined: 20 Aug 2004
Posts: 32
Location: San Jose, Costa Rica

PostPosted: Sun Jan 16, 2005 6:31 am    Post subject: Reply with quote

seriousmoose wrote:
sucarino, to quote the qmail-scanner ebuild,

* Please note that it was a call to qmail-scanner-queue.pl before,
* but this is now changed to use a wrapper to improve security!
* Once you have changed to the wrapper, you can remove the setuid
* bit on qmail-scanner-queue.pl

so, for future, it would probably be best to use the wrapper


Sorry... i'm just a noob on this, really don't know how to use the tcp wrappers... can you help me or give me some tips/links?

my last question.. i noted that Spam Assassin is not identifying dirty strings in "only text" message bodies. It's just doing RBL checkouts, Razor , etc. However on HTML messages it make a very deep inspection with a higher rate of efectivity. Is that normal?
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Sun Jan 16, 2005 7:59 am    Post subject: Reply with quote

sucarino, it just means that you should use "qmail-scanner-queue" instead of "qmail-scanner-queue.pl" from now on :D np

-------------------------

SSL was very easy for me to setup... here is how I did it:

# emerge stunnel
# nano -w /etc/stunnel/stunnel.conf

Code:
# location of pid file
pid = /etc/stunnel/stunnel.pid

# user to run as
setuid = stunnel
setgid = stunnel

CAfile = /usr/etc/stunnel/certs.pem

cert = /var/qmail/control/servercert.pem
[ssmtp]
accept  = 465
connect = 25


make sure your certs are generated properly... they should be, if you filled out the information wile doing the ebuild config for qmail
# rc-update add stunnel default
# /etc/init.d/stunnel start

peace
Back to top
View user's profile Send private message
shadowteller
n00b
n00b


Joined: 01 Oct 2004
Posts: 27
Location: Logan, UT

PostPosted: Mon Jan 17, 2005 12:09 am    Post subject: Still Hammering away.... Reply with quote

In mid-November I posted because I was having trouble installing this tutorial by Sabrex.

Unfortunately on a RAID 10 when you blow a PS and over half of your HDs, it reaks severe havoc.

So, I ended up replacing parts (got a redudant PS and a Better UPS).

Onward to the problems...I got Qmail and Vpopmail working no problems. I can send mail back and forth between local users. I however can not send to yahoo, hotmail or as far as I can tell anyone out side of my network. How do I fix this? I also presume since it fails on outgoing - it will fail incoming as well.

Secondly I installed courier-imap. Here's where my problems begin. (I noticed things have changed here since November) At first I thought everything was working okies.

I got squirrelmail installed...no problems there. When I try logging into squirrelmail it gives me the "ERROR : Connection dropped by imap-server"

So I went back and checked using Outlook to see if I can connect...same thing.

So I tried to telnet on ports 143 and 993

Quote:
Trying 127.0.0.1...
Connected to leto.freelancephotography.org.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE AUTH=CRAM-MD5 ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc. See COPYING for distribution information.
a login user passwd (also tried user@domain.name)
a NO Login failed.


So I have no clue how to fix this...also the new authmysqlrc kind of confuses me to what I am supposed to place in where.

This is what I have so far...

Quote:

MYSQL_SERVER localhost
MYSQL_USERNAME vpopmail
MYSQL_PASSWORD passwd
MYSQL_PORT 0
MYSQL_OPT 0
MYSQL_DATABASE vpopmail
MYSQL_USER_TABLE pw_name
MYSQL_CLEAR_PWFIELD clear
DEFAULT_DOMAIN freelancephotography.org
MYSQL_UID_FIELD pw_uid
MYSQL_GID_FIELD pw_gid
MYSQL_LOGIN_FIELD email
MYSQL_HOME_FIELD homedir
MYSQL_NAME_FIELD name
MYSQL_MAILDIR_FIELD maildir


I think thats it....

Also I am a little confused as to whether or not once things are up and running...if users that have a /home/username directory will have mail there or if you have to create a symlink from /var/vpopmail/domains/domain.name/user/

Hope someone can help me and help me soon...cause this has been frustrating me.
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Mon Jan 17, 2005 1:49 pm    Post subject: Re: Still Hammering away.... Reply with quote

shadowteller wrote:
So I have no clue how to fix this...also the new authmysqlrc kind of confuses me to what I am supposed to place in where.

This is what I have so far...

Quote:

MYSQL_SERVER localhost
MYSQL_USERNAME vpopmail
MYSQL_PASSWORD passwd
MYSQL_PORT 0
MYSQL_OPT 0
MYSQL_DATABASE vpopmail
MYSQL_USER_TABLE pw_name
MYSQL_CLEAR_PWFIELD clear
DEFAULT_DOMAIN freelancephotography.org
MYSQL_UID_FIELD pw_uid
MYSQL_GID_FIELD pw_gid
MYSQL_LOGIN_FIELD email
MYSQL_HOME_FIELD homedir
MYSQL_NAME_FIELD name
MYSQL_MAILDIR_FIELD maildir



If you're thinking about vpopmail.conf it's a totaly diffrent setup now

Code:

# Line 1 defines the connection to use for database reads,
# Line 2 defines the connection to use for database updates/writes.
# settings for each line:
# host|port|user|password|database

# Read-only DB
localhost|0|vpopmail|password|vpopmail
# Write DB
localhost|0|vpopmail|password|vpopmail
Back to top
View user's profile Send private message
shadowteller
n00b
n00b


Joined: 01 Oct 2004
Posts: 27
Location: Logan, UT

PostPosted: Tue Jan 18, 2005 4:49 am    Post subject: RE: Still hammering away Reply with quote

Petterg:

Nope not thinking of vpopmail...
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Tue Jan 18, 2005 5:19 am    Post subject: Reply with quote

you shouldn't be using authmysqlrc... vchkpw instead... When you use vchkpw, then you will need to set vpopmail.conf just petterg said
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Tue Jan 18, 2005 6:03 am    Post subject: Reply with quote

had working server until updating world. rebuilt new system on new pc and followed this howto. everything working, EXCEPT I can NOT send mail from outside my LAN.
I'm extremely tired and would greatly appreciate it if someone could suggest where I should start looking when I get up tomorrow (been at this since sunday 9am.)

i can not even telnet port 25 remotely with firewall completely relaxed, yet it works fine internally. I've enabled pop-before-smtp instead of smtp-auth(which I have NEVER had working).

Where should I look for something that is only blocking access from the internet?

Thanks,
-Sky
Back to top
View user's profile Send private message
cybris
n00b
n00b


Joined: 15 Jan 2005
Posts: 14

PostPosted: Tue Jan 18, 2005 6:16 am    Post subject: Reply with quote

my config files look exactly like yours petterg.

I did ls -l /var/vpopmail/bin/vchkpw and got
-rws--x--x 1 vpopmail vpopmail 74796 Jan 14 07:26 /var/vpopmail/bin/vchkpw

465 is the port used to authorize SSL over SMTP.
I also installed stunnel as seriousmoose suggested this did open the port to listen but it still is not working. I still get errors saying it can't authorize the password when I try to send mail through Kmail on localhost
and yes I am running Kmail on the same box as the server hehe.

one i did do is I re-did using alocaluser@mydomain.tld
Telnet localhost 25
mail from: who@mydomain.tld
rcpt to: alocaluser@mydomain.tld
data
<body of message here>
<carriage return>
.

250 ok 1105028372 qp 31048

i then checked mutt and it showed up, i also tested using qmail-inject and that showed up in my inbox in mutt as well.

So now i'm thinking it's something wrong with how kmail is configured? cause when I check the inbox in kmail using the same user name and password it says it checks and no new messages are found and I get no errors. but when I try to send one through Kmail I get errors saying it can't authorize and yes I made sure for the username to put user@mydomain.tld

still need help arrgggh pulling out my hair LOL
Back to top
View user's profile Send private message
seriousmoose
n00b
n00b


Joined: 07 Nov 2002
Posts: 39

PostPosted: Tue Jan 18, 2005 7:25 am    Post subject: Reply with quote

cybris,
yes, kmail is probably misconfigured.

The best way I can tell you to configure kmail (without taking screenshots of my own) would be to refer you to the gmail settings (if you have gmail), as they are identical (or at least should be) to yours:

Incoming POP3/IMAP server settings:
mail.yourdomain.com
UseSSL: Yes (put it on there, it's better for everyone :))
Port:995

Outgoing SMTP server settings:
mail.yourdomain.com
use authentication: Yes
Use TLS (Or SSL for some): Yes
Port: 465
account name: username@yourdomain.com (REMEMBER that it's the full email address for the username)

Those settings should work. good luck.

Skywacker,
Ok, open the rcpthosts file, and type in domain.com (where domain.com is the domain that you are running). Of course, if you have multiple domains, place each of those on its own line. Next, add your ip, just for good measure.

Go to your email account settings, and be sure that you have the same settings as the above. TLS should get rid of the rcpthosts error. The only difference is, for you, you probably don't have SSL enabled, so TLS will probably have to go on port 25. also, make sure you don't have the use variable set... I think notlsbeforeauth or something like that.

Shoot, my memory is getting foggy. I hope the info I gave is correct.

-------------------------

There seems to be a surge in questions. I think I'm going to rewrite the howto, using all the new qmail settings... gimme a few days though
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Tue Jan 18, 2005 10:03 am    Post subject: Reply with quote

cybris: You should not configure kmail to use smtp-auth when running on localhost!

Edit: (I mean when klient and server is on the same pc)
Back to top
View user's profile Send private message
cybris
n00b
n00b


Joined: 15 Jan 2005
Posts: 14

PostPosted: Wed Jan 19, 2005 4:25 am    Post subject: Reply with quote

I'm just using kmail to test the settings on the localhost at the moment eventually i will be using the mail sever externally. Still having problems tho and Kmail is setup up properly with the settings metioned above. i'm still getting authorization failed (#5.7.0). I'm stuck I don't know what else to try unless i just redo the whole box but I really don't want to do that cause KDE took 3 days to compile :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 23, 24, 25  Next
Page 19 of 25

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum