Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: qmail vpopmail courier-imap qmail-scanner etc (NEW)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4 ... 23, 24, 25  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Sun May 23, 2004 6:53 am    Post subject: Now I have no clue what I'm doing Reply with quote

It's set up (I think?) but I can't seem to do anything with it.

I have another machine running Win XP, with Eudora 6. I was kinda hoping my mail server would be mail.mydomain.org, which I could then send/receive mail from.

I added my domain via vadddomain, and added a user (myself) using vadduser. So now my question is, what do I need to set up in Eudora so it'll check it? I like the idea of vpopmail because I can use it as a POP server instead of IMAP (in case I decide to dish out email addresses to other people, which also in my intention).

So, I create a new profile, add my username, tell Eudora it's a POP server, at address mail.mydomain.org, and all that fun stuff. Then it tries to connect. Connection refused. Weird, so I change the server to my local network address (192.168.1.2) and then it says that it's rejecting the SSL something because it's less than 0 (-1). (Also note that my username is crymson@mydomain.org, so it was trying to connect as crymson@mydomain.org@mail.mydomain.org originally, then crymson@mydomain.org@192.168.1.2).

I'm pretty much stupid in this area, am I doing something wrong? If I can't get it working for myself, I'll never get it working for other people. It is important that they be able to connect from outside.

To quash any questions before they come, my DNS stuff is set up to where all sub-domains point to my gentoo machine (www, ns, ftp, mail, etc). I figured that the port number would tell it which service it needs to run, and with web/ftp, it has been working. mail seems to be another beast.

Is there another HOWTO or anything I can look at that might help me? Sorry to blather on, but I'm so close to being finished!!!
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Sun May 23, 2004 11:42 am    Post subject: Reply with quote

Crymson:
I'm not familiar with Eudora, but it seems like you've configured it that crymson@mydomain.org is your username and mail.mydomain.org is the incoming/outgoing server name. It looks like you should verify in Eudora your username is just crymson and the incoming/outgoing server is mydomain.org.
_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
pmgas
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2003
Posts: 97
Location: Austria

PostPosted: Sun May 23, 2004 5:05 pm    Post subject: problems with vadddomain Reply with quote

Hi

I wanted to create a domain with vadddomain and got following message:vmysql: sql error[c]: MySQL server has gone away
vmysql: sql error[b]: MySQL server has gone away
vmysql: sql error[3]: MySQL server has gone away
could not create limits table CREATE TABLE limits ( domain CHAR(64) PRIMARY KEY, maxpopaccounts INT(10) NOT NULL DEFAULT -1, maxaliases INT(10) NOT NULL DEFAULT -1, maxforwards INT(10) NOT NULL DEFAULT -1, maxautoresponders INT(10) NOT NULL DEFAULT -1, maxmailinglists INT(10) NOT NULL DEFAULT -1, diskquota INT(12) NOT NULL DEFAULT 0, maxmsgcount INT(12) NOT NULL DEFAULT 0, defaultquota INT(12) NOT NULL DEFAULT 0, defaultmaxmsgcount INT(12) NOT NULL DEFAULT 0, disable_pop TINYINT(1) NOT NULL DEFAULT 0, disable_imap TINYINT(1) NOT NULL DEFAULT 0, disable_dialup TINYINT(1) NOT NULL DEFAULT 0, disable_passwordchanging TINYINT(1) NOT NULL DEFAULT 0, disable_webmail TINYINT(1) NOT NULL DEFAULT 0, disable_relay TINYINT(1) NOT NULL DEFAULT 0, disable_smtp TINYINT(1) NOT NULL DEFAULT 0, perm_account TINYINT(2) NOT NULL DEFAULT 0, perm_alias TINYINT(2) NOT NULL DEFAULT 0, perm_forward TINYINT(2) NOT NULL DEFAULT 0, perm_autoresponder TINYINT(2) NOT NULL DEFAULT 0, perm_maillist TINYINT(4) NOT NULL DEFAULT 0, perm_quota TINYINT(2) NOT NULL DEFAULT 0, perm_defaultquota TINYINT(2) NOT NULL DEFAULT 0 )
vmysql: sql error[p]: MySQL server has gone away
Error: (vadduser) can't read domain limits

I am sure, that the mysql user is valid with the correct password. In console, i can log in with that account ...

Has anyone a solution?

thanxs, peda
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Sun May 23, 2004 8:41 pm    Post subject: Reply with quote

ryker wrote:
Crymson:
I'm not familiar with Eudora, but it seems like you've configured it that crymson@mydomain.org is your username and mail.mydomain.org is the incoming/outgoing server name. It looks like you should verify in Eudora your username is just crymson and the incoming/outgoing server is mydomain.org.


To be honest, I was just guessing at what it should be in Eudora. A better question would be, how does the server expect the addresses/servers to be formatted? If the server expects a username of 'crymson' and a mail server of 'mail.mydomain.org' (which is apparently doesn't since, it rejects all connections), then I could set up Eudora properly.
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Sun May 23, 2004 8:48 pm    Post subject: Re: problems with vadddomain Reply with quote

pmgas wrote:
Hi

I wanted to create a domain with vadddomain and got following message:vmysql: sql error[c]: MySQL server has gone away
vmysql: sql error[b]: MySQL server has gone away
vmysql: sql error[3]: MySQL server has gone away
could not create limits table CREATE TABLE limits ( domain CHAR(64) PRIMARY KEY, maxpopaccounts INT(10) NOT NULL DEFAULT -1, maxaliases INT(10) NOT NULL DEFAULT -1, maxforwards INT(10) NOT NULL DEFAULT -1, maxautoresponders INT(10) NOT NULL DEFAULT -1, maxmailinglists INT(10) NOT NULL DEFAULT -1, diskquota INT(12) NOT NULL DEFAULT 0, maxmsgcount INT(12) NOT NULL DEFAULT 0, defaultquota INT(12) NOT NULL DEFAULT 0, defaultmaxmsgcount INT(12) NOT NULL DEFAULT 0, disable_pop TINYINT(1) NOT NULL DEFAULT 0, disable_imap TINYINT(1) NOT NULL DEFAULT 0, disable_dialup TINYINT(1) NOT NULL DEFAULT 0, disable_passwordchanging TINYINT(1) NOT NULL DEFAULT 0, disable_webmail TINYINT(1) NOT NULL DEFAULT 0, disable_relay TINYINT(1) NOT NULL DEFAULT 0, disable_smtp TINYINT(1) NOT NULL DEFAULT 0, perm_account TINYINT(2) NOT NULL DEFAULT 0, perm_alias TINYINT(2) NOT NULL DEFAULT 0, perm_forward TINYINT(2) NOT NULL DEFAULT 0, perm_autoresponder TINYINT(2) NOT NULL DEFAULT 0, perm_maillist TINYINT(4) NOT NULL DEFAULT 0, perm_quota TINYINT(2) NOT NULL DEFAULT 0, perm_defaultquota TINYINT(2) NOT NULL DEFAULT 0 )
vmysql: sql error[p]: MySQL server has gone away
Error: (vadduser) can't read domain limits

I am sure, that the mysql user is valid with the correct password. In console, i can log in with that account ...

Has anyone a solution?

thanxs, peda


I was having this exact error up until yesterday. To quote my own message, with my solution, attempt the following:

1) Make CERTAIN mysql is in your USE flags.

2) Edit your /etc/vpopmail.conf file to contain the following:
Code:

# Read-only DB
localhost|0|vpopmail|secret|vpopmail
# Write DB
localhost|0|vpopmail|secret|vpopmail

where "secret" is your vpopmail password

3) type the following: mysql -u root -p
Supply the root password.
Once you are in mysql, type the following:
Code:

mysql> drop database vpopmail;
Query OK, 0 rows affected (0.00 sec)

mysql> create database vpopmail;
Query OK, 1 row affected (0.00 sec)

mysql> use mysql;
Database changed

mysql> GRANT select, insert, update, delete, create, drop on vpopmail.* to vpopmail@localhost identified by 'password';
Query OK, 0 rows affected (0.00 sec)

mysql> flush privileges;
Query OK, 0 rows affected (0.00 sec)

mysql> quit
Bye


NOTE THAT THE ABOVE IS EXACTLY WHAT YOU SHOULD SEE ONSCREEN!!

Replace the word "password" (in single quotes) with the password you used in the /etc/vpopmail.conf file. I believe it helps if it is entirely lowercase. The single quotes MUST be in the mysql command, but are NOT in the /etc/vpopmail.conf file.

Once I did this, mine began to work.

Good luck.
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
pmgas
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2003
Posts: 97
Location: Austria

PostPosted: Sun May 23, 2004 9:14 pm    Post subject: thanxs .... Reply with quote

Ok, problem solved .... I changed the syntax in vpopmail.conf to
# Read-only DB
localhost|0|vpopmail|secret|vpopmail
# Write DB
localhost|0|vpopmail|secret|vpopmail
and it worked! ;-) strange ...

Ok, another question, I am still a n00b......
I used this tutorial, installed everything and how can i create
a user account for squirrelmail?????? where do i write my
domain into, in which file, .....??

sorry guys for asking that stupid questions! ;-)

thanxs
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Sun May 23, 2004 9:19 pm    Post subject: Reply with quote

This one I don't know- I'm not using Squirrelmail myself.

If I had to venture a guess, I would say "vadddomain mydomain.com" which I'm assuming you did. Then, "vadduser user@mydomain.com". That will set up the .maildir.

How you get that to work with squirrelmail...? I don't know.
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Sun May 23, 2004 11:53 pm    Post subject: Still having login problems with POP server Reply with quote

Ok, so I do the following:

Code:

vadddomain mydomain.org password
vadduser crymson@mydomain.org password


Then, making sure that both port 25 and 110 are forwarded to my server, I go to Win XP, and set up the following:

smtp server: mail.mydomain.org
pop server: mail.mydomain.org
username: crymson
password: password

I then try to check the mail. If it's using SSL, it gives me an error about the checksum being -1 so it bails. So I turn off SSL.

It finds the pop server, tries to log in, asks for my password, so I supply it. Then it gives me this error:

Code:

mydomain.org, Logging into POP Server, PASS [04:50:38 PM]
There has been an error transferring your mail.  I said:  PASS <shhhh! Don't tell anyone.>  and then the POP server (crymson@mail.mydomain.org) said:  ERR Login failed.


Where are the log files for this? Maybe I can figure out what's wrong by looking at them. There's some stuff in /var/log/qmail/qmail-pop3d/ but the current gives a bunch of hashes (at lesat, that's what they look like) followed by tcpserver: fatal: unable to bind: address already used.

Any ideas??
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Mon May 24, 2004 2:13 am    Post subject: Could my problems be caused by port conflicts? Reply with quote

I was thinking about the port already in use error... I can't restart the courier-pop3d service. If I do, BIND tells me that the port is already in use. In order to get it to start at all, I had to move pop3d in to the boot run level, instead of default.

The weird thing is, when I took a look at what ports were being used by what process, things kept filling the 110 hole. I'd turn off pop3d, something would take its place on 110. Shut that down, something else would take its place, and so on. I suppose that pop3d isn't actually working as it should, which could explain why I can't login.

Has anyone else had this problem and been able to rectify it?
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Mon May 24, 2004 3:26 am    Post subject: Reply with quote

:roll:
I had the same exact problem as pmgas. Tried struggling through it for several days with some help from darkweaseljedi. I wish I had seen Crymson's post earlier. I just finished completely removing my setup and am starting from scratch. I'll bet if I had changed those lines in vpopmail.conf, it would have worked for me too. I wonder why the default conf is so different? I'll try again and post my outcome.
_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
gcasillo
l33t
l33t


Joined: 23 Sep 2003
Posts: 739
Location: Cincinnati, Ohio, USA

PostPosted: Mon May 24, 2004 5:25 am    Post subject: Reply with quote

Got it! Just one obstacle that I had to figure out. I use kmail. I had everything set up, but I couldn't seem to log in to check my mail. It kept telling me that my password was wrong, but it wasn't.

Finally, I figured out that I needed to use my e-mail address as my login, not my username. Everything is good-to-go now that I'm doing that. Just in case others run into the same snag.
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Mon May 24, 2004 1:18 pm    Post subject: Reply with quote

OK. I got farther than before so far. Before I couldn't add a domain without database errors, even though I was following the commented format of the vpopmail.conf file. I changed my used flags from 'x86' to '~x86' and started from the beginning. When I went to edit the vpopmail.conf file, the comments in the file showed the new format
Code:
# Read-only DB
localhost|0|vpopmail|secret|vpopmail
# Write DB
localhost|0|vpopmail|secret|vpopmail

I guess the older stable version 'x86' in portage wasn't quite as good as the '~x86' in portage. :?
I haven't finished installing everything yet, but I'm confident now that it will work.
For anyone using 'x86' in their use flags, this will be a problem.
_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Mon May 24, 2004 2:36 pm    Post subject: Reply with quote

I'm really pissed now, I can't log in to send OR receive mail, under any circumstances. I installed qmailadmin, just for, and it works great. I can log in to postmaster, view all the accounts, add, delete, etc.

I sent a test message to crymson@mydomain.org, and browsed to the new folder, and it's there, waiting for me. I even sent a message to a bogus address, and it bounced back like it should.

Has anyone else had any kind of auth problems for both sending and receiving? Where does vpopmail keep logs?? If I could figure out what the hell is going on, this would be much more worthwhile.

Ask for any file, and directory listing, anything, I am completely out of ideas, and this is VERY frustrating. Maybe I'm not even approaching this correctly, but I really need some direction here. PLEASE!!! :)
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Tue May 25, 2004 4:36 am    Post subject: Reply with quote

Crymson:
I've been struggling with this for a while and I think I have it working, but not like the how to suggests. I had to make 3 changes to be able to log in at all.
1. In /etc/courier-imap/imapd leave AUTHMODULES="authdaemon"
2. In /etc/courier-imap/pop3d leave AUTHMODULES="authdaemon"
3. In /etc/courier-imap/authdaemonrc set authmodulelist="authpam"

I wasn't able to log in with authvchkpw. I've set the group and permissions per the how to instructions, but it wouldn't work. Now it works fine.
I'm new to setting up an email server so I'm not sure what the difference is between authpam and authvchkpwd. Could someone enlighten me on this?
At least I can log in now!
_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Tue May 25, 2004 4:51 am    Post subject: Reply with quote

ryker wrote:
Crymson:
I've been struggling with this for a while and I think I have it working, but not like the how to suggests. I had to make 3 changes to be able to log in at all.
1. In /etc/courier-imap/imapd leave AUTHMODULES="authdaemon"
2. In /etc/courier-imap/pop3d leave AUTHMODULES="authdaemon"
3. In /etc/courier-imap/authdaemonrc set authmodulelist="authpam"

I wasn't able to log in with authvchkpw. I've set the group and permissions per the how to instructions, but it wouldn't work. Now it works fine.
I'm new to setting up an email server so I'm not sure what the difference is between authpam and authvchkpwd. Could someone enlighten me on this?
At least I can log in now!


Well, I changed the stuff you mentioned, but I still can't log in.

What syntax are you using? Can you log in via telnet, and post a copy of the output here? I'd really like to know what the hell I'm doing wrong (still)
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
larry
n00b
n00b


Joined: 07 Jan 2004
Posts: 9

PostPosted: Tue May 25, 2004 5:02 am    Post subject: Reply with quote

Crymson wrote:
larry wrote:
Hi guys,
I am installing qmail, mysql, vpopmail, courier-imap... I was following the guide on ths website:
http://www.gentoo.org/doc/en/qmail-howto.xml

When I change the password in /etc/vpopmail.conf, and add the database vpopmail as per the instructions, I get this error with vpopmail cmmands like vadddomain my.domain.com:

Quote:
could not connect to mysql update server Access denied for user: 'vpopmail@localhost' (Using password: YES)


but when I switch back to the default password "secret" and remake the vpopmail database, everything works fine. Can somebody give me a clue on how to fix this? Thanks.


My guess is, you didn't set a password for the vpopmail user in MySQL when you created the vpopmail database. In the tutorial, it talks about setting the privileges for the user using 'Your Password' or whatever. Whatever you type in there, must match what is in the /etc/vpopmail.conf file. I believe it is case sensitive. Try that, and you should be ok.



Thanks, you were right, I had only changed one of the two instances of the password in the file :oops:

But now, I have a new problem. When I try adding a user with vadduser, I get this error:

Quote:
vmysql: sql error[3]: Table 'vpopmail.vpopmail' doesn't exist
Error: User's directory already exists?


I tried following all the steps. I re-emerged the latest vpopmail and recreated the vpopmail database. I can login into the vpopmail database with the vpopmail password. This is what I get:

Quote:
mysql> show tables;

+--------------------+
| Tables_in_vpopmail |
+--------------------+
| dir_control |
| limits |
| vlog |
+--------------------+
3 rows in set (0.00 sec)

mysql>


Thanks for the help.
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Tue May 25, 2004 6:15 am    Post subject: Reply with quote

Crymson wrote:
What syntax are you using? Can you log in via telnet, and post a copy of the output here? ...

one thing I forgot to mention is I'm using ssl so I actually edited imapd-ssl and pop3d-ssl as well. What output do you want? Do you want me to post the complete contents of the files I changed?
Let me know what you need and I will post it for you.
_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Tue May 25, 2004 7:04 am    Post subject: Reply with quote

ryker wrote:
Crymson wrote:
What syntax are you using? Can you log in via telnet, and post a copy of the output here? ...

one thing I forgot to mention is I'm using ssl so I actually edited imapd-ssl and pop3d-ssl as well. What output do you want? Do you want me to post the complete contents of the files I changed?
Let me know what you need and I will post it for you.


I'd like to be using SSL, but I can't get the SSL to work, so until it does work without, I'm not even going to screw with it. The output I'd like to see is this:

Code:

telnet mail.yourdomain.com 110
+OK Hello There
USER <user>
+OK Password required
PASS <pass>
???


When I try to login, all I get is
Code:

-ERR Login failed


So- my user is crymson. So here's what I would type, and this is what's failing on me:

Code:

telnet mail.mydomain.org 110
+OK Hello there
USER crymson
+OK Password required
PASS password
-ERR Login failed


Am I not using the correct user name syntax? Does yours have a log? My /var/log/messages says that pop3d is getting a connection, and that I failed my authorization, but beyond that, I can't figure anything else out. Maybe I'm using the wrong syntax. Just spell it out for me. Please :)
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Tue May 25, 2004 9:10 am    Post subject: I forgot to ask... Reply with quote

How did you create your .pem files for the POP3/IMAP server? I just noticed that I don't have any under the /etc/courier-imap directory. I bet that would be why I can't log in via SSL/TLS in Eudora :)

Of course, being able to auth would be good too. Can you post your imapd-ssl and your pop3-ssl files?
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
ryker
Guru
Guru


Joined: 28 May 2003
Posts: 412
Location: Portage, IN

PostPosted: Tue May 25, 2004 1:26 pm    Post subject: Reply with quote

I have never tried to telnet into my pop3 account. But I gave it a try. I don't think it worked right though because I am using pop3 w/ssl so the port should be 995. Here's my output using 110 and then 995:
Code:
alberts4 root # telnet something.dyndns.org 110
Trying 4.15.110.4...
Connected to something.dyndns.org.
Escape character is '^]'.
+OK <5169.1085485785@something.dyndns.org>
USER alberts
+OK
PASS <mypassword>
+OK
ls
-ERR unimplemented
help
-ERR unimplemented
HELP
-ERR unimplemented
USER
-ERR unimplemented
dir
-ERR unimplemented
quit
+OK
Connection closed by foreign host.
-----------------
alberts4 root # telnet something.dyndns.org 995
Trying 4.15.110.4...
Connected to something.dyndns.org.
Escape character is '^]'.
USER alberts
Connection closed by foreign host.

As you can see, I didn't know what to do after I got in on port 110. :(
Here's the relevant lines from my /var/log/messages when I connected using pop3 and imap. I usually use imap and it works fine as well
Code:
May 25 06:56:25 albertsrouter pop3d-ssl: Connection, ip=[4.15.109.169]
May 25 06:56:25 something pop3d-ssl: LOGIN, user=alberts, ip=[4.15.109.169]
May 25 06:56:26 something pop3d-ssl: LOGOUT, user=alberts, ip=[4.15.109.169], top=0, retr=115268
May 25 06:45:45 something imapd-ssl: Connection, ip=[4.15.109.169]
May 25 06:45:45 something imapd-ssl: LOGIN, user=alberts, ip=[4.15.109.169], protocol=IMAP

I only attempted to get things working using ssl not without. All I did was follow this threads howto and the official how to as another reference.

As for ssl I followed the instructions from the official howto. Specifically the following section
Code:
Code Listing 4.2: Out-of-the-box setup for POP3/SSL

# cd /etc/courier-imap
# nano authdaemonrc
(Set the authmodulelist variable to only contain "authvchkpw")
# nano pop3d.cnf
(Edit the [ req_dn ] section)
# mkpop3dcert
# rc-update add courier-pop3d-ssl default
# /etc/init.d/courier-pop3d-ssl start

Code Listing 4.3: Out-of-the-box setup for IMAP/SSL

# cd /etc/courier-imap
# nano imapd.cnf
(Edit the [ req_dn ] section)
# mkimapdcert
# rc-update add courier-imapd-ssl default
# /etc/init.d/courier-imapd-ssl start

Your mail client should now be able to login to the host running courier and retrieve mail for the virtual host. In my case, I am now able to login with the username 'vapier@wh0rd.org' and password 'vappw'.

5. qmail (talking to the world)

Let's get SMTP up and running while making sure we don't create another spam hole for people to abuse.

Code Listing 5.1: Start qmail SMTP service

# cd /var/qmail/control/
# nano conf-smtpd
(Uncomment the SMTP-AUTH variables and set QMAIL_SMTP_CHECKPASSWORD to /var/vpopmail/bin/vchkpw)
# nano servercert.cnf
(Edit the [ req_dn ] section)
# mkservercert
# cd /service
# ln -s /var/qmail/supervise/qmail-smtpd qmail-smtpd
# /etc/init.d/svscan restart

In addition, I also did the following
Code:
> nano -w /etc/courier-imap/imapd-ssl
  IMAPDSSLSTART=YES
> nano -w /etc/courier-imap/pop3d-ssl
  POP3DSSLSTART=YES
> rc-update add courier-imapd-ssl default
> rc-update add courier-pop3d-ssl default
> /etc/init.d/courier-imapd-ssl start
> /etc/init.d/courier-pop3d-ssl start

I also did the the same for the /etc/courier-imap/imapd and /etc/courier-imap/pop3d file. The only thing is I didn't put
Code:
AUTHMODULES="authvchkpw"
like this threads howto suggested. It wouldn't work for me. So I used
Code:
AUTHMODULES="authdaemon"
which the comments in the files say to leave anyway. I also changed in the file /etc/courier-imap/authdaemonrc the line for authmodulelist to
Code:
authmodulelist="authpam"
It was the only thing that would work. Also after you change everything, don't forget to do
Code:

/etc/init.d/svscan restart
/etc/init.d/authdaemond restart

Hope this helps.
_________________
Athlon 64 3200+, 80G WD sata hd + 200G IDE, 1G Geil DDR400, MSI K8T Neo
IntelCore2Duo 2.0Ghz MSI laptop,100G SATA hd, 2G RAM
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Tue May 25, 2004 3:58 pm    Post subject: SMTP-auth problem Reply with quote

I have the same problem with smtp-auth as I've had using the official howto and the old howto written by sabrex.
I've followed every single step in this howto.

Here's the thing, using mozilla mailclient:
If I set up the client to use a username, it will ask for password. If I provide a wrong user/password combination, it will not send mail. If I provide a correct user/password it will send mail. So far so good.

However, if I setup the client to NOT provide any username I'm also able to send mail!

To investigate this furter I installed mozilla on a pc that that has never been running any mailclient before - gave it an ip adress that haven't been used in my localnet before, and sat it up with an non existing mail account. And there was the same thing: it is able to send mail without providing any username/password.
This is the case nomatter which address is the sender or which is the reciever. Like I can have the sender address = fake@hotmail.com and reciever address = myself@yahoo.com and it will send trough my smtpserver!

Anyone got any ideas of how to solve this problem?

Could someone else please check if they are able to use their smtp-server if they don't provide any username/password?

It's like smtp-auth works, but it's not forced by the server.
Back to top
View user's profile Send private message
sabrex
n00b
n00b


Joined: 28 Nov 2003
Posts: 45

PostPosted: Tue May 25, 2004 4:34 pm    Post subject: Re: SMTP-auth problem Reply with quote

petterg wrote:
I have the same problem with smtp-auth as I've had using the official howto and the old howto written by sabrex.
I've followed every single step in this howto.

Here's the thing, using mozilla mailclient:
If I set up the client to use a username, it will ask for password. If I provide a wrong user/password combination, it will not send mail. If I provide a correct user/password it will send mail. So far so good.

However, if I setup the client to NOT provide any username I'm also able to send mail!


That's probably because you're allowing your local network to relay mail, which is what the HOWTO tells you to do.

Code:
 From step 8 of the new howto:

> nano -w /etc/tcp.smtp
# Qmail-Scanner disabled for mail from localhost, relay allowed
127.0.0.1:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-queue"                                                                                                                         
# Qmail-Scanner enabled (virus only) for mail from local network, relay allowed
192.168.1.:allow,RELAYCLIENT="",RBLSMTPD="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"                                                                                                                         
# Qmail-Scanner enabled (virus and spam) for mail from external internet, relay denied
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue.pl"

save tcp.smtp and then:

> tcprules /etc/tcp.smtp.cdb /etc/tcp.smtp.tmp < /etc/tcp.smtp
> chmod 644 /etc/tcp.smtp*


The line starting with 192.168.1.:allow... is the one that allows the local network (in this case 192.168.1.0/0) to send mail via smtp.
Back to top
View user's profile Send private message
larry
n00b
n00b


Joined: 07 Jan 2004
Posts: 9

PostPosted: Tue May 25, 2004 5:01 pm    Post subject: Reply with quote

[quote="larry"][quote="Crymson"]
larry wrote:
Hi guys,
Quote:
vmysql: sql error[3]: Table 'vpopmail.vpopmail' doesn't exist
Error: User's directory already exists?


Thanks for the help.


OK, I fixed this by manually removing the domains from /var/vpopmail/domains. Then I had to use the vdeldomain to remove them from the database. This gave some errors, like "could not access directory /var/vpopmail/domains/my.domain but then I could do vadddomain and vadduser without any more errors.
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Tue May 25, 2004 5:26 pm    Post subject: Re: SMTP-auth problem Reply with quote

sabrex wrote:
That's probably because you're allowing your local network to relay mail, which is what the HOWTO tells you to do.


Ah! Thats it! Thank you!
I've wasted so many hours - installed this stuff 6 or 7 times on 3 different servers.

Now everything should be working
Back to top
View user's profile Send private message
lorano
n00b
n00b


Joined: 27 Sep 2003
Posts: 66

PostPosted: Tue May 25, 2004 6:25 pm    Post subject: Reply with quote

I keep getting this when I do vadddomain.



mysql: sql error[c]: MySQL server has gone away
vmysql: sql error[b]: MySQL server has gone away
vmysql: sql error[3]: MySQL server has gone away
could not create limits table CREATE TABLE limits ( domain CHAR(64) PRIMARY KEY, maxpopaccounts INT(10) NOT NULL DEFAULT -1, maxaliases INT(10) NOT NULL DEFAULT -1, maxforwards INT(10) NOT NULL DEFAULT -1, maxautoresponders INT(10) NOT NULL DEFAULT -1, maxmailinglists INT(10) NOT NULL DEFAULT -1, diskquota INT(12) NOT NULL DEFAULT 0, maxmsgcount INT(12) NOT NULL DEFAULT 0, defaultquota INT(12) NOT NULL DEFAULT 0, defaultmaxmsgcount INT(12) NOT NULL DEFAULT 0, disable_pop TINYINT(1) NOT NULL DEFAULT 0, disable_imap TINYINT(1) NOT NULL DEFAULT 0, disable_dialup TINYINT(1) NOT NULL DEFAULT 0, disable_passwordchanging TINYINT(1) NOT NULL DEFAULT 0, disable_webmail TINYINT(1) NOT NULL DEFAULT 0, disable_relay TINYINT(1) NOT NULL DEFAULT 0, disable_smtp TINYINT(1) NOT NULL DEFAULT 0, perm_account TINYINT(2) NOT NULL DEFAULT 0, perm_alias TINYINT(2) NOT NULL DEFAULT 0, perm_forward TINYINT(2) NOT NULL DEFAULT 0, perm_autoresponder TINYINT(2) NOT NULL DEFAULT 0, perm_maillist TINYINT(4) NOT NULL DEFAULT 0, perm_quota TINYINT(2) NOT NULL DEFAULT 0, perm_defaultquota TINYINT(2) NOT NULL DEFAULT 0 )
vmysql: sql error[p]: MySQL server has gone away
Error: (vadduser) can't read domain limits

When I use Mutt to try and send I get
qmail-inject: fatal: qq trouble creating files in queue (#4.3.0)

And I can't login from my domain at all says invalid user. Any help ould be appreciatted!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4 ... 23, 24, 25  Next
Page 3 of 25

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum