Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gcc CFLAGS for ibook g4 (cpu: 7447A) - segfaults
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
cuc
n00b
n00b


Joined: 17 Jul 2002
Posts: 11
Location: Vienna

PostPosted: Mon May 10, 2004 10:33 pm    Post subject: gcc CFLAGS for ibook g4 (cpu: 7447A) - segfaults Reply with quote

hi

i've got troubles with some packages that compile on my ibook but segfault at startup or during use...

my CFLAGS are:
CFLAGS="-O2 -mcpu=7400 -maltivec -pipe"
removed -mabi=altivec as it seems to break even more packages :)

for example:
links segfaults on startup
vi segfaults when using: -mabi=altivec (without it, it does fine)
irssi segfaults during use... e.g /whois and then it died with a nice segfault :)
mozilla loads but wont show up...
emergeing xfree brings segfaults while the emerge-process is running /usr/bin/fc-cache (free(): invalid pointer )- well at least xfree does work and quite nice with 1793fps at glxgears :)
etc...

i'm just curious if someone else experiences these problems? as i'm new to the ppc-platform i don't know that much about it...
any recommandations? perhaps updating gcc? other CFLAGS?

(its a new 1ghz ibook 12")

thx for any help... or advises :)
_________________
--
".. and who is this god person anyway?"
-thhgttg
Back to top
View user's profile Send private message
stimuli
Apprentice
Apprentice


Joined: 16 Dec 2002
Posts: 292
Location: Vancouver, BC, Canada

PostPosted: Tue May 11, 2004 2:01 am    Post subject: Reply with quote

try cpu 7450. I doubt it will solve your problems (sounds like reinstall time to me, start from scratch) but it is a closer match and in my experience quite stable.
Back to top
View user's profile Send private message
cuc
n00b
n00b


Joined: 17 Jul 2002
Posts: 11
Location: Vienna

PostPosted: Tue May 11, 2004 2:42 pm    Post subject: Reply with quote

hm ok i will try that! thank you
reinstalling the hole thing... puuuh
it took me twice the time to compile everything than on my old pIII 1ghz notebook...
i hope i dont have to... well.. lets see :)
_________________
--
".. and who is this god person anyway?"
-thhgttg
Back to top
View user's profile Send private message
cuc
n00b
n00b


Joined: 17 Jul 2002
Posts: 11
Location: Vienna

PostPosted: Tue May 11, 2004 2:58 pm    Post subject: Reply with quote

wow... seems that this works way better!
vim emerges absolutely clean and does work... even with -mabi=altivec
hm lets see if i get everything to compile/run cleanly now! :)
_________________
--
".. and who is this god person anyway?"
-thhgttg
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum