Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Livecds won't boot on a g3 powerbook
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
CHAOSACES
n00b
n00b


Joined: 12 Jan 2004
Posts: 66

PostPosted: Thu May 27, 2004 4:01 am    Post subject: Livecds won't boot on a g3 powerbook Reply with quote

My buddy has a powerbook with a 400MHz G3, 192 mB, 6Gb, and DVD. He's always complaining about how slow the thing is, so I thought I might wipe OS X and have him try Gentoo. Anyway, I can't seem to get the live cd's to boot properly. When I put the universal cd in, power on, and hold down the Option button, it won't recognize the cd as bootable (it could be a bad download or burn, but I'm out of cdr's to test that with at the moment). The minimal cd will get to the boot prompt, but fails with the following output during init:
Code:

losetup: /mnt/live/mnt/cdrom/livecd.gcloop: No such file or directory
mount: Mounting /dev/loop/0 on /mnt/live/mnt/live-env failed: Invalid argument
cp: dev: No such file or directory
cp: home: No such file or directory
cp: root: No such file or directory
cp: tmp: No such file or directory
cp: etc: No such file or directory
chmod: /mnt/live/tmp: No such file or directory
cd: 233: can't cd to ../mnt/live-env/var
cp: cache: No such file or directory
cp: lib: No such file or directory
cp: lock: No such file or directory
cp: log: No such file or directory
cp: run: No such file or directory
cp: spool: No such file or directory
cp: tmp: No such file or directory
/linuxrc: 245: mount: not found
/linuxrc: 246: cannot open /dev/console No such file
Kernel panic: Attempted to kill init!
<0>Rebooting in 180 seconds

I've tried booting with "G3" and "G3 nol3", both with the same result.

I also thought I might try my hand at a "network install" using the latest ppc knoppix, but I can't seem to get pppoe to work. (and there's no wget)

Any suggestions?
Back to top
View user's profile Send private message
paf
n00b
n00b


Joined: 27 May 2004
Posts: 3

PostPosted: Thu May 27, 2004 10:41 pm    Post subject: Same problem here Reply with quote

I have a PowerBook G3 Lombard @ 333MHz with the CD-ROM drive in the expansion bay. I have the exact same message when booting off the liveCD, as I tried to install Linux on a second partition (dual-boot)

Starting it in debug mode, I rammed around a little bit and figured a few things I cannot correct:
- the hdaX are not mapped, even though the /dev/ide/.../partXX are there and are mountable (I mounted the hfsplus OS 9 partition)
- the CD-ROM device is not present anywhere. the /dev/cdroms/ dir is empty, and on IDE there is always only one device detected. SCSI does not detect anything more, even if I try hdc=ide-scsi and load the ide-scsi module.

As the busybox has only limited tools, I cannot find out what is on the busses (lspci, etc) and cannot copy stuff onto the partition, as mkfs is not accessible either...

Any help would be most welcome:-)
_________________
paf
Back to top
View user's profile Send private message
pvdabeel
Retired Dev
Retired Dev


Joined: 25 Mar 2003
Posts: 188
Location: Belgium

PostPosted: Mon May 31, 2004 12:50 am    Post subject: Reply with quote

It can't find the livecd.gcloop (which contains all the programs etc) on the cdrom, probably because the kernel lacks drivers to see the cdrom. I'll take note of this problem and try to solve it for 2004.2.
Back to top
View user's profile Send private message
flickerfly
l33t
l33t


Joined: 08 Nov 2002
Posts: 677
Location: Lanham, MD

PostPosted: Thu Jun 10, 2004 3:56 pm    Post subject: Reply with quote

Is there any work around for this? Better than Install YDL? I agree that it seems to be a CD-ROM issue as right before it does this I see a message about it doing something with the CD-ROM.

I'd like to just boot up the CD and see what I can do. Perhaps I could build a small kernel on a floppy? Is that possible anymore?

Perhaps more pertinent, how far away are we from the 2004.2 release. :-)
_________________
An Evil Genious' Guide to Sheeple and How To Avoid Becoming One | 0x4C9EF4A
Back to top
View user's profile Send private message
flickerfly
l33t
l33t


Joined: 08 Nov 2002
Posts: 677
Location: Lanham, MD

PostPosted: Thu Jun 10, 2004 4:01 pm    Post subject: Reply with quote

nevermind, I found a solution at https://forums.gentoo.org/viewtopic.php?t=176105
_________________
An Evil Genious' Guide to Sheeple and How To Avoid Becoming One | 0x4C9EF4A
Back to top
View user's profile Send private message
asiddens
n00b
n00b


Joined: 29 Aug 2003
Posts: 31

PostPosted: Thu Jul 15, 2004 5:05 pm    Post subject: Reply with quote

Ok, I'm having the same problem on a G4 xserve. However, I get the exact same problem with the 2004.0 cd as I get with the 2004.1 cd. So what can I do? Is there no way around this? Is there a way I can get the old 1.4 cd? Can somebody slip me a 2004.2 beta?
Back to top
View user's profile Send private message
flickerfly
l33t
l33t


Joined: 08 Nov 2002
Posts: 677
Location: Lanham, MD

PostPosted: Thu Jul 15, 2004 5:09 pm    Post subject: Reply with quote

I can't help beyond suggesting using Catalyst, roll your own kernel with the drivers in it and replace your kernel with the one in 2004.1. I know it is theoretically possible, but I'm not sure how to go about it.
_________________
An Evil Genious' Guide to Sheeple and How To Avoid Becoming One | 0x4C9EF4A
Back to top
View user's profile Send private message
hairlessape
n00b
n00b


Joined: 01 Jul 2004
Posts: 5

PostPosted: Fri Jul 16, 2004 11:46 am    Post subject: Reply with quote

I think there are alot of missing files on the CD. I maybe wrong though.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum