Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
upgrade to gtk+-2.4.0-r1 segfaults...? (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ruben
Guru
Guru


Joined: 04 Jul 2003
Posts: 462

PostPosted: Fri Jun 04, 2004 4:02 pm    Post subject: upgrade to gtk+-2.4.0-r1 segfaults...? (solved) Reply with quote

I did an "emerge -U world": this upgraded my gcc and glibc to resp. gcc-3.3.3_pre20040408-r1 and glibc-2.3.3_pre20040420-r1.
There's a whole lot of other things that it wants to upgrade, but the upgrade to gtk+-2.4.0-r1 segfaults with the following:

Code:
make[4]: Entering directory `/var/tmp/portage/gtk+-2.4.0-r1/work/gtk+-2.4.0/gtk/stock-icons'
GDK_PIXBUF_MODULE_FILE=../../gdk-pixbuf/gdk-pixbuf.loaders ../../gdk-pixbuf/gdk-pixbuf-csource                                          \
   --raw --build-list stock_add_16              ./stock_add_16.png stock_add_24                 ./stock_add_24.png stock_align_center_16        ./stock_align_center_16.png stock_align_center_24  ./stock_align_center_24.png stock_align_justify_16      ./stock_align_justify_16.png stock_align_justify_24        ./stock_align_justify_24.png stock_align_left_16        ./stock_align_left_16.png stock_align_left_24   ./stock_align_left_24.png stock_align_right_16     ./stock_align_right_16.png stock_align_right_24 ./stock_align_right_24.png stock_apply_20               ./stock_apply_20.png stock_cancel_20               ./stock_cancel_20.png stock_dnd_multiple_32     ./stock_dnd_multiple_32.png stock_bottom_16             ./stock_bottom_16.png stock_bottom_24              ./stock_bottom_24.png stock_cdrom_16            ./stock_cdrom_16.png stock_cdrom_24             ./stock_cdrom_24.png stock_clear_24                ./stock_clear_24.png stock_close_20             ./stock_close_20.png stock_close_24             ./stock_close_24.png stock_colorselector_24        ./stock_colorselector_24.png stock_color_picker_25      ./stock_color_picker_25.png > gtkstockpixbufs.h ||\
           ( rm -f gtkstockpixbufs.h && false )
make[4]: *** [gtkstockpixbufs.h] Error 1


anyone any ideas what's going wrong ? (if i remove the GDK_PIXBUF_MODULE_FILE and run the script by itself, it seems to work)

my CFLAGS (i already tried with other settings, to no avail)
Code:
CFLAGS="-O2 -pipe -mcpu=750 -mtune=750 -fomit-frame-pointer -mpowerpc-gfxopt -fno-strict-aliasing"


the USE-flags
Code:
[ebuild     U ] x11-libs/gtk+-2.4.0-r1 [2.2.4-r1] +doc +jpeg +tiff  0 kB


Just wondering whether there's something stupid that i missed..? since it's marked stable, i suppose at least it should compile...


Last edited by ruben on Sun Jun 06, 2004 8:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
stimuli
Apprentice
Apprentice


Joined: 16 Dec 2002
Posts: 292
Location: Vancouver, BC, Canada

PostPosted: Fri Jun 04, 2004 5:35 pm    Post subject: Reply with quote

I'm experiencing the same thing.
Back to top
View user's profile Send private message
gronesy
n00b
n00b


Joined: 02 Apr 2004
Posts: 14

PostPosted: Fri Jun 04, 2004 6:07 pm    Post subject: Reply with quote

Ditto for me too.
Back to top
View user's profile Send private message
stimuli
Apprentice
Apprentice


Joined: 16 Dec 2002
Posts: 292
Location: Vancouver, BC, Canada

PostPosted: Fri Jun 04, 2004 11:34 pm    Post subject: Reply with quote

I'm guessing the problem lies with the source code tgz, and will be fixed w/ a new ebuild. Annoying, as many useful gnome applets segfault (task switcher, virtual desktop switcher, etc) on my current gnome 2.6 install, and I was hoping to simply emerge gnome and have it all fixed. Not so until GTK+ 2.4 can build properly.

edit: My gnome applets crashing problem is solved. I believe it was fixed by downloading the CPAN perl XML::Parser module. All applets now work, no errors.
Back to top
View user's profile Send private message
ruben
Guru
Guru


Joined: 04 Jul 2003
Posts: 462

PostPosted: Sat Jun 05, 2004 3:54 pm    Post subject: Reply with quote

At least i'm not the only one with problems...

Just for testing i tried to re-emerge my currently installed gtk+-2.2.4-r1.... guess what: it fails at exactly the same place, which makes me start to wonder about the stability of gcc-3.3.3_pre20040408-r1 and glibc-2.3.3_pre20040420-r1, since that are the major 2 changes on my system recently...
Back to top
View user's profile Send private message
ruben
Guru
Guru


Joined: 04 Jul 2003
Posts: 462

PostPosted: Sun Jun 06, 2004 8:02 pm    Post subject: Reply with quote

gtk+-2.4 successfully emerge'd after a re-emerge of libpng
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum