Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sash 3.6/3.7 compile problems G5 PPC64 (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
asv
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jul 2003
Posts: 138
Location: State College, PA United States

PostPosted: Sun Jun 06, 2004 2:14 am    Post subject: sash 3.6/3.7 compile problems G5 PPC64 (solved) Reply with quote

I have a problem compiling sash with emerge system. Here is the problem I have with sash 3.6:
Code:

>>> md5 src_uri ;-) sash-3.6.tar.gz
>>> Unpacking source...
>>> Unpacking sash-3.6.tar.gz to /var/tmp/portage/sash-3.6/work
 * Applying sash-3.6-fix-includes.patch...                                [ ok ]readline
 * Applying sash-3.6-readline.patch...                                    [ ok ]ppc64
 * Applying sash-3.6-ppc64-includes.patch...                              [ ok ]ppc
 * Applying sash-3.6-2.6-includes.patch...
 
 * Failed Patch: sash-3.6-2.6-includes.patch!
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/sash-3.6/temp/sash-3.6-2.6-includes.patch-20232.out
 
 
!!! ERROR: app-shells/sash-3.6 failed.
!!! Function epatch, Line 322, Exitcode 0
!!! Failed Patch: sash-3.6-2.6-includes.patch!


I had this problem before and fixed it by emerge sash 3.7 but when i try to emerge sash 3.7, I get the following error:
Code:

gcc -O2 -mcpu=power4 -mtune=power4 -mabi=altivec -maltivec -fno-strict-aliasing -pipe -Wall -Wmissing-prototypes -DHAVE_GZIP=1 -DHAVE_LINUX_ATTR=1 -DHAVE_LINUX_MOUNT=1 -DHAVE_BSD_MOUNT=0 -DMOUNT_TYPE='"ext3"' -DHAVE_READLINE   -c -o cmd_chattr.o cmd_chattr.c
In file included from /usr/include/linux/spinlock.h:16,
                 from /usr/include/linux/blockgroup_lock.h:8,
                 from /usr/include/linux/ext2_fs_sb.h:19,
                 from /usr/include/linux/ext2_fs.h:20,
                 from cmd_chattr.c:15:
/usr/include/asm/processor.h:543: error: parse error before "vector128"
/usr/include/asm/processor.h:549: error: parse error before '}' token
In file included from /usr/include/linux/ext2_fs.h:20,
                 from cmd_chattr.c:15:
/usr/include/linux/ext2_fs_sb.h:49: error: parse error before "u32"
/usr/include/linux/ext2_fs_sb.h:51: error: parse error before '*' token
/usr/include/linux/ext2_fs_sb.h:56: error: parse error before '}' token
make: *** [cmd_chattr.o] Error 1
 
!!! ERROR: app-shells/sash-3.7 failed.
!!! Function src_compile, Line 37, Exitcode 2
!!! (no error message)


Anybody have a workaround?


Last edited by asv on Sun Jun 06, 2004 2:43 am; edited 1 time in total
Back to top
View user's profile Send private message
asv
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jul 2003
Posts: 138
Location: State College, PA United States

PostPosted: Sun Jun 06, 2004 2:43 am    Post subject: solved Reply with quote

Code:

<tgall_foo> asv_, ok for sash-3.6 I suspect I know your problem ... umm could you tell me thefollowing .. what is /etc/make.profile linked to?
<asv_> ../usr/portage/profiles/default-ppc64-2004.0
<tgall_foo> ah .. change tat to ../usr/portage/profiles/default-ppc64-2004.1
<tgall_foo> and then cd to that directory
<tgall_foo> nano make.defaults
<tgall_foo> and look at USE=" ..."   if there is a ppc in that string change it to ppc64, save and away you go


thanks again tgall!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum