Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome problems?!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
_savage
Guru
Guru


Joined: 06 Jun 2004
Posts: 308
Location: Redmond, WA

PostPosted: Tue Jun 08, 2004 8:19 pm    Post subject: Gnome problems?! Reply with quote

hello,

well i managed to install and run Xorg last night. then i installed Gnome 2.6 and it was finished this morning. however, i've barely seen anything as flaky as Gnome. i used to run KDE on my Yellow Dog and it was stable and really reliale. Gnome crashes when i want to change window themes, frames, when i modify the terminal's colors etc etc... the applets keep dying. not happy at all! does anybody have similar problems?

i am running on a standard 1GHz Titanium Powerbook. did i skrew up my gfx settings? compiler flags?

cheers,
jens
_________________
Jens Troeger
http://savage.light-speed.de/
Back to top
View user's profile Send private message
stimuli
Apprentice
Apprentice


Joined: 16 Dec 2002
Posts: 292
Location: Vancouver, BC, Canada

PostPosted: Wed Jun 09, 2004 2:01 am    Post subject: Reply with quote

I have the same problems. These problems are from the gnome 2.6.1 ebuilds, and are new. Gnome is not typically this flaky. Obviously whatever packages control user preferences (gconf?) are the culprits, because as you say, whenever you change themes/fonts/colors/gnome terminal prefs/etc these things crash.

shitty. I haven't had a properly working Gnome in about a year.

I am on an 867mhz Tibook. Maybe it is our compiler flags or something.
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Wed Jun 09, 2004 4:17 am    Post subject: Reply with quote

Used to happen to my Gnome 2.4 on Gentoo, more specifically gnome-terminal's preferences would crash the whole application as soon as one would change anything. Luckily, all of this went away with the Gnome 2.6 upgrade.

I am using GCC 3.3.3-r6, glibc 2.3.3, and the following C flags:

Code:
-O3 -mcpu=7450 -mtune=7450 -maltivec -mabi=altivec -fno-strict-aliasing


I introduced the latter because of all of those annoying warnings; now that I thing of it, this is about the only difference between the compilation of 2.4 and 2.6.

Even if the problem went away in my case, I would love to hear about the cause...
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum