Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
German umlaute in bash?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
mox2k
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 119

PostPosted: Tue Jun 08, 2004 9:54 pm    Post subject: German umlaute in bash? Reply with quote

I have tried various things under 2004.0 to get German umlaute for the console (well, bash) - nothing has worked so far. In rc.conf export LANG=de_DE does not have any effect. The modified inputrc doesn't have any effect either. All the other letters are ok, but the umlaute are not working. Anyone?
Back to top
View user's profile Send private message
porodzila
Guru
Guru


Joined: 22 May 2004
Posts: 307
Location: Terrapin Station

PostPosted: Wed Jun 09, 2004 2:20 am    Post subject: Reply with quote

I dont think those characters are available in the console
_________________
ubi primum potero, me hinc subduco.
Back to top
View user's profile Send private message
mat74
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2004
Posts: 88

PostPosted: Wed Jun 09, 2004 2:39 am    Post subject: Reply with quote

I have them in console and on tty's. These are the sections from my rc.conf concerning fonts:
Code:
KEYMAP="de-latin1-nodeadkeys"

...
Code:
CONSOLEFONT="lat9w-16"

...
You might also want to check:http://www.gentoo.org/doc/de/guide-localization.xml
for more infos on localization.

cya
Back to top
View user's profile Send private message
bergs
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jul 2002
Posts: 141
Location: Bern, Switzerland

PostPosted: Wed Jun 09, 2004 8:58 am    Post subject: Reply with quote

Also check these kernel options if you want to be able to use Umlaute in file names:

File systems -> Native Language Support

[*] Codepage 850 (only needed if you want to mount FAT filesystems)
[*] NLS ISO 8859-1

I'm not shure if this is also needed:

in /etc/profile

export LC_CTYPE="iso_8859_1" (I have: export LC_CTYPE="de_CH")

Please correct me if I am wrong ...

Simon
Back to top
View user's profile Send private message
mox2k
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 119

PostPosted: Thu Jun 10, 2004 8:19 am    Post subject: Umlaute do work :) Reply with quote

Thanks everyone :) I think it was

CONSOLEFONT="lat9w-16"

that eventually helped me get going.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum