Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Automounting in userspace with ivman
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 27, 28, 29  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
foulmetal
n00b
n00b


Joined: 09 Jul 2004
Posts: 20
Location: Nantes

PostPosted: Sun Jul 18, 2004 9:54 am    Post subject: Reply with quote

Redeeman wrote:
then edit /etc/conf.d/ivman and change to root....

ok, but is there no way to make it works as non-root? If not, can you explain me?
the problem with this solution is if autoplay is enable, the command which is used is executed as root :/ (i know that i can use the su -c command, but its ulgy)

(sorry for my bad english)
Back to top
View user's profile Send private message
eikketk
Apprentice
Apprentice


Joined: 03 Jun 2003
Posts: 270
Location: Belgium

PostPosted: Sun Jul 18, 2004 10:51 am    Post subject: Reply with quote

Ivman was initially written to be run as root. I run it as root too. The method to run it as an unpriviledged user is just a sort of hack, I never intended it to be like this, and the code isn't optimized to work as a non-root user, because of some problems we experience when running as non-root. Please read the mailing list archives for some other toughts on this (related to ivman_ng).
_________________
Working day and night to enhance the Linux Desktop Experience :)

Homepage
Back to top
View user's profile Send private message
DocterD
Tux's lil' helper
Tux's lil' helper


Joined: 15 May 2004
Posts: 129

PostPosted: Tue Jul 20, 2004 5:00 pm    Post subject: Reply with quote

can't emerge hal-cvs etc.

Quote:
/usr/sbin/ebuild.sh: line 1101: /usr/portage/eclass/fluidcvs.eclass: No such file or directory

!!! ERROR: sys-apps/hal-cvs-20040522 failed.
!!! Function inherit, Line 1102, Exitcode 1
!!! died sourcing /usr/portage/eclass/fluidcvs.eclass in inherit()


aux_get(): (0) Error in sys-apps/hal-cvs-20040522 ebuild. (1)
Check for syntax error or corruption in the ebuild. (--debug)

Calculating dependencies
!!! all ebuilds that could satisfy "hal-cvs" have been masked.
!!! possible candidates are:
/usr/sbin/ebuild.sh: line 1101: /usr/portage/eclass/fluidcvs.eclass: No such file or directory

!!! ERROR: sys-apps/hal-cvs-20040522 failed.
!!! Function inherit, Line 1102, Exitcode 1
!!! died sourcing /usr/portage/eclass/fluidcvs.eclass in inherit()


aux_get(): (0) Error in sys-apps/hal-cvs-20040522 ebuild. (1)
Check for syntax error or corruption in the ebuild. (--debug)


!!! Error calculating dependencies. Please correct.
Back to top
View user's profile Send private message
Chaosite
Guru
Guru


Joined: 13 Dec 2003
Posts: 540
Location: Right over here.

PostPosted: Tue Jul 20, 2004 5:09 pm    Post subject: Reply with quote

DocterD wrote:
can't emerge hal-cvs etc.

Quote:
/usr/sbin/ebuild.sh: line 1101: /usr/portage/eclass/fluidcvs.eclass: No such file or directory

!!! ERROR: sys-apps/hal-cvs-20040522 failed.
!!! Function inherit, Line 1102, Exitcode 1
!!! died sourcing /usr/portage/eclass/fluidcvs.eclass in inherit()


aux_get(): (0) Error in sys-apps/hal-cvs-20040522 ebuild. (1)
Check for syntax error or corruption in the ebuild. (--debug)

Calculating dependencies
!!! all ebuilds that could satisfy "hal-cvs" have been masked.
!!! possible candidates are:
/usr/sbin/ebuild.sh: line 1101: /usr/portage/eclass/fluidcvs.eclass: No such file or directory

!!! ERROR: sys-apps/hal-cvs-20040522 failed.
!!! Function inherit, Line 1102, Exitcode 1
!!! died sourcing /usr/portage/eclass/fluidcvs.eclass in inherit()


aux_get(): (0) Error in sys-apps/hal-cvs-20040522 ebuild. (1)
Check for syntax error or corruption in the ebuild. (--debug)


!!! Error calculating dependencies. Please correct.


First of all, hal-cvs is still masked.

Second, you didn't follow the instructions well enough and grab the eclass stuff.

Look again.
Back to top
View user's profile Send private message
Chaosite
Guru
Guru


Joined: 13 Dec 2003
Posts: 540
Location: Right over here.

PostPosted: Thu Jul 22, 2004 2:52 pm    Post subject: Reply with quote

Ummm...

Bump?

This is some good stuff, it should stay on the main page!
Back to top
View user's profile Send private message
StuRReaL
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2003
Posts: 117

PostPosted: Thu Jul 22, 2004 5:34 pm    Post subject: Reply with quote

I've followed the tutorial through and i've read through the forum and I can't for the life of me get automounter to work :(

Its compiled the services are installed and running and i'm using a full udev system as i didn't compile devfs into my kernel.
Back to top
View user's profile Send private message
eikketk
Apprentice
Apprentice


Joined: 03 Jun 2003
Posts: 270
Location: Belgium

PostPosted: Thu Jul 22, 2004 5:49 pm    Post subject: Reply with quote

Did you try running in debug mode? That *should* clarify some things.

I'll be on holiday next 2 weeks, no internet connection or whatsoever (:(), so I won't be able to help people out for some time, srry.
_________________
Working day and night to enhance the Linux Desktop Experience :)

Homepage
Back to top
View user's profile Send private message
StuRReaL
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2003
Posts: 117

PostPosted: Thu Jul 22, 2004 6:43 pm    Post subject: Reply with quote

turning on debug just seems to stop it showing [ok] when i start the service
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Thu Jul 22, 2004 6:52 pm    Post subject: Reply with quote

dont run it as service when doing debug...
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
StuRReaL
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2003
Posts: 117

PostPosted: Thu Jul 22, 2004 7:07 pm    Post subject: Reply with quote

ok now i'm very confused, its a system service so surely it can't run as anything else?
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Thu Jul 22, 2004 7:24 pm    Post subject: Reply with quote

just type ivman in console
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
StuRReaL
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2003
Posts: 117

PostPosted: Thu Jul 22, 2004 7:51 pm    Post subject: Reply with quote

ok i've done it and i get the following

Code:

Ikke's Volume Manager, http://ivman.sf.net


I insert a CD and it doesn't mount i have to do it manually :(
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Thu Jul 22, 2004 9:53 pm    Post subject: Reply with quote

yeah well you still need HAL and DBUS started, and remember to switch to debug mode in ivman
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
StuRReaL
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2003
Posts: 117

PostPosted: Sat Jul 24, 2004 11:17 am    Post subject: Reply with quote

I have it working on my VMware Gentoo install which runs in windows. As main Gentoo install that doesn't work I don't even get any debug output? no idea why, here are the kernels i'm running on each one anyway

VMWare Gentoo: Gentoo Gentoo-Dev-Sources 2.6.7-r11
Main Gentoo install: Love-sources 2.6.7-r7
Back to top
View user's profile Send private message
bennettp
Guru
Guru


Joined: 22 Feb 2004
Posts: 335
Location: on my back and tumbling

PostPosted: Sat Jul 24, 2004 3:13 pm    Post subject: Reply with quote

hey now this really looks promising... Its a pity there are still a few things that don't work (like drive bay unlocking, audio cd playback, probably others also), but this could really be "the killer app" as far as the linux desktop is concerned... once its finished.

The "automagic dvd playback" also doesn't work for me: not the default option anyway; I had to set up my own action. It opens mplayer in a new X server, rather than in the console:

1. Open the file /etc/ivman/IvmConfigActions.xml
2. Change the line <ivm:Option name="autoplay_dvd_cmd" value="blah" /> to:

Code:
<ivm:Option name="autoplay_dvd_cmd" value="xinit /usr/bin/xterm -e /usr/bin/mplayer -nofixed-vo dvd://1-99 -fs -- :4" />

This command opens up a new X server, with mplayer running in an xterm (in fullscreen mode of course)! Mplayer then tries to play all titles (1-99) on the dvd, and exits.

Instead of opening a new X server, it might be possible to tell mplayer to connect to :0 with the option "-display :0", but I haven't tried this myself.


Last edited by bennettp on Sat Jul 24, 2004 3:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
bennettp
Guru
Guru


Joined: 22 Feb 2004
Posts: 335
Location: on my back and tumbling

PostPosted: Sat Jul 24, 2004 3:15 pm    Post subject: Reply with quote

StuRReaL wrote:
I have it working on my VMware Gentoo install which runs in windows. As main Gentoo install that doesn't work I don't even get any debug output? no idea why, here are the kernels i'm running on each one anyway

VMWare Gentoo: Gentoo Gentoo-Dev-Sources 2.6.7-r11
Main Gentoo install: Love-sources 2.6.7-r7

Not sure what you meant here, if you want debug output from ivman, open /etc/ivman/IvmConfigBase.xml and change the "debug" option to "true". ivman will then tell you what its going, in a fair amount of detail.

EDIT: Oops shoulda read your previous posts, looks like you've already enabled debug...
Back to top
View user's profile Send private message
StuRReaL
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2003
Posts: 117

PostPosted: Sat Jul 24, 2004 3:23 pm    Post subject: Reply with quote

bennettp wrote:
StuRReaL wrote:
I have it working on my VMware Gentoo install which runs in windows. As main Gentoo install that doesn't work I don't even get any debug output? no idea why, here are the kernels i'm running on each one anyway

VMWare Gentoo: Gentoo Gentoo-Dev-Sources 2.6.7-r11
Main Gentoo install: Love-sources 2.6.7-r7

Not sure what you meant here, if you want debug output from ivman, open /etc/ivman/IvmConfigBase.xml and change the "debug" option to "true". ivman will then tell you what its going, in a fair amount of detail.

EDIT: Oops shoulda read your previous posts.


My main gentoo install i.e the one on my second HDD the one running the love-sources is the one thats not displaying any debug info when it is set to debug :(
Back to top
View user's profile Send private message
motaboy
Developer
Developer


Joined: 15 Dec 2003
Posts: 1483

PostPosted: Mon Jul 26, 2004 1:18 pm    Post subject: Reply with quote

Hi, from some months I'm very interest in this ivman features but unfortunately I don't have much time to dig in the ivman code (exams...).

I've did some experiments on ejecting the CD/DVD WHENEVER I WANT.

EDIT: Forget what I've said, after some experimentes I've noticed that the -l umount's option will only mark the device as unmounted but the VFS will be already connected to it, so if you remount another device you'll get only garbage.


I don't know if ivman already implement (it yes, then it doesn't work on my system :) ) it but I think (if it's right) that this will be a good solution.

I've read on various mailinglist (utopia, hal etc...) that the "umount -f" command doesn't works, well you're right, but why don't you use the "umount -l".
It's the lazy option, from "man umount":
Quote:

-l Lazy unmount. Detach the filesystem from the filesystem hierarchy
now, and cleanup all references to the filesystem as soon as it is
not busy anymore. (Requires kernel 2.4.11 or later.)


Example:


1) UNLOCK the cdrom tray

Code:

echo 0 > /proc/sys/dev/cdrom/lock


2) mount the cd/dvd and use it (read files, play video, oggs etc...)

3) while you are accessing CD, press the eject button, the programs will stop them (If they are correctly programmed)

4) umount the cd/dvd.
Code:

umount /mnt/...

You'll get this error, because the programs are accessing it:
Code:

umount: /mnt/cdrom0: device is busy
umount: /mnt/cdrom0: device is busy


Well, this is a normal behavior, now try this:

Code:

umount -l /mnt/...


On my system, the fs is correctly unmounted without any problem (look at "mount" output), and can be remounted too.

Well, the question is: Does this works only on my system, or works well for you too?
Please can you try this? THANKS A LOT.
(you can launch offences to me too :) )
_________________
...


Last edited by motaboy on Sun Aug 01, 2004 9:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
jawest12
n00b
n00b


Joined: 23 Jul 2002
Posts: 12
Location: USA

PostPosted: Tue Jul 27, 2004 12:39 am    Post subject: Help Reply with quote

I am getting the following error when using the ivman-0.3 ebuild downloaded from the sourceforge ivman site.

If anyone has time to help me it would be greatly appreciated, and please let me know if you need anymore information such as my make.conf.

Listed below is the main error.

Quote:
/bin/sh ./config.status --recheck
running /bin/sh ./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib CC=gcc CFLAGS=-O2 -march=pentium4 -fomit-frame-pointer host_alias=i686-pc-linux-gnu --no-create --no-recursion
configure: warning: CC=gcc: invalid host type
configure: warning: CFLAGS=-O2 -march=pentium4 -fomit-frame-pointer: invalid host type
configure: error: can only configure for one host and one target at a time
make: *** [config.status] Error 1

!!! ERROR: sys-apps/ivman-0.3 failed.
!!! Function src_compile, Line 24, Exitcode 2
!!! Make failed


That's the quick version. Listed below is the full output in case someone can see something I am missing.

Quote:

Calculating dependencies ...done!
>>> emerge (1 of 1) sys-apps/ivman-0.3 to /
>>> md5 src_uri ;-) ivman-0.3.tar.gz
>>> Unpacking source...
>>> Unpacking ivman-0.3.tar.gz to /var/tmp/portage/ivman-0.3/work
>>> Source unpacked.
configure: WARNING: If you wanted to set the --build type, don't use --host.
If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... found
checking for working autoconf... found
checking for working automake-1.4... found
checking for working autoheader... found
checking for working makeinfo... found
checking for i686-pc-linux-gnu-gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for a BSD-compatible install... /bin/install -c
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for ld used by GCC... /usr/i686-pc-linux-gnu/bin/ld
checking if the linker (/usr/i686-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for /usr/i686-pc-linux-gnu/bin/ld option to reload object files... -r
checking for BSD-compatible nm... nm
checking for a sed that does not truncate output... /bin/sed
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking command to parse nm output... ok
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for i686-pc-linux-gnu-ranlib... no
checking for ranlib... ranlib
checking for i686-pc-linux-gnu-strip... no
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking whether the linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking whether -lc should be explicitly linked in... no
creating libtool
checking for mount... /bin/mount
checking for umount... /bin/umount
checking wether to enable debugging... no
checking for pkg-config... /usr/bin/pkg-config
checking for libxml-2.0... yes
checking LIBXML_CFLAGS... -I/usr/include/libxml2
checking LIBXML_LIBS... -lxml2 -lpthread -lz -lm
checking for glib-2.0 >= 2.2.2 ... yes
checking GLIB_CFLAGS... -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
checking GLIB_LIBS... -lglib-2.0
checking for dbus-glib-1 >= 0.20 ... yes
checking DBUS_GLIB_CFLAGS... -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
checking DBUS_GLIB_LIBS... -ldbus-glib-1 -ldbus-1 -lglib-2.0
checking for hal >= 0.2.90 ... yes
checking HAL_CFLAGS... -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/hal -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
checking HAL_LIBS... -lhal -ldbus-1
checking for unistd.h... (cached) yes
checking stdio.h usability... yes
checking stdio.h presence... yes
checking for stdio.h... yes
checking dbus/dbus.h usability... no
checking dbus/dbus.h presence... no
checking for dbus/dbus.h... no
checking dbus/dbus-glib.h usability... no
checking dbus/dbus-glib.h presence... no
checking for dbus/dbus-glib.h... no
checking libhal.h usability... no
checking libhal.h presence... no
checking for libhal.h... no
checking for printf... yes
checking for fprintf... yes
checking for strcmp... yes
checking for strncmp... yes
checking for g_warning... no
checking for g_strdup... no
checking for g_string_append... no
checking for g_spawn_async... no
checking for g_string_free... no
checking for g_free... no
checking for g_build_path... no
checking for g_file_test... no
checking for g_main_loop_new... no
checking for g_main_loop_run... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating src/IvmConfig/Makefile
config.status: creating config.h
config.status: executing default-1 commands
cd . && aclocal-1.4
cd . && automake-1.4 --gnu Makefile
cd . && autoconf
/bin/sh ./config.status --recheck
running /bin/sh ./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib CC=gcc CFLAGS=-O2 -march=pentium4 -fomit-frame-pointer host_alias=i686-pc-linux-gnu --no-create --no-recursion
configure: warning: CC=gcc: invalid host type
configure: warning: CFLAGS=-O2 -march=pentium4 -fomit-frame-pointer: invalid host type
configure: error: can only configure for one host and one target at a time
make: *** [config.status] Error 1

!!! ERROR: sys-apps/ivman-0.3 failed.
!!! Function src_compile, Line 24, Exitcode 2
!!! Make failed
Back to top
View user's profile Send private message
HydroSan
l33t
l33t


Joined: 04 Mar 2004
Posts: 764
Location: The Kremlin (aka Canada)

PostPosted: Sat Jul 31, 2004 2:59 am    Post subject: Reply with quote

Failure on compiling hal-cvs.

Code:
make[3]: Entering directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/fdi'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/fdi'
make[2]: Leaving directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/fdi'
Making all in doc
make[2]: Entering directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc'
Making all in api
make[3]: Entering directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc/ api'
/usr/bin/doxygen
make[3]: Leaving directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc/a pi'
Making all in spec
make[3]: Entering directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc/ spec'
/usr/bin/docbook2html --nochunks hal-spec.xml -o .
Using catalogs: /usr/share/sgml/docbook/sgml-dtd-3.0/catalog, /usr/share/sgml/do cbook/sgml-dtd-3.1/catalog, /usr/share/sgml/docbook/sgml-dtd-4.0/catalog, /usr/s hare/sgml/docbook/sgml-dtd-4.1/catalog, /usr/share/sgml/docbook/dsssl-stylesheet s-1.77/catalog, /usr/share/sgml/xml-iso-entities-8879.1986/catalog, /usr/share/s gml/sgml-iso-entities-8879.1986/catalog, /usr/share/sgml/openjade-1.3.2/dsssl/ca talog, /usr/share/sgml/openjade-1.3.2/catalog, /usr/share/sgml/opensp-1.5.1/Open SP/catalog
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.12/docbook-utils.dsl#html
Working on: /var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc/spec/hal-spec.xml
jade:/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc/spec/hal-spec.xml:4:125: E: cannot open "/usr/share/sgml/docbook/xml-dtd-4.1.2-1.0-22.1/docbookx.dtd" (No  such file or directory)
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/dblink.dsl:203:1:E: XRe f LinkEnd to missing ID 'device-properties'
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/dblink.dsl:203:1:E: XRe f LinkEnd to missing ID 'using-devices'
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.77/html/../common/dbtable.dsl:2 24:13:E: 2nd argument for primitive "ancestor" of wrong type: "#<unknown object 135998024>" not a singleton node list
make[3]: *** [hal-spec.html] Error 8
make[3]: Leaving directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc/s pec'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/hal-cvs-20040522/work/hal-cvs'
make: *** [all] Error 2

!!! ERROR: sys-apps/hal-cvs-20040522 failed.
!!! Function src_compile, Line 33, Exitcode 2
!!! Make failed


GCC 3.3.4, glibc 2.3.4 (latest).
_________________
I was a Gangster for Capitalism, by Major General Smedley Butler.

Server status: Currently down, being replaced with fresh install - 20% completed.
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Sat Jul 31, 2004 9:10 am    Post subject: Reply with quote

yeah, i cant garantuee it will always compile since its being pulled from cvs
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
andyknownasabu
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 281
Location: Zurich, Switzerland

PostPosted: Sat Jul 31, 2004 10:56 am    Post subject: Reply with quote

I did not follow the whole thread and therefore don't know if this has already been mentioned... Anyway:

Besides using the "homemade" ebuilds (as they seem to cause some problems) you can make use of the alternative "BreakMyGentoo" portage overlay:
Code:
emerge gentoolkit-dev
mkdir /usr/local/overlays/
gensync bmg-main

After this change PORTDIR_OVERLAY in /etc/make.conf to read
Code:
PORTDIR_OVERLAY=/usr/local/overlays/bmg-main.alternative/

Now, you have dbus-cvs, hal-cvs and ivman-cvs in your tree! ;)

After that, just do
Code:
emerge /usr/local/overlays/bmg-main.alternative/sys-apps/dbus-cvs/dbus-cvs-0.22-r3.ebuild
emerge /usr/local/overlays/bmg-main.alternative/sys-apps/hal-cvs/hal-cvs-0.3-r2.ebuild
emerge /usr/local/overlays/bmg-main.alternative/sys-apps/ivman-cvs/ivman-cvs-0.30.ebuild

and you're ready to go.
Back to top
View user's profile Send private message
andyknownasabu
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 281
Location: Zurich, Switzerland

PostPosted: Sat Jul 31, 2004 7:54 pm    Post subject: Reply with quote

But I also have a question concerning ivman:
/var/log/user.log says
Code:
Jul 31 14:19:21 phoenix ivman: Devices table has 1 entries
Jul 31 14:19:21 phoenix ivman:        "/org/freedesktop/Hal/devices/block_11_1-disc"   "/mnt/dvdrom"

If I insert a CD in my second drive nothing happens. Where/how can I add further devices into the table or is this automatically done by hal/dbus?
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Sat Jul 31, 2004 9:01 pm    Post subject: Reply with quote

andyknownasabu wrote:
I did not follow the whole thread and therefore don't know if this has already been mentioned... Anyway:

Besides using the "homemade" ebuilds (as they seem to cause some problems) you can make use of the alternative "BreakMyGentoo" portage overlay:

they aint more homemade than breakmygentoo ;P

also, i do not suggest using breakmygentoo's, as when i tried them, they were having problems with the configure options ;P

Quote:
If I insert a CD in my second drive nothing happens. Where/how can I add further devices into the table or is this automatically done by hal/dbus?

hal is supposed to do that
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
andyknownasabu
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 281
Location: Zurich, Switzerland

PostPosted: Sat Jul 31, 2004 9:08 pm    Post subject: Reply with quote

Redeeman wrote:
they aint more homemade than breakmygentoo ;P

also, i do not suggest using breakmygentoo's, as when i tried them, they were having problems with the configure options ;P


What kind of problems? hal-cvs, dbus-cvs and ivman-cvs are all working fine on my gentoo box... well, at least except that problem with my second drive.

I didn't want to criticize you or your work - I just wanted to mention this for the sake of completeness... Please don't take it personally:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 27, 28, 29  Next
Page 7 of 29

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum