Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udaten van portage zelf
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Donny
n00b
n00b


Joined: 06 Jun 2004
Posts: 59

PostPosted: Mon Jun 14, 2004 3:55 pm    Post subject: udaten van portage zelf Reply with quote

Na een emerge sync kreeg ik het bericht dat er een nieuwe versie van portage beschikbaar was en dat deze me hoog nodig werd aangeraden.

Na emerge -up portage kreeg ik de volgende lijst:
Code:

portage # emerge -up portage

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild     U ] sys-devel/gnuconfig-20040214 [20030708]
[ebuild     U ] sys-libs/ncurses-5.4-r1 [5.3-r5]
[ebuild     U ] sys-devel/gettext-0.12.1-r1 [0.11.5]
[ebuild     U ] sys-apps/texinfo-4.6 [4.5]
[ebuild     U ] sys-apps/groff-1.19 [1.18.1-r4]
[ebuild     U ] sys-apps/man-1.5m-r1 [1.5l-r6]
[ebuild     U ] sys-devel/libperl-5.8.4 [5.8.2]
[ebuild     U ] dev-lang/perl-5.8.4 [5.8.2-r1]
[ebuild     U ] sys-devel/autoconf-2.59-r3 [2.58-r1]
[ebuild     U ] sys-devel/libtool-1.5.2-r5 [1.4.3-r3]
[ebuild     U ] sys-devel/gcc-config-1.3.5-r1 [1.3.4]
[ebuild     U ] sys-devel/binutils-2.15.90.0.1.1-r3 [2.14.90.0.8-r1]
[ebuild     U ] sys-devel/gcc-3.3.3-r6 [3.3.3]
[ebuild     U ] sys-kernel/linux-headers-2.4.21-r1 [2.4.21]
[ebuild  N    ] app-crypt/hashalot-0.2.0
[ebuild     U ] sys-apps/util-linux-2.12-r4 [2.11z-r8]
[ebuild     U ] sys-apps/baselayout-1.9.4-r2 [1.8.6.13]
[ebuild     U ] sys-libs/glibc-2.3.3_pre20040529 [2.3.2-r9]
[ebuild     U ] sys-apps/sed-4.0.9 [4.0.7]
[ebuild     U ] dev-python/python-fchksum-1.7.1 [1.6.1-r1]
[ebuild     U ] app-shells/bash-2.05b-r9 [2.05b-r7]
[ebuild     U ] dev-libs/openssl-0.9.7d [0.9.7c-r1]
[ebuild     U ] dev-libs/expat-1.95.7 [1.95.6-r1]
[ebuild     U ] dev-lang/python-2.3.3-r1 [2.3.3]
[ebuild     U ] sys-apps/portage-2.0.50-r8 [2.0.50-r1]

Betekend het nu dat al deze paketten worden geupdate?
En zoja is het verantwoord het met emerge -u portage te doen?
Waarom sys-kernel/linux-headers-2.4.21-r1 als ik een 2.6 kernel gebruik?
Sorry voor al deze vragen maar ik ben nieuw met gentoo en moet nog erg wennen aan portage en het juiste gebruik ervan.

Ik heb gentoo geinstalleerd met de universal 2004.0 cd 64bit version.
Back to top
View user's profile Send private message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 106
Location: The Netherlands

PostPosted: Mon Jun 14, 2004 4:08 pm    Post subject: Reply with quote

Als je per se eerst alleen portage wilt updaten kun je bijv. dit doen:

Code:

emerge -u --nodeps portage


Als dat is uitgeraasd kun je de rest updaten

Om de 2.6 kernel headers te installeren zul je in "/etc/portage/packages.keywords" even moeten aangeven dat je daarvoor de onstabiele (dat moet je relatief zien..) pakketten wilt gebruiken.

Code:

sys-kernel/linux-headers ~x86


Als het dan nog niet werkt kun je ook i.p.v. "~x86" bijv. "-x86" of zelfs "-*" doen. Het makkelijkst is om even te kijken in de betreffende ebuild en daar even kijken wat er bij de variabele "KEYWORDS" staat.

Ik hoop dat je nu weer even vooruit komt, schroom niet nog meer te vragen..;)

Succes!
Back to top
View user's profile Send private message
Donny
n00b
n00b


Joined: 06 Jun 2004
Posts: 59

PostPosted: Mon Jun 14, 2004 4:40 pm    Post subject: Reply with quote

Bedankt voor je snelle antwoord de --nodeps werkt perfect!
Portage is nu geupdate en de rest doe ik wel een andere keer ik zie op dit moment het nut er nog niet van in.

De file /etc/portage/packages.keywords bestond nog niet op mijn system dus deze heb ik meteen aangemaakt. Voor dat ik portage met --nodeps ging updaten heb ik eerst nog even geprobeert om met
Code:
sys-kernel/linux-headers ~x86

die 2.4 headers er uit te laten maar dit had geen succes ook niet met de andere opties.
De sys-kernel/linux-headers-2.6.3-r1 die het eigenlijk hadden moeten zijn kreeg ik er niet bij ook niet met het keyword -* wat in de ebuild stond. Waarschijnlijk doe ik wel wat fout hoor.
Is de packages.keyword file nu om keywords die in de packages niet te gebruiken of juist wel te gebruiken?
Back to top
View user's profile Send private message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 106
Location: The Netherlands

PostPosted: Mon Jun 14, 2004 4:49 pm    Post subject: Reply with quote

In principe is het zo dat als je "x86" instelt portage op zoek gaat naar het de hoogste versie van dat softwarepakket die nog steeds "x86" in de keywords heeft staan, wat wil zeggen dat het stabiel is op het x86 platform.

Op het moment dat je "~x86" invult gaat portage op zoek naar de nieuwste versie met "~x86" in de keywords.

Ik heb het nagekeken en zelf heb ik "-*" in /etc/portage/package.keywords staan .

Dus:
Code:

sys-kernel/linux-headers -*


Bij mij werkt dat prima...;)

Ow wacht even, ik zie het al, ik heb een letter teveel gedaan in mijn vorige post..:lol: Het bestand moet zijn "/etc/portage/package.keywords" enkelvoud dus. Zo zie je maar, foutje is snel gemaakt..;)

Hopelijk gaat alles nu wel goed, nogmaals succes!
Back to top
View user's profile Send private message
Donny
n00b
n00b


Joined: 06 Jun 2004
Posts: 59

PostPosted: Mon Jun 14, 2004 5:32 pm    Post subject: Reply with quote

Ik heb het extra s`je verwijdert en portage reageert nu wel op de file :)
Bedankt voor je behulpzaamheid en je ziet me vast en zeker terug met meer vragen :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum