Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
radeon igp howto
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
neuron
Advocate
Advocate


Joined: 28 May 2002
Posts: 2371

PostPosted: Thu Jun 17, 2004 10:49 am    Post subject: radeon igp howto Reply with quote

I was looking around to get this card to work, and it's a lot simpler than the instructions I found everywhere (cvs drivers and xfree + kernel patches).

Took me whole day to figure it out, but..

grab the 2.6.7 kernel
#emerge development-sources
grab a new xfree ebuild:
#mkdir -p /usr/local/portage/x11-base/xfree/
#cd /usr/local/portage/x11-base/xfree/
#wget http://www.consultmatt.co.uk/downloads/xfree-4.3.99.16.ebuild
(see http://www.consultmatt.co.uk/nx9005/radeon-igp/index.php, he made the ebuild and that page helped me figure out the mess ;) ).
Unmask the ebuild
#mkdir /etc/portage
#echo "=x11-base/xfree-4.3.99.16" >> /etc/portage/package.unmask

#emerge -f xfree && ebuild xfree-4.3.99.16.ebuild digest

rebuild your kernel with theese options:
device drivers -> character devices:
<M> /dev/agpgart (AGP Support)
<M> ATI chipset support
[*] Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)
<M> ATI Radeon


build the kernel, build xfree and reboot.
load agpgart and ati-agp before radeon
note that I had to build them as modules, not into the kernel.
I'm also using radeonfb now, works perfectly, but takes around 50fps off my 650fps xfree.
Back to top
View user's profile Send private message
Twiggy794
Guru
Guru


Joined: 21 Jun 2004
Posts: 321
Location: Hershey, PA

PostPosted: Wed Jun 23, 2004 1:06 pm    Post subject: Reply with quote

You compiled those as modules...so do you need to manually insmod them after you boot? I hear the performance sucks, is that true?
_________________
"Subtraction: Addition's tricky pal." --David Letterman
http://ferg.ath.cx == teh bL0g
Back to top
View user's profile Send private message
neuron
Advocate
Advocate


Joined: 28 May 2002
Posts: 2371

PostPosted: Wed Jun 23, 2004 1:44 pm    Post subject: Reply with quote

Twiggy794 wrote:
You compiled those as modules...so do you need to manually insmod them after you boot? I hear the performance sucks, is that true?


you need to manualy load them or add them to /etc/modules.autoload.d/kernel-2.6

and... yeah, the performance sucks, but its a hell of a lot better than nothing :)

and having xv is very nice for video playback performance.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum