Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Mini-HOWTO] X.org & font
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Bash[DevNull]
Guru
Guru


Joined: 10 Oct 2003
Posts: 333

PostPosted: Sat Jun 26, 2004 8:41 pm    Post subject: Reply with quote

Hey, people! Please, post your screenshots (for example Firefox with opened gentoo-forums) :)))
_________________
Biomechanical Artificial Sabotage Humanoid
Back to top
View user's profile Send private message
BlindSpy
Apprentice
Apprentice


Joined: 20 Mar 2004
Posts: 263

PostPosted: Sun Jun 27, 2004 5:47 am    Post subject: Reply with quote

Sastraxi whats the dif without moznoxft compiled in? do you still have antialiasing?
_________________
Symlinks to:
xorg.conf
Back to top
View user's profile Send private message
Sastraxi
Apprentice
Apprentice


Joined: 25 Feb 2003
Posts: 258

PostPosted: Mon Jun 28, 2004 3:40 pm    Post subject: Reply with quote

I have antialiasing and no more of that awful blurry 'x' or 'k' without a bottom... it's amazing :) Here's my current desktop, if you guys want to see it.

[img:f6daf4689c]http://www.crystal-rain.com/files/screeno.png[/img:f6daf4689c]
http://www.crystal-rain.com/files/screeno.png if the image doesn't work...
_________________
Platypus.
Back to top
View user's profile Send private message
Zyne
Guru
Guru


Joined: 08 Jun 2004
Posts: 334

PostPosted: Tue Jun 29, 2004 1:32 pm    Post subject: Reply with quote

Thanks a lot for this great guide mate...
I just finished compiling my X.org after getting rid of xfree, and my fonts looked like shit... This little howto fixed all my problems with my fonts.


Thanks again mate!
Back to top
View user's profile Send private message
mlybarger
Guru
Guru


Joined: 04 Sep 2002
Posts: 463

PostPosted: Wed Jun 30, 2004 4:37 pm    Post subject: Reply with quote

i tried this also to the T, but still have not so good fonts. they're probably not getting anti aliased or some such. my /var/log/Xorg.0.log file shows:

Code:

(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/encodings/".
        Entry deleted from font path.
        (Run 'mkfontdir' on "/usr/share/fonts/encodings/").
(WW) The directory "/usr/share/fonts/sharefont/" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/share/fonts/lfp-fix/" does not exist.
        Entry deleted from font path.
(**) FontPath set to "/usr/share/fonts/TTF/,/usr/share/fonts/ttf-bitstream-vera/,/usr/share/fonts/terminus/,/usr/share/fonts/corefonts/,/usr/share/fonts/Type1/,/usr/share/fonts/freefont/,/usr/share/fonts/artwiz/,/usr/share/fonts/local/,/usr/share/fonts/misc/,/usr/share/fonts/75dpi/:unscaled,/usr/share/fonts/100dpi/:unscaled,/usr/share/fonts/Speedo/,/usr/share/fonts/CID/,/usr/share/fonts/util/,/usr/share/fonts/75dpi/,/usr/share/fonts/100dpi/,/usr/share/fonts/unifont/"
        X.Org Font Renderer : 0.4
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) Loading extension FontCache
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Speedo
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.so
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) Initializing built-in extension XFree86-Bigfont
Could not init font path element /usr/share/fonts/Type1/, removing from list!
Could not init font path element /usr/share/fonts/local/, removing from list!
Could not init font path element /usr/share/fonts/Speedo/, removing from list!
Could not init font path element /usr/share/fonts/CID/, removing from list!
Could not init font path element /usr/share/fonts/util/, removing from list!
Back to top
View user's profile Send private message
Tun
n00b
n00b


Joined: 19 Jan 2004
Posts: 58
Location: Stockport, England

PostPosted: Wed Jun 30, 2004 10:16 pm    Post subject: Reply with quote

Cheers for this, it was a big help in sorting my fonts out.

I never realised firefox could look like this, it's a lot more impressive than it was under XFree and I can now use artwiz fonts with fluxbox which I'd failed at before.

I had a test of different options an I found -moznoxf and uncommenting the sub-pixel rendering worked best for me. If compiled with +moznoxf the fonts in firefox were basic, and the sub-pixel rendering 'fattened out' the antialiased fonts making them more pleasing on the eye.
Back to top
View user's profile Send private message
Bash[DevNull]
Guru
Guru


Joined: 10 Oct 2003
Posts: 333

PostPosted: Thu Jul 01, 2004 12:26 am    Post subject: Reply with quote

Tun wrote:

I never realised firefox could look like this, it's a lot more impressive than it was under XFree and I can now use artwiz fonts with fluxbox which I'd failed at before.


IMHO nothing seriously was changed in font from XFree-4.3 to Xorg
_________________
Biomechanical Artificial Sabotage Humanoid
Back to top
View user's profile Send private message
paperp
Guru
Guru


Joined: 27 Feb 2004
Posts: 544
Location: Toscana , Italy

PostPosted: Thu Jul 01, 2004 7:11 am    Post subject: Reply with quote

First of all thanks a lot for this guide.I got this errorand I 'm not able to get ananswer on myself why says .."have been masked ..2 if i use ACCEPT_KEYWORDS="~x86???

Code:

root@killertux emanuele # ACCEPT_KEYWORDS="~x86" emerge sharefonts
Calculating dependencies
!!! all ebuilds that could satisfy "sharefonts" have been masked.
!!! possible candidates are:
- media-fonts/sharefonts-0.10-r1 (masked by: missing keyword)
- media-fonts/sharefonts-0.10-r2 (masked by: missing keyword)
- media-fonts/sharefonts-0.10-r3 (masked by: missing keyword)

!!! Error calculating dependencies. Please correct.
root@killertux emanuele # emerge media-fonts/sharefonts
Calculating dependencies
!!! all ebuilds that could satisfy "media-fonts/sharefonts" have been masked.
!!! possible candidates are:
- media-fonts/sharefonts-0.10-r1 (masked by: missing keyword)
- media-fonts/sharefonts-0.10-r2 (masked by: missing keyword)
- media-fonts/sharefonts-0.10-r3 (masked by: missing keyword)

!!! Error calculating dependencies. Please correct.


Thanks in advance.
Back to top
View user's profile Send private message
Tun
n00b
n00b


Joined: 19 Jan 2004
Posts: 58
Location: Stockport, England

PostPosted: Thu Jul 01, 2004 9:40 pm    Post subject: Reply with quote

Bash[DevNull] wrote:
Tun wrote:

I never realised firefox could look like this, it's a lot more impressive than it was under XFree and I can now use artwiz fonts with fluxbox which I'd failed at before.


IMHO nothing seriously was changed in font from XFree-4.3 to Xorg


I think you're right. The difference I can see probably comes down to my laziness in correctly configuring my original xfree install.
Back to top
View user's profile Send private message
Tun
n00b
n00b


Joined: 19 Jan 2004
Posts: 58
Location: Stockport, England

PostPosted: Thu Jul 01, 2004 10:03 pm    Post subject: Reply with quote

paperp wrote:
First of all thanks a lot for this guide.I got this errorand I 'm not able to get ananswer on myself why says .."have been masked ..2 if i use ACCEPT_KEYWORDS="~x86???
...
Thanks in advance.


I'm no portage expert, but I'll try. On my box

Code:

plato sharefonts # emerge -pv sharefonts
These are the packages that I would merge, in order:
Calculating dependencies ...done!
[ebuild   R   ] media-fonts/sharefonts-0.10-r1   0 kB
Total size of downloads: 0 kB
 

Which is as you'd expect so taking a look at the ebuilds in /usr/portage/media-fonts/sharefonts

Code:

plato sharefonts # find .  |  xargs grep -H KEYWORDS
./sharefonts-0.10-r1.ebuild:KEYWORDS="x86 sparc ppc amd64"
./ChangeLog:  Added LICENSE, KEYWORDS, SLOT.
./sharefonts-0.10-r2.ebuild:KEYWORDS="~x86 ~sparc ~ppc ~amd64"
./sharefonts-0.10-r3.ebuild:KEYWORDS="~x86 ~sparc ~ppc ~amd64"


How do your ebuilds match up to mine?

If I were you I'd emerge sync and try again. Then failing that take a look at /usr/portage/package.mask and /usr/portage/profiles/package.mask

Like I said I'm no expert and there is probably better advice out there, but it's not here yet so hopefully this is a step in the right direction
Back to top
View user's profile Send private message
thinair
Tux's lil' helper
Tux's lil' helper


Joined: 01 Nov 2002
Posts: 144
Location: Suisse

PostPosted: Fri Jul 02, 2004 3:15 pm    Post subject: Reply with quote

I dont understand what is the difference between :

Code:

Bitstream Vera Serif

and

bitstream-bitstream vera serif-iso8859-15


I follow this guide, but I only have bitstream-bitstream fonts...
Bitstream are not in firefox menu... and antialiasing is not working in firefox 0.9.1

why ?

thx in advance
_________________
http://www.gentoofr.org
Le site francophone de GNU/Linux Gentoo
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Fri Jul 02, 2004 9:39 pm    Post subject: Reply with quote

Hi all.
I'm back from my holidays and now I can give some answers, but first I want to thank you all for your support :)

torklingberg wrote:
media-fonts/corefonts is masked. Nothing to worry about or?


Yes, this isn't a problem. I'll add a note regarding this masking, I forgot it.

torklingberg wrote:
I had two issues with the HOWTO:

1. artwiz changed my mouse cursor. Moving FontPath "/usr/share/fonts/artwiz/" to the end of the list fixed that.

2. running "/etc/init.d/xdm stop" from within X made my computer freeze completely.


I'll add other notes for this, thank you.

BlindSpy wrote:
ISSUES:

1. I've did the 0.9 guide and I didnt have an user.js file so I just made one. It seemed to make some fonts anti-alias but not all.


user.js doesn't exist by default in 0.9, in fact you have to create it. Have you solved your problem about anti-aliasing?

Sastraxi wrote:
From my last post, I recompiled firefox without moznoxft... and it looks amazing. Thanks a lot for the guide, but I still do recommend changing that "moznoxft" tip =)


Fonts in x sometimes make me crazy, in fact as I said without moznoxft my fonts look ugly. I'll study this when I'll return from my holiday in Scotland, at the end of July.

mark_lybarger wrote:
i tried this also to the T, but still have not so good fonts. they're probably not getting anti aliased or some such. my /var/log/Xorg.0.log file shows:


Check your font config files, first of all ~/.fonts.conf. I was stuck to this problem due to the "antialias" option.

thinair wrote:
I follow this guide, but I only have bitstream-bitstream fonts...
Bitstream are not in firefox menu... and antialiasing is not working in firefox 0.9.1

why ?

thx in advance


If you have compiled Firefox without the "moznoxft" flag you have fonts listed as "bitstream-bitstream vera serif-iso8859-15", vice versa if you use the "moznoxft" flag you have "Bitstream Vera Serif".
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
nostabo
Apprentice
Apprentice


Joined: 15 Jun 2004
Posts: 201
Location: 38° 31' N 121° 30' W

PostPosted: Sat Jul 03, 2004 5:11 am    Post subject: Reply with quote

To change the fonts when using Mozilla (1.7 at least) add the code (as suggested earlier):

Code:
// TrueType
user_pref ("font.FreeType2.enable", true);
user_pref ("font.freetype2.shared-library", "libfreetype.so.6");
// if libfreetype was built without hinting compiled in
// it is best to leave hinting off
user_pref ("font.FreeType2.autohinted", true);
user_pref ("font.FreeType2.unhinted", true);
// below a certian pixel size anti-aliased fonts produce poor results
user_pref ("font.antialias.min",        0);
user_pref ("font.embedded_bitmaps.max", 1000000);
user_pref ("font.scale.tt_bitmap.dark_text.min", 0);
user_pref ("font.scale.tt_bitmap.dark_text.gain", "0.0");
// sample user_pref s for TrueType font dirs
user_pref ("font.directory.truetype.1", "/usr/share/fonts/ttf-bitstream-vera");
user_pref ("font.directory.truetype.2", "/usr/share/fonts/TTF");
user_pref ("font.directory.truetype.3", "/usr/share/fonts/corefonts");
user_pref ("font.directory.truetype.4", "/usr/share/fonts/freetype");
user_pref ("font.FreeType2.printing", true);


to the "/usr/lib/mozilla/greprefs/all.js" file. This apparently does for Mozilla what the "~/.mozilla/firefox/default.xxx/user.js" does for Firefox.

After editing the file make the changes to the Preferences -->Appearance -->Fonts settings as noted previously. There are other font selections with Mozilla, but leaving them as is seems to be OK.

Rick B
Back to top
View user's profile Send private message
Psycam
n00b
n00b


Joined: 26 Jun 2004
Posts: 17

PostPosted: Thu Jul 29, 2004 5:04 pm    Post subject: Reply with quote

By not using -moznoxfs, the firefox 9.1 actually produced better results for me (anti-aliased menu, etc.). Just thought I'd share that.
Back to top
View user's profile Send private message
JetAce44
Apprentice
Apprentice


Joined: 02 Feb 2004
Posts: 152

PostPosted: Wed Aug 04, 2004 2:35 am    Post subject: Reply with quote

I just have to say, excellent guide, I have everything up and running with X.org now, very very painless. Thank you very much!
_________________
Tyan Tiger MPX 2466
2x AMD Athlon MP 1800+
1gig Crucial PC2100 ECC
NV 6600GT
1x 1000JB WD 100gig 8mb Cache IDE Drive
4x 2000JD WD 200gig 8mb Cache Sata Drive (Under RAID 5 on a 3ware 8506-4LP)
Registered Linux User #346685
Back to top
View user's profile Send private message
nkolia
n00b
n00b


Joined: 15 Jul 2004
Posts: 21

PostPosted: Thu Aug 05, 2004 4:05 am    Post subject: Reply with quote

If I understand this correctly then the changes made to ~/.fonts.conf can be done in /etc/fonts/local.conf to enable system-wide effects instead of a per user basis?
_________________
Nadeem Kolia
Naruto Chaos
nkolia@gmail.com
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Thu Aug 05, 2004 10:41 am    Post subject: Reply with quote

Well I have never tried but I think that's correct...
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
Boworr
n00b
n00b


Joined: 30 Jul 2004
Posts: 45
Location: England. Where the history comes from.

PostPosted: Thu Aug 05, 2004 3:03 pm    Post subject: Worked a treat... Reply with quote

Thanks! I followed this to the letter and have nice fonts to look at again.

Great work on putting this together.
Back to top
View user's profile Send private message
Boworr
n00b
n00b


Joined: 30 Jul 2004
Posts: 45
Location: England. Where the history comes from.

PostPosted: Fri Aug 06, 2004 8:30 am    Post subject: Problem with /etc/fonts/fonts.conf Reply with quote

I tried this on my home PC too and it would not work. I eventually tracked it down to my /etc/fonts/fonts.conf being empty. It had the header file information, the starting <fontconfig>, the usual warning text but then nothing else.

So if you're seeing the error below check your fonts.conf file too.
Code:
office root #  fc-cache -fv
Fontconfig error: line 26: no element found
Fontconfig error: [b]Cannot load default config file[/b]
fc-cache: "/usr/X11R6/lib/X11/fonts/Type1": caching, 29 fonts, 0 dirs
fc-cache: succeeded


I copied mine from my laptop and it worked fine after that.
Back to top
View user's profile Send private message
lagrima
Apprentice
Apprentice


Joined: 11 Feb 2004
Posts: 199
Location: Whorenge County

PostPosted: Fri Aug 06, 2004 3:26 pm    Post subject: Reply with quote

hello guys, im new at this but can you guys post what the necessary USE flags for this? for some reason i emerge the fonts and it emerges xfree also i want to use xorg omg!
_________________
"Argent fa molt, amor fa tot"
Back to top
View user's profile Send private message
lagrima
Apprentice
Apprentice


Joined: 11 Feb 2004
Posts: 199
Location: Whorenge County

PostPosted: Fri Aug 06, 2004 3:44 pm    Post subject: Reply with quote

when i do emerge -pv fonts fonts etc etc

one of the things in red is +X

would adding -X on my use flags not install xfree?
_________________
"Argent fa molt, amor fa tot"
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Fri Aug 06, 2004 9:10 pm    Post subject: Reply with quote

No, the USE flag "X" is also for x.org.
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
lagrima
Apprentice
Apprentice


Joined: 11 Feb 2004
Posts: 199
Location: Whorenge County

PostPosted: Sat Aug 07, 2004 12:48 am    Post subject: Reply with quote

i took the X off and it stopped installing xfree for my fonts oh well xorg works now it seems
_________________
"Argent fa molt, amor fa tot"
Back to top
View user's profile Send private message
nostabo
Apprentice
Apprentice


Joined: 15 Jun 2004
Posts: 201
Location: 38° 31' N 121° 30' W

PostPosted: Sat Aug 07, 2004 1:26 am    Post subject: Reply with quote

A way to stop any merging of xfree is by adding a line to your /etc/portage/package.mask file which will exclude any ebuilds that are listed within it. This approach should not block any X.org files which will allow you to do updates without worrying about that "tainted" code.

If you don't have a /etc/portage/package.mask all you need to do is:
Code:
mkdir /etc/portage  ---> this creates the directory


If you have a /etc/portage/package.mask or after you created the directory then simply issue:
Code:
echo x11-base/xfree >> /etc/portage/package.mask  ---> this creates the file (if it doesn't exist and adds the entry


or you could simply add the line "x11-base/xfree" to the file's text, on a separate line.

Note that the only ebuild blocked is the x11-base/xfree...I believe that X.org uses some source files that are xfree86 files...at least thats what I saw as I watched the merging on one system...it kinda had me worried, but all is well.
_________________
Registered Linux user number 362941
Get counted - http://counter.li.org/
Back to top
View user's profile Send private message
scruff
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2003
Posts: 142
Location: Boston, MA

PostPosted: Tue Aug 17, 2004 2:57 am    Post subject: Reply with quote

Thanks for the tutorial! Had to tweak the Firefox fonts to my liking, but otherwise it worked fine right off the bat.
_________________

AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ @ oc'd to 2.3ghz
DFI Lanparty UltraD nForce4 SLI
2x1gb Geil PC4000
GeForce 7800GT
Sound Blaster Audigy Platinum
200gb Maxtor DiamondMax 10
74gb WD Raptor 10k RPM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum