Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Mini-HOWTO] X.org & font
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
chrisaasan
n00b
n00b


Joined: 28 Apr 2004
Posts: 2
Location: Norway

PostPosted: Tue Aug 17, 2004 10:29 pm    Post subject: Reply with quote

Nice How- To, keep up the good work!
_________________
--
chris
Back to top
View user's profile Send private message
_FD_
n00b
n00b


Joined: 06 Aug 2004
Posts: 37

PostPosted: Wed Aug 25, 2004 4:08 pm    Post subject: Reply with quote

Quote:

// TrueType
user_pref ("font.FreeType2.enable", true);
user_pref ("font.freetype2.shared-library", "libfreetype.so.6");
// if libfreetype was built without hinting compiled in
// it is best to leave hinting off
user_pref ("font.FreeType2.autohinted", true);
user_pref ("font.FreeType2.unhinted", true);
// below a certian pixel size anti-aliased fonts produce poor results
user_pref ("font.antialias.min", 0);
user_pref ("font.embedded_bitmaps.max", 1000000);
user_pref ("font.scale.tt_bitmap.dark_text.min", 0);
user_pref ("font.scale.tt_bitmap.dark_text.gain", "0.0");
// sample user_pref s for TrueType font dirs
user_pref ("font.directory.truetype.1", "/usr/share/fonts/ttf-bitstream-vera");
user_pref ("font.directory.truetype.2", "/usr/share/fonts/TTF");
user_pref ("font.directory.truetype.3", "/usr/share/fonts/corefonts");
user_pref ("font.directory.truetype.4", "/usr/share/fonts/freetype");
user_pref ("font.FreeType2.printing", true);


Shouldn't the directory for font.directory.truetype.4 be something like /usr/share/fonts/freefont ?

Otherwise great guide. Thanks.
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Wed Aug 25, 2004 7:09 pm    Post subject: Reply with quote

It can be whatever you want, I think that the most important are the ttf-bitstream-vera one and the corefonts.
However, this is true, it was a typo :)
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
asph
l33t
l33t


Joined: 25 Aug 2003
Posts: 738
Location: Barcelona, Spain

PostPosted: Sat Aug 28, 2004 12:27 am    Post subject: Reply with quote

very nice, my eyes thank you :)
_________________
gentoo sex is updatedb; locate; talk; date; cd; strip; look; touch; finger; unzip; uptime; gawk; head; emerge --oneshot condom; mount; fsck; gasp; more; yes; yes; yes; more; umount; emerge -C condom; make clean; sleep
Back to top
View user's profile Send private message
Deranger
Veteran
Veteran


Joined: 26 Aug 2004
Posts: 1215

PostPosted: Sun Aug 29, 2004 7:57 pm    Post subject: Reply with quote

Hmm, I don't have ~/.fonts.conf file at all. I have only /etc/fonts/fonts.conf and it shouldn't be modified (that's commented)

Should I make it or...? Thanks in advance.
Back to top
View user's profile Send private message
ksuther
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2003
Posts: 86
Location: New York

PostPosted: Mon Aug 30, 2004 12:55 am    Post subject: Reply with quote

Oktane, you just create the ~/.fonts.conf file.

Since compiling 0.6.7.99.902/903, my fonts in most applications look about 6 points larger than they should be. It seems to be in all my gtk2 apps, as it's appearing throughout xfce4 and any g-apps I run. Does anybody know of a fix to this problem?
Back to top
View user's profile Send private message
Deranger
Veteran
Veteran


Joined: 26 Aug 2004
Posts: 1215

PostPosted: Mon Aug 30, 2004 5:36 am    Post subject: Reply with quote

ksuther wrote:
Oktane, you just create the ~/.fonts.conf file.

Since compiling 0.6.7.99.902/903, my fonts in most applications look about 6 points larger than they should be. It seems to be in all my gtk2 apps, as it's appearing throughout xfce4 and any g-apps I run. Does anybody know of a fix to this problem?

Okey, thanks.
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Mon Aug 30, 2004 7:22 am    Post subject: Reply with quote

ksuther wrote:

Since compiling 0.6.7.99.902/903, my fonts in most applications look about 6 points larger than they should be. It seems to be in all my gtk2 apps, as it's appearing throughout xfce4 and any g-apps I run. Does anybody know of a fix to this problem?


Try changing the font dimension with the command 'switch2'.
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
ksuther
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2003
Posts: 86
Location: New York

PostPosted: Mon Aug 30, 2004 1:47 pm    Post subject: Reply with quote

I remembered to use switch2 after I posted, but in Firefox I still have some weird font issues. Whenever I select some text, or hover or click links, the text on the page will shift up or down one or two pixels, and it looks really weird. I haven't had this problem previous to switching to xorg, but I remember my friend had it before in XFree 4.3. Does anybody know what would be causing this?

Thanks
Back to top
View user's profile Send private message
e2k
n00b
n00b


Joined: 30 Jul 2004
Posts: 44

PostPosted: Wed Sep 08, 2004 7:33 pm    Post subject: Reply with quote

Everything worked like a charm, but I can't seem to get the scands (ä, ö and å) working in aterm? They worked fine before, what to do?

EDIT: Doesn't work in eterm either.
Back to top
View user's profile Send private message
Ateo
Advocate
Advocate


Joined: 02 Jun 2003
Posts: 2021
Location: Republic of California

PostPosted: Fri Sep 10, 2004 6:34 pm    Post subject: Reply with quote

I'm confused.

Why does this (and other) HOWTOs make it seem so difficult to install fonts when it is a simple task? All I did to install new fonts was create a new folder (with all of my TTF fonts) into /usr/share/fonts, modified /etc/X11/xorg.conf, ran fc-cache -fv and restarted X. That was pretty much it.

Are the instructions contained within this original post of this thread really necessary?
Back to top
View user's profile Send private message
Stormy Eyes
Veteran
Veteran


Joined: 09 Apr 2003
Posts: 1064
Location: Watching God spit-shine my boots.

PostPosted: Thu Sep 16, 2004 2:44 pm    Post subject: Reply with quote

Good job on the tutorial. I've used it on all the machines running X at home and it looks fecking great!
Back to top
View user's profile Send private message
eeknay
Guru
Guru


Joined: 07 Jul 2003
Posts: 402
Location: EndOfTheRainbow

PostPosted: Sun Sep 19, 2004 4:41 pm    Post subject: Reply with quote

I'd like to say thanks, this is a great howto. :)
_________________
Linda: "The holiday season is time of celebration for most but it is also the time to remember the tragic suffering of the less fortunate."
Morbo: "Earthlings do not yet know the meaning of suffering."
Back to top
View user's profile Send private message
palsyboy
Apprentice
Apprentice


Joined: 08 Jun 2004
Posts: 262
Location: USA

PostPosted: Fri Oct 15, 2004 8:17 am    Post subject: Reply with quote

Thank you immensely, solka. You've made my day. :)
Back to top
View user's profile Send private message
ozt
Apprentice
Apprentice


Joined: 13 Dec 2002
Posts: 212
Location: Stockholm

PostPosted: Tue Oct 26, 2004 8:23 am    Post subject: Reply with quote

I've followed this howto and my fonts got much better until a couple of days ago when I started X. All fonts had become blur and bold :(, and I'm sure I haven't touched any of my configs.

Snapshot
http://members.chello.se/hajder/bold.png

help?
_________________
=:)
Back to top
View user's profile Send private message
palsyboy
Apprentice
Apprentice


Joined: 08 Jun 2004
Posts: 262
Location: USA

PostPosted: Wed Oct 27, 2004 5:53 am    Post subject: Reply with quote

ozt, I don't see any flaws whatsoever in that image. All the fonts look fine, including what you circled. Is something possibly wrong with your monitor?
Back to top
View user's profile Send private message
ozt
Apprentice
Apprentice


Joined: 13 Dec 2002
Posts: 212
Location: Stockholm

PostPosted: Wed Oct 27, 2004 8:08 am    Post subject: Reply with quote

Hmm..maybe it's my resolution :S. But the thing is that ALL my links are bold now.

Edit: I reset my monitor to factory settings and suddenly it became more pleasant to look at :). But the mystery of the bold fonts remains! :evil:
_________________
=:)
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Thu Oct 28, 2004 6:47 am    Post subject: Reply with quote

Thank You!

Now I can type my optics lab write-up using Times New Roman as required. :)

One thing though, my mouse cursor suddenly changed when I installed the fonts. Is that just an added feature? I'm not complaining though, because it looks kinda cool. 8)
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Fri Oct 29, 2004 1:03 pm    Post subject: Reply with quote

Hey all,
I'm really sorry but currently I'm busy for school so I don't have much spare time.

I'm happy to see that this HOWTO still makes people satisfied ;)

However, as torklingberg said some posts above for the cursor question you only have to move FontPath "/usr/share/fonts/artwiz/" to the end of the list.

Cheers,
solka
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
Piper Dawn
n00b
n00b


Joined: 31 Oct 2004
Posts: 6

PostPosted: Sun Oct 31, 2004 1:57 pm    Post subject: Reply with quote

I'm having troubles with fonts in Firefox; changing the prefs as suggested makes no noticeable difference, and I've compiled it with GTK2 support without the moznoxft flag.

Ideally I'd like my fonts to resemble those in ozt's screenshot, as that's essentially what they looked like on my Slackware installation.

Included is a screenshot of my own for your viewing pleasure: note the k's, v's and x's in particular.

http://tinypic.com/f8ac9

Any help would be greatly appreciated.

[edit: nevermind; I uncommented the "autohint" part of ~/.fonts.conf and now it's working perfectly.
Back to top
View user's profile Send private message
ozt
Apprentice
Apprentice


Joined: 13 Dec 2002
Posts: 212
Location: Stockholm

PostPosted: Mon Nov 01, 2004 8:57 am    Post subject: Reply with quote

Piper Dawn wrote:
I'm having troubles with fonts in Firefox; changing the prefs as suggested makes no noticeable difference, and I've compiled it with GTK2 support without the moznoxft flag.

Ideally I'd like my fonts to resemble those in ozt's screenshot, as that's essentially what they looked like on my Slackware installation.

Included is a screenshot of my own for your viewing pleasure: note the k's, v's and x's in particular.

http://tinypic.com/f8ac9

Any help would be greatly appreciated.

[edit: nevermind; I uncommented the "autohint" part of ~/.fonts.conf and now it's working perfectly.


I'm glad it worked out. But your links are not bold :(..lucky you

Edit: I just noticed that the fonts in "Welcome to Opera" (the window that pop-ups when you start Opera) are bold too. Even the text in the address bar in Opera is bold. So I guess it's something set system wide.

any ideas?
_________________
=:)
Back to top
View user's profile Send private message
Fanatic
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 173
Location: Stocktown

PostPosted: Mon Nov 15, 2004 4:40 pm    Post subject: Reply with quote

How do you enable antialiasing on Opera? I got it working on Firefox but Opera isn't antialiased :/
Back to top
View user's profile Send private message
fdavid
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2003
Posts: 82
Location: Graz, Austria, EU

PostPosted: Sun Nov 21, 2004 7:42 am    Post subject: Reply with quote

Ateo wrote:
I'm confused.

Why does this (and other) HOWTOs make it seem so difficult to install fonts when it is a simple task? All I did to install new fonts was create a new folder (with all of my TTF fonts) into /usr/share/fonts, modified /etc/X11/xorg.conf, ran fc-cache -fv and restarted X. That was pretty much it.

Are the instructions contained within this original post of this thread really necessary?


I second your opinion. Installing new fonts and editing the font paths in xorg.conf does the trick, although not completely. (My fonts got better, but not all of them, so I still don't have nice fonts everywhere.) Manipulating the fonts/local.conf does not change anything.
Back to top
View user's profile Send private message
molecularbear
n00b
n00b


Joined: 24 Mar 2004
Posts: 22

PostPosted: Sun Nov 21, 2004 7:27 pm    Post subject: Reply with quote

Wow, this font business is really a mess. I think if I want to solve my font problems I'm going to have to learn a whole lot about fonts on Linux. For example, why do we need to specify font paths for both xfs and xorg? Since xfs is the font server, isn't it just xfs that needs to know about the fonts? The X server renders fonts via xfs, correct? Obviously my understanding of this is very shallow.

I did a number of updates recently, including migrating from xfree to xorg. Following the migration, the font for Konsole, and fonts in Opera look very ugly. KDE fonts generally are okay, but I'd long ago set them all to use Luxi. I tried following the HOWTO, but it didn't get rid of my cruddy fonts. I installed all the fonts listed in the HOWTO, but it seems I am still missing a few directories. Namely:
Code:
/usr/share/fonts/CID/
/usr/share/fonts/Speedo/
/usr/share/fonts/lfp-fix/

This post seems to indicate that Speedo is deprecated.

Another problem I had is that after I added the fonts to my configs, my mouse pointer turned "weird". It turned into this odd art deco like triangular shape. I then found this post where someone had the same problem. It is apparently caused by artwiz-fonts - I removed that font from my configs and got my old mouse pointer back.
Back to top
View user's profile Send private message
fdavid
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2003
Posts: 82
Location: Graz, Austria, EU

PostPosted: Sun Nov 21, 2004 7:55 pm    Post subject: Reply with quote

molecularbear wrote:
Wow, this font business is really a mess. I think if I want to solve my font problems I'm going to have to learn a whole lot about fonts on Linux. For example, why do we need to specify font paths for both xfs and xorg? Since xfs is the font server, isn't it just xfs that needs to know about the fonts? The X server renders fonts via xfs, correct? Obviously my understanding of this is very shallow.


Either you use xfs and configure the font paths in fs/config, or you don't use it and configure the font paths in xorg.conf. If you use xfs, the one and only font path you must set in xorg.conf is "unix/:-1".

molecularbear wrote:
I did a number of updates recently, including migrating from xfree to xorg. Following the migration, the font for Konsole, and fonts in Opera look very ugly. KDE fonts generally are okay, but I'd long ago set them all to use Luxi. I tried following the HOWTO, but it didn't get rid of my cruddy fonts. I installed all the fonts listed in the HOWTO, but it seems I am still missing a few directories. Namely:
Code:
/usr/share/fonts/CID/
/usr/share/fonts/Speedo/
/usr/share/fonts/lfp-fix/

This post seems to indicate that Speedo is deprecated.

Another problem I had is that after I added the fonts to my configs, my mouse pointer turned "weird". It turned into this odd art deco like triangular shape. I then found this post where someone had the same problem. It is apparently caused by artwiz-fonts - I removed that font from my configs and got my old mouse pointer back.


I encountered exactly the same problems and found exactly the same solutions, so here we go.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum