Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with a dependency
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
japacheze
n00b
n00b


Joined: 15 Apr 2004
Posts: 2
Location: Wichita Falls, Tx

PostPosted: Sun Jun 20, 2004 5:42 pm    Post subject: Problem with a dependency Reply with quote

I've been doing a networkless install on my 12" PB. I'm using the prebuilt packages on CD 2, but neither Gnome, KDE, and a few others will emerge due to no package satisfying a dependency for glib-1.2*.

However, on the CD, there is a package for glib-2.2.3, which I have already emerged. How do I get Gnome, etc, to emerge using glib-2.2.3 to satisfy the dependency for glib-1.2 ?


Also, has anyone else experienced the fact that neither OpenOffice.org, Firefox, vim, and others are on that CD 2 ? Even though they are advertised to be there on the Gentoo store page for the PPC CD's.
Back to top
View user's profile Send private message
bin-doph
Guru
Guru


Joined: 23 May 2003
Posts: 302

PostPosted: Mon Jun 21, 2004 6:46 am    Post subject: Reply with quote

are you sure you're not mixing up glib and glibc ?
    * dev-libs/glib
    Latest version installed: 1.2.10-r5
    Size of downloaded files: 1,981 kB
    Homepage: http://www.gtk.org/
    Description: The GLib library of C routines

    * sys-libs/glibc
    Latest version installed: 2.3.2-r9
    Size of downloaded files: 15,671 kB
    Homepage: http://www.gnu.org/software/libc/libc.html
    Description: GNU libc6 (also called glibc2) C library


hth
-fe
_________________
perl -e '$_=q;4a75737420616e6f74686572205065726c204861636b65720as;;for(s;s;s;s;s;s;s;s;s;s;s;s){s;(..)s?;qq qprint chr 0x$1 and \161 ssq;excess;}'
Back to top
View user's profile Send private message
japacheze
n00b
n00b


Joined: 15 Apr 2004
Posts: 2
Location: Wichita Falls, Tx

PostPosted: Mon Jun 21, 2004 11:57 am    Post subject: Reply with quote

I'm sure.
glibc is not on the CD.

The only thing on the CD is glib-2.2.3.tbz2

:cry:
Back to top
View user's profile Send private message
__LoneStar__
n00b
n00b


Joined: 15 Oct 2004
Posts: 12
Location: Middle East

PostPosted: Fri Oct 15, 2004 6:36 am    Post subject: Reply with quote

Hello japacheze,

I had the same problem on a G3 iMac 333.
I worked around it by running:
Code:
emerge inject dev-libs/glib-1.2.10

After that all the packages emerged nicely.
Please note that injecting is generally a bad idea, and do it only if you intend to use only prebuilt packages.
_________________
Dan Elharrar
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum