Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
make aMSN and other tcl/tk apps use anti-aliased fonts
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Hum
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2005
Posts: 116
Location: Canada

PostPosted: Wed Jun 14, 2006 1:47 pm    Post subject: Reply with quote

HTS wrote:
Only the very first method with the stubs worked for me.
The ebuilds fail because of the 3.1 bash and I don't want to downgrade to 3.0... :P

A few updates though,
The link for the nightly CVS has changed and is now ftp://ftp.tcl.tk/pub/tcl/nightly-cvs/
Also, the use of stubs is deprecated and is no longer done by emerge -i <whatever>

The post should be updated with the following method:
add the stubs in /etc/make.profile/package.provided

Write what follows in the file /etc/make.profile/package.provided
Code:
dev-lang/tcl-8.4.9
dev-lang/tk-8.4.9

Cheers,
HTS

Edit: huh... aMSN lauches correctly and can use the AA fonts, however, it can't locate the TLS Module... and no matter what I do to set the path in the options I can't connect. I switched back to the Ugly fonts with tcl and tk 8.4 8O

https://forums.gentoo.org/viewtopic-t-417673-start-0.html
Back to top
View user's profile Send private message
HTS
Guru
Guru


Joined: 20 Feb 2006
Posts: 410
Location: Bristol, UK

PostPosted: Thu Jun 15, 2006 5:14 pm    Post subject: Reply with quote

Yes thanks for the link but as I said above, you need to downgrade to bash 3.1 to make this work... well I guess I'll downgrade then... Or maybe there's a patch to make the ebuilds work with the new bash?
Back to top
View user's profile Send private message
HTS
Guru
Guru


Joined: 20 Feb 2006
Posts: 410
Location: Bristol, UK

PostPosted: Thu Jun 15, 2006 5:45 pm    Post subject: Reply with quote

Ok I modified the ebuilds to make them work with bash 3.1 :P

Here are the ebuilds:
tcl-8.5.0.ebuild
tk-8.5.0.ebuild

Give me some feedback please!
Back to top
View user's profile Send private message
Alejandro Nova
n00b
n00b


Joined: 08 Sep 2004
Posts: 50

PostPosted: Sun Aug 06, 2006 10:18 pm    Post subject: Reply with quote

HTS, it seems that you forgot to write --enable-xft in your TK configure flags ;)

TK 8.5.0 ebuild:

Says:

Code:
        econf \
                --with-tcl=/usr/$(get_libdir) \
                ${local_config_use} || die


Must say:

Code:
        econf \
                --with-tcl=/usr/$(get_libdir) \
                --enable-xft ${local_config_use} || die

_________________
Becoming someone beautiful, through my music, my silent devotion...
Alejandro Nova™.
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Sun Aug 06, 2006 10:37 pm    Post subject: Reply with quote

No he didn't ;)

Since the tip, propose to run:
Code:
EXTRA_ECONF="--enable-xft" emerge -av tcl tk amsn


(and then you have the choice of enabling or not..)

If you want to add this 'flag' automaticely, then you might be interested in this post(second part)
Back to top
View user's profile Send private message
saffsd
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2006
Posts: 139

PostPosted: Thu Aug 10, 2006 11:51 am    Post subject: Reply with quote

Why not have xft as a use flag in the ebuild? Pinning EXTRA_ECONF to the front seems a bit of a hack...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum