Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound works but sounds horrible
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
JCScoobyRS
n00b
n00b


Joined: 18 Dec 2003
Posts: 57
Location: Colorado, USA

PostPosted: Wed Jun 23, 2004 4:38 am    Post subject: Sound works but sounds horrible Reply with quote

I have installed ALSA and have working sound in KDE. The issue is that there is a crackling and horrible sound quality. What information can I give someone with a good working sound to diagnose this? Thanks, Jeremy

P.S. - Here is some generic information:

kernel - 2.6.1-r1
PowerBook G4 667Mhz
256MB RAM
_________________
He who listens well, speaks well.
Back to top
View user's profile Send private message
blubbfisch
n00b
n00b


Joined: 19 Oct 2003
Posts: 55
Location: World->Pacific->New Zealand->Hamilton

PostPosted: Wed Jun 23, 2004 5:44 am    Post subject: Re: Sound works but sounds horrible Reply with quote

JCScoobyRS wrote:
I have installed ALSA and have working sound in KDE. The issue is that there is a crackling and horrible sound quality.

kernel - 2.6.1-r1


Try upgrading to latest (ie 2.6.7 atm) kernel, this should do the trick. (I use gentoo-dev-sources and am happily using usb-audio and powermac (Alu Powerbook, though)

Have fun*

Niklas
Back to top
View user's profile Send private message
JCScoobyRS
n00b
n00b


Joined: 18 Dec 2003
Posts: 57
Location: Colorado, USA

PostPosted: Wed Jun 30, 2004 3:06 am    Post subject: Reply with quote

I'm doing so as we speak. Why will this fix it? Is there anyway you can tell me your current sound configuration or kernel config? Laters, Jeremy
_________________
He who listens well, speaks well.
Back to top
View user's profile Send private message
chester_rockwell
n00b
n00b


Joined: 27 Jun 2004
Posts: 7
Location: Ohio

PostPosted: Thu Jul 01, 2004 8:12 pm    Post subject: Reply with quote

I am having a similar problem with the 2.6.7 kerel installed. Whenever I adjust the volume in Kmixer the audio crackles. What are possible problems that could cause this?

Thanks,

Chester
Back to top
View user's profile Send private message
blubbfisch
n00b
n00b


Joined: 19 Oct 2003
Posts: 55
Location: World->Pacific->New Zealand->Hamilton

PostPosted: Thu Jul 01, 2004 11:03 pm    Post subject: Reply with quote

Well, I could post my .config, but it's a bit of no-brainer, because there's just this one option for snd-powermac.

The kernel-upgrade also upgrades the alsa-driver, that's why it helps.

There are some apps that have problems with the newer alsa on powermac, because they obviously use older calls... (jackd works just fine, whereas mplayer only works well with the oss-emulation). I don't know about kde, since I'm not using it, but I guess artsd has similar legacy-problems...

The crackling only occurs while adjusting? (That's probably the crappy sound-chip then, although mine does not crackle...)

Have fun*

Niklas
Back to top
View user's profile Send private message
JCScoobyRS
n00b
n00b


Joined: 18 Dec 2003
Posts: 57
Location: Colorado, USA

PostPosted: Sun Jul 04, 2004 12:24 am    Post subject: Reply with quote

The kernel upgrade didn't work. I would be very happy seeing your .config (Only sound related portions would suffice.). Does /etc/modules.d/alsa matter if you have ALSA built into the kernel? Also...the crackling/scratchy sounds are constant in all sounds. The only ones that don't sound bad are the little beeps but it's hard to screw those up. Anyone got any .config or help for me? It's the only portion left before this system is 100% optimal. Thanks, Jeremy
_________________
He who listens well, speaks well.
Back to top
View user's profile Send private message
JCScoobyRS
n00b
n00b


Joined: 18 Dec 2003
Posts: 57
Location: Colorado, USA

PostPosted: Sun Jul 04, 2004 9:25 pm    Post subject: Reply with quote

I've been instructed to rebuild my kernel and take out all native support for ALSA and make them all modules. Can someone confirm the need to do this? Thanks, Jeremy
_________________
He who listens well, speaks well.
Back to top
View user's profile Send private message
blubbfisch
n00b
n00b


Joined: 19 Oct 2003
Posts: 55
Location: World->Pacific->New Zealand->Hamilton

PostPosted: Sun Jul 04, 2004 10:11 pm    Post subject: Reply with quote

I tend to have sound and the likes compiled as modules. (1: you can unload them on a laptop to save energy, 2: you can maybe un-/reload them if it hangs...)

/etc/modules.d/alsa
Code:

# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsa-modules.conf-rc,v 1.1 2003/08/05 21:07:55 johnm Exp $

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
alias snd-card-0 snd-powermac
alias snd-card-1 snd-usb-audio
##  OSS/Free portion
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1
##
## ID's for easy identification
options snd-powermac id="snapper"
options snd-usb-audio id="emi",index=1

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=2


(But see my earlier post: NOT ALL apps work fine! mplayer sound ugly!)

My .config is on http://ppcconfdb.sourceforge.net/conf/PowerBook_G4_1250MHz-15.2_Aluminium/ (a bit older, but the sound stuff hasn't changed.)

Have fun*

Niklas
Back to top
View user's profile Send private message
JCScoobyRS
n00b
n00b


Joined: 18 Dec 2003
Posts: 57
Location: Colorado, USA

PostPosted: Mon Jul 05, 2004 9:23 pm    Post subject: Reply with quote

Thanks for the update. I will try this and let everyone know. Thanks, Jeremy
_________________
He who listens well, speaks well.
Back to top
View user's profile Send private message
JCScoobyRS
n00b
n00b


Joined: 18 Dec 2003
Posts: 57
Location: Colorado, USA

PostPosted: Mon Jul 05, 2004 10:15 pm    Post subject: Reply with quote

Thanks for the help but it didn't work. Same output using your kernel config and /etc/modules.d/alsa file. Got anymore ideas? Thanks, Jeremy
_________________
He who listens well, speaks well.
Back to top
View user's profile Send private message
blubbfisch
n00b
n00b


Joined: 19 Oct 2003
Posts: 55
Location: World->Pacific->New Zealand->Hamilton

PostPosted: Mon Jul 05, 2004 10:29 pm    Post subject: Reply with quote

Sorry, Jeremy, no. no more ideas.

you have checked http://ppcconfdb.sourceforge.net/?id=conf I assume? There might be machines nearer to yours than mine.

ditch kde, otherwise :-)

Have fun*

Niklas
Back to top
View user's profile Send private message
JCScoobyRS
n00b
n00b


Joined: 18 Dec 2003
Posts: 57
Location: Colorado, USA

PostPosted: Mon Jul 05, 2004 11:56 pm    Post subject: Reply with quote

If it were KDE, I'd do that but it's no matter what I play using whatever I play it with. It's got to be driver related or settings related and I don't know where to configure my settings. I've used "aplayer -f cdr xxx" and it always has 22000hz as my playback rate when I need about 41-18khz. Just wondering why this is so hard. Laters, Jeremy
_________________
He who listens well, speaks well.
Back to top
View user's profile Send private message
JCScoobyRS
n00b
n00b


Joined: 18 Dec 2003
Posts: 57
Location: Colorado, USA

PostPosted: Tue Jul 06, 2004 1:27 am    Post subject: Reply with quote

I fixed it for the most part thanks to alsamixer. Can someone post their alsa mixer settings? Thanks, Jeremy
_________________
He who listens well, speaks well.
Back to top
View user's profile Send private message
blubbfisch
n00b
n00b


Joined: 19 Oct 2003
Posts: 55
Location: World->Pacific->New Zealand->Hamilton

PostPosted: Tue Jul 06, 2004 2:48 am    Post subject: Reply with quote

Ah, mixer, good point. try setting the PCM level just below 50 and control the rest using the master fader. otherwise it gets horribly distorted...

ermm, what does "aplay mysoundfile@44.1kHz.wav" give you?

Have fun*

Niklas
Back to top
View user's profile Send private message
JCScoobyRS
n00b
n00b


Joined: 18 Dec 2003
Posts: 57
Location: Colorado, USA

PostPosted: Tue Jul 06, 2004 3:37 am    Post subject: Reply with quote

I actually have good sound coming out now thanks to alsamixer. I have adjusted some settings and it's sounding good but there are a few I don't understand so I'm asking for help in the Multimedia forum. Thanks for all the help, Jeremy
_________________
He who listens well, speaks well.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum